SSU Development thread (4.0 to 5.0) [DEVELOPMENT HALTED DUE TIME REQUIREMENTS!]

GLS

Well-known member
Orbiter Contributor
Addon Developer
Joined
Mar 22, 2008
Messages
4,560
Reaction score
784
Points
138
Guys , when I save scenario STS-1 in SSU then load again i got weird texture can you fix it guys ?
More information is needed:
which texture (and mesh)?
scenario?
anything in the log?
only sts-1 or all scenarios?
what are you running? (SSU, Orbiter, graphics engine)
 

asdad

Member
Joined
Feb 25, 2015
Messages
138
Reaction score
2
Points
18
Location
South of Tangerang
OfOqr6A.png
 
Last edited:

GLS

Well-known member
Orbiter Contributor
Addon Developer
Joined
Mar 22, 2008
Messages
4,560
Reaction score
784
Points
138
(ok, now I can see the image)
That seems to be the OV mesh... that happens in all the scenarios, right?
Could you recompile the code, to be sure it isn't that?
 

DaveS

Space Shuttle Ultra Project co-developer
Addon Developer
Donator
Beta Tester
Joined
Feb 4, 2008
Messages
9,158
Reaction score
421
Points
173
I just checked on my end and everything is fine in the default DX7 graphics engine. No issues whatsoever.
 

GLS

Well-known member
Orbiter Contributor
Addon Developer
Joined
Mar 22, 2008
Messages
4,560
Reaction score
784
Points
138
I just checked on my end and everything is fine in the default DX7 graphics engine. No issues whatsoever.

It works on my end as well, but that doesn't mean there is nothing wrong with the mesh. :shrug:
 

STS

Active member
Joined
Feb 1, 2009
Messages
418
Reaction score
31
Points
43
Location
Vigo
Website
orbisondas.es
This happened to me on the past, but not with SSU.


If I recall correctly, it was a scenario issue, an attachment issue or a missing texture.
I dont remember very well, but it was one of those three things.
 

DaveS

Space Shuttle Ultra Project co-developer
Addon Developer
Donator
Beta Tester
Joined
Feb 4, 2008
Messages
9,158
Reaction score
421
Points
173
This happened to me on the past, but not with SSU.


If I recall correctly, it was a scenario issue, an attachment issue or a missing texture.
I dont remember very well, but it was one of those three things.
Now that you mention it, I've seen this before with incorrectly calculated DIR and ROT vectors for docking ports and attachment points. This causes the object with the incorrect vectors to look exactly like in that screenshot. So this explains why neither GLS or I are seeing this, we don't have the object that is causing this. So I'd label this "user error".
 

STS

Active member
Joined
Feb 1, 2009
Messages
418
Reaction score
31
Points
43
Location
Vigo
Website
orbisondas.es
Now that you mention it, I've seen this before with incorrectly calculated DIR and ROT vectors for docking ports and attachment points. This causes the object with the incorrect vectors to look exactly like in that screenshot. So this explains why neither GLS or I are seeing this, we don't have the object that is causing this. So I'd label this "user error".
Wrong docking port orientation on custom payload. Yes, that was it!
 

asdad

Member
Joined
Feb 25, 2015
Messages
138
Reaction score
2
Points
18
Location
South of Tangerang
Guys , I have question about Panel R2.cpp it says: pAPUOperate->ConnectPort(2, pBundle, 0); // temporary; THIS IS NOT CORRECT what does mean ?
 

GLS

Well-known member
Orbiter Contributor
Addon Developer
Joined
Mar 22, 2008
Messages
4,560
Reaction score
784
Points
138
Guys , I have question about Panel R2.cpp it says: pAPUOperate->ConnectPort(2, pBundle, 0); // temporary; THIS IS NOT CORRECT what does mean ?


It means exactly that: the switch is not correctly wired, as it connects both the Start and Injector Cool positions to the same "wire", so they end up doing the same. Bottom line: the APUs are not fully simulated. :shrug:
 

GLS

Well-known member
Orbiter Contributor
Addon Developer
Joined
Mar 22, 2008
Messages
4,560
Reaction score
784
Points
138
ok, so you mean the APUs are not fully simulated like APU Auto Shutdown right ?

Yes, and when the panel was coded that simplification was made.
 

Urwumpe

Not funny anymore
Addon Developer
Donator
Joined
Feb 6, 2008
Messages
36,404
Reaction score
870
Points
203
Location
Langendernbach
Yes, and when the panel was coded that simplification was made.


Also the cables had been assumed inaccurate since we lacked the technical documentation back then that we have now. Today we can even tell that it is not to spec.
 

GLS

Well-known member
Orbiter Contributor
Addon Developer
Joined
Mar 22, 2008
Messages
4,560
Reaction score
784
Points
138
Also the cables had been assumed inaccurate since we lacked the technical documentation back then that we have now. Today we can even tell that it is not to spec.

Plus, I'm pretty sure the switch changed functionality at some point. :shrug:
 

GLS

Well-known member
Orbiter Contributor
Addon Developer
Joined
Mar 22, 2008
Messages
4,560
Reaction score
784
Points
138

GLS

Well-known member
Orbiter Contributor
Addon Developer
Joined
Mar 22, 2008
Messages
4,560
Reaction score
784
Points
138
About 1 year ago I finished most of the entry upgrades needed for SSU to run in Orbiter 2016. Since then a big chunk of my work in SSU was dedicated to help fixing the 1001 problems in the meshes and textures (most of them exist for several years now) so a release could finally be made, the first for Orbiter 2016 and the first since SSU 4.2 in late 2016, I think.
Sadly not all horses are pulling in that direction. There appears to be little interest in fixing long standing issues and more interest in reflections, handrails and unneeded expensive detail. This was always a project where one did something that he/she liked, but when after several years the simple basics aren't working, and the graphics are nowhere near a releasable state... something is wrong. The project should not only be for the devs personal "pleasure" but also for the community, and the progress in the last year has brought me little "pleasure" and nothing was given to the community.
And so I simply cannot continue in SSU... :(

This decision was maybe 95% done some months ago, and I was just waiting to confirm the course of things. Today the course revealed itself to be: a brand new ODS/ExtAL mesh, I think the second one in maybe 3 or 4 years... meanwhile the Orbiter mesh maintains its problems... :uhh:


But because I really want an "advanced" shuttle simulation to be available for Orbiter, I will fork SSU and continue on my own (after I come up with a new name :facepalm:). Help is of course appreciated and needed. The first task in the list is to fix the main mesh to enable a release. Although my graphics skills aren't huge, I'll use them to fix the problems. This means that a release it will take some time, but at least there will be one to look forward to. :shrug:
After this initial bump things should be much smoother: I've done some code work (offline, as I already expected this to happen), so subsequent releases with new features should follow in a small timeframe. Eventually I'll open a thread for updates.
 
Top