Small Bug with XR Fleet vessels on Orbiter Beta R90

yitianetie

Member
Joined
Mar 24, 2020
Messages
48
Reaction score
14
Points
23
Location
Brittany
Hi,

I really enjoy the XR fleet vessels and I really hope that EVA functionalities will be enabled in a near feature (Does someone have some recent news since last december about oMMU project ?).

Currently, I use Orbiter Beta R90 since it is recommanded for using NASSP 8. But after loading an XR fleet scenario like "Ready to take off for ISS", I get an odd behaviour of the vessel. Instead of appearing flat on the runway or on the launchpad, it is partly lying down in the mesh terrain.
https://drive.google.com/open?id=1QDoEMsyLrKpG2L8TyjzDxzH1ZQAz7nSH
https://drive.google.com/open?id=1rbWwoMpiCHpvRuKuQLTKv1F05X9bkwXQ

And this behaviour has been found every time I try to load a scenario with XR1,XR2 or XR5 landed on a surface (runways and launchpad on celestial bodies). However, every other spacecrafts or rockets supposed to work on Orbiter 2016 run well. I have tried several third parties rockets from addons like CSG Kourou or Pad24_UR500 from Pappy's Hangar and I don't see any major aberation, except for the MultistageMFD which generates CTD)

Of course, these 3 XR vessels seem to fly without problem. I have loaded another scenario while docking at ISS and I have not found any aberation (the docking functions and MFDs work properly).

Moreover, this bug is only related with vessels that already exist in the scenerio while loading it. If I try to add another XR spacecraft on another launchpad with the Scenario Editor, it is well positionned on the surface, until I close the simulation. If you load the scene again (the last current state or the same scenario), the bug appears again and you have to reset the position of the XR vessels with scenario editor. It is a small pain to do that for every XR spacecraft (expecially if you have several ones) after every loading of the scene.

Below, it is the log from orbiter Beta after loading the scenario "Ready to take off for ISS" with XR1 :

000000.000:
000000.000: **** Creating simulation session
000000.000: D3D9: [DirectX 9 Initialized]
000000.000: D3D9: 3D-Adapter.............. : NVIDIA GeForce GTX 950M
000000.000: D3D9: MaxTextureWidth......... : 16384
000000.000: D3D9: MaxTextureHeight........ : 16384
000000.000: D3D9: MaxTextureRepeat........ : 8192
000000.000: D3D9: VolTexAddressCaps....... : 0x3F
000000.000: D3D9: NumSimultaneousRTs...... : 4
000000.000: D3D9: VertexDeclCaps.......... : 0x30F
000000.000: D3D9: MiscCaps................ : 0x2FCEF2
000000.000: D3D9: XNA Math Support........ : Yes
000000.000: D3D9: Vertex Texture.......... : Yes
000000.000: D3D9: Shadow Mapping.......... : Yes
000000.000: D3D9: D3DFMT_A16B16G16R16F.... : Yes
000000.000: D3D9: D3DFMT_A32B32G32R32F.... : Yes
000000.000: D3D9: D3DFMT_D32F_LOCKABLE.... : Yes
000000.000: D3D9: D3DFMT_A2R10G10B10...... : Yes
000000.000: D3D9: D3DFMT_L8............... : Yes
000000.000: D3D9: D3DDTCAPS_DEC3N......... : No
000000.000: D3D9: D3DDTCAPS_FLOAT16_2..... : Yes
000000.000: D3D9: D3DDTCAPS_FLOAT16_4..... : Yes
000000.000: D3D9: Runs under WINE......... : No
000000.000: D3D9: Available Texture Memory : 4088 MB
000000.000: D3D9: [3DDevice Initialized]
000000.000: D3D9: [Loading Constellations]
000000.000: D3D9: [D3D9Client Initialized]
000000.000: Module Sun.dll ............... [Build 190914, API 190914]
000000.000: VSOP87(E) Sun: Precision 1.0e-06, Terms 554/6634
000000.000: Module Mercury.dll ........... [Build 190914, API 190914]
000000.000: VSOP87(B) Mercury: Precision 1.0e-05, Terms 167/7123
000000.000: Module Venus.dll ............. [Build 190914, API 190914]
000000.000: Module VenusAtm2006.dll ...... [Build 190914, API 190914]
000000.000: VSOP87(B) Venus: Precision 1.0e-05, Terms 79/1710
000000.000: Module Earth.dll ............. [Build 190914, API 190914]
000000.000: Module EarthAtmJ71G.dll ...... [Build 190914, API 190914]
000000.000: VSOP87(B) Earth: Precision 1.0e-08, Terms 2564/2564
000000.000: Module Moon.dll .............. [Build 190914, API 190914]
000000.000: ELP82: Precision 1.0e-05, Terms 116/829
000000.000: Module Mars.dll .............. [Build 190914, API 190914]
000000.000: Module MarsAtm2006.dll ....... [Build 190914, API 190914]
000000.000: VSOP87(B) Mars: Precision 1.0e-05, Terms 405/6400
000000.000: Module Phobos.dll ............ [Build ******, API 060425]
000000.000: Module Deimos.dll ............ [Build ******, API 060425]
000000.000: Module Galsat.dll ............ [Build 190914, API 190914]
000000.000: Module Jupiter.dll ........... [Build 190914, API 190914]
000000.000: VSOP87(B) Jupiter: Precision 1.0e-06, Terms 1624/3625
000000.000: Module Io.dll ................ [Build 190914, API 190914]
000000.000: Module Europa.dll ............ [Build 190914, API 190914]
000000.000: Module Ganymede.dll .......... [Build 190914, API 190914]
000000.000: Module Callisto.dll .......... [Build 190914, API 190914]
000000.000: Module Satsat.dll ............ [Build 190914, API 190914]
000000.000: Module Saturn.dll ............ [Build 190914, API 190914]
000000.000: VSOP87(B) Saturn: Precision 1.0e-06, Terms 2904/6365
000000.000: Module Mimas.dll ............. [Build 190914, API 190914]
000000.000: SATSAT Mimas: Terms 113
000000.000: Module Enceladus.dll ......... [Build 190914, API 190914]
000000.000: SATSAT Enceladus: Terms 33
000000.000: Module Tethys.dll ............ [Build 190914, API 190914]
000000.000: SATSAT Tethys: Terms 101
000000.000: Module Dione.dll ............. [Build 190914, API 190914]
000000.000: SATSAT Dione: Terms 59
000000.000: Module Rhea.dll .............. [Build 190914, API 190914]
000000.000: SATSAT Rhea: Terms 68
000000.000: Module Titan.dll ............. [Build 190914, API 190914]
000000.000: SATSAT Titan: Terms 100
000000.000: Module Iapetus.dll ........... [Build 190914, API 190914]
000000.000: SATSAT Iapetus: Terms 605
000000.000: Module Uranus.dll ............ [Build 190914, API 190914]
000000.000: VSOP87(B) Uranus: Precision 1.0e-06, Terms 1827/5269
000000.000: Module Miranda.dll ........... [Build ******, API 060425]
000000.000: Module Ariel.dll ............. [Build ******, API 060425]
000000.000: Module Umbriel.dll ........... [Build ******, API 060425]
000000.000: Module Titania.dll ........... [Build ******, API 060425]
000000.000: Module Oberon.dll ............ [Build ******, API 060425]
000000.000: Module Neptune.dll ........... [Build 190914, API 190914]
000000.000: VSOP87(B) Neptune: Precision 1.0e-06, Terms 391/2024
000000.000: Finished initialising world
000000.000: Module DeltaGliderXR1.dll .... [Build 180220, API 160828]
000000.000: Module ShuttleA.dll .......... [Build 190914, API 190914]
000000.000: Module ShuttlePB.dll ......... [Build 190914, API 190914]
000000.000: Module DeltaGlider.dll ....... [Build 190914, API 190914]
000000.000: Module LuaInline.dll ......... [Build 190914, API 190914]
000000.000: Finished initialising status
000000.000: Finished initialising camera
000000.000: Finished setting up render state
000000.000: D3D9: [Scene Initialized]
000000.000: XRSound 1.10 (Build Date: Mar 9 2018) initialized using sound driver DirectSound8; irrKlang version = 1.6.0. XRSound UpdateInterval = 0.050 (20.0 updates per second)
000000.000: ---------------------------------------------------------------
000000.000: >>> WARNING: Obsolete API function used: oapiBlt
000000.000: Colour key argument not supported by graphics client
000000.000: ---------------------------------------------------------------
000000.000: Finished initialising panels
000009.995: D3D9: [Session Closed. Scene deleted.]
000009.995: D3D9: [Destroy Render Window Called]
000009.995: XRSound 1.10 (Build Date: Mar 9 2018) terminating.
000009.995: **** Closing simulation session


I will add another thing : the bug appears on both graphic versions of Orbiter Beta, so the D3D9 client is not the source of the problem. I would like to point out the obsolete api version. Do you think that it could be related that I try to describe above ? But I don't think so...

Warmest regards,
Etienne

---------- Post added 04-12-20 at 03:53 PM ---------- Previous post was 04-11-20 at 05:36 PM ----------

I think that the bug is more related to XR fleet addons than Orbiter Beta. I ask administrators to change the location of this topic if I am not wrong.

Kind regards.
 
Last edited:

Abloheet

Addon Developer
Addon Developer
Joined
Apr 18, 2009
Messages
197
Reaction score
16
Points
33
Location
Kolkata,West Bengal
True. This issue has to be posted in the XR Fleet add-ons thread. But I am not an admin, so I can't shift this thread.

I have also noticed this bug. It happens when the status of the XR Vessel goes to landed (at rest), from being dynamic when the vessel status is being actively updated when in motion.

When the vessel state is dynamic, there is no bug. All features work as expected. When it returns to the landed at rest static status, the vessel is jutting out from the terrain at an angle. This behaviour happens only in the latest orbiter beta, not in 2016 release.

For example, I can land and then roll out and taxi in the runway just fine. When the vessel rolls to a stop, it returns to the static state when the parking brake gets engaged, and the issue occurs.
 

yitianetie

Member
Joined
Mar 24, 2020
Messages
48
Reaction score
14
Points
23
Location
Brittany
Thanks for confirming the bug. I have sent a message to dbeachy1 who is both an administrator and one of this mod developers.
 

aldarion

Member
Joined
Oct 20, 2007
Messages
46
Reaction score
0
Points
6
Location
Gdansk
Any updates?
Is this bug solved? Or do we have at least any more permanent workaround?
 

dbeachy1

O-F Administrator
Administrator
Orbiter Contributor
Addon Developer
Donator
Beta Tester
Joined
Jan 14, 2008
Messages
9,163
Reaction score
1,496
Points
203
Location
VA
Website
alteaaerospace.com
Preferred Pronouns
He/Him
This is due to different behavior between Orbiter 2016 (for which the XR vessels were built) and the Orbiter beta. See this post for an easy workaround.

tl;dr: set this in your XR vessel's .cfg file:

Code:
EnableParkingBrakes = 0
 
Top