Software Shuttle Fleet Addon Install with all the trimmings...

Slaintemaith

Old Timer
Joined
Jul 5, 2011
Messages
76
Reaction score
0
Points
0
Is there a known way to get the old Shuttle Fleet working with any version of Orbiter with all the happy addons, including but not limited to:

  • D3D9 Client
  • AutoFCS (with bases visible in the drop-down box--the best I've managed is a truncated list where I can't see what base is which)
  • Edwards AFB and KSC Launch facilities (preferably Slats)
  • STS Payloads
  • STS Guidance MFD
  • Orbit Targeting MFD
  • ...I think that's it.

I -think- I have all the files I need.
I've gotten things to partially work, only to have them ...not work. I've followed a couple install tutorials I've found (one translated from Japanese!) and have come close--although AutoFCS will show the bases/runways, I cannot tell which is which... so that's out as well.

Anyone familiar with this process that can step me through it?
I used to be able to do this stuff in my sleep. Hacked config files, the whole shebang.

I just forget how anymore. Been too long.

Thanks to any brave souls who respond.
 
Last edited:

Marg

Member
Joined
Mar 20, 2008
Messages
371
Reaction score
14
Points
18
All I can say, I do not use Shuttle Fleet, because as I remember, it is not updated to Orbiter 2016. Problem is with touchdown points, which have to defined in a different way (I think so).
I "created" working shuttle using amazing multistage 2015 add-on by fred18.
At first, I just played like with a toy, not thinking seriously, but now I created quite realistic missions, using meshes from Shuttle Fleet, SSU, STS_payload and other addons. Even more - what is exciting - I even created missions with specific looking ET's and SRB's, because .ini files allow to define meshes, masses and some other parameters. For example, STS-3 external tank was the first rust colored, but... cable trays were white (as well as in STS-4 and STS-5). Since 1983 it was not like this anymore. Or take solid rocket boosters - frustrum\skirt areas were white, without black band on the left SRB. Since Discovery's first flight in 1984 that changed...
And hutchison's recently published LC39 pads are amazing. I figured out TIMER parameter there.
Also I even got IUS stage + TDRS with predeployment tilting possibility.
I made it with a struggle, borrowing astronaut EMU from some addon with robotic arm feature (knees, elbows, hands were able to change angles).
 

Slaintemaith

Old Timer
Joined
Jul 5, 2011
Messages
76
Reaction score
0
Points
0
I'm using the 2010 version of Orbiter for the shuttle fleet stuff.
I found out about the touchdown points with the 2016 version using the Delta Glider IV. Crashes whenever you touch where it thinks the ground is.
Yay.

You know, I've played with this sim since 2002.
I've forgotten too much about it, and Kerbal has made me stupid.

---------- Post added 01-17-17 at 02:02 AM ---------- Previous post was 01-16-17 at 06:52 PM ----------

Nevermind. It's just too unstable on modern machines. 2016 is loading, working, crashing, then crashing to desktop any time I load it unless I reboot.
Screw it.
2010 is even less stable.
Orbiter has had its day.
 
Last edited:

Face

Addon Developer
Addon Developer
Beta Tester
Joined
Mar 18, 2008
Messages
4,153
Reaction score
94
Points
73
Location
Vienna
Nevermind. It's just too unstable on modern machines. 2016 is loading, working, crashing, then crashing to desktop any time I load it unless I reboot.
Screw it.
2010 is even less stable.

I don't know what hardware you use, but on everything I have tried, Orbiter 2010 and 2016 both run stable. It seems like you mistake Shuttlefleet for Orbiter as a whole. Just because one set of addons is unstable doesn't mean the whole system to be so.

Your rant at post 3 of a help request topic is showing a very impatient mind. Given that you are one of the louder fans of David413's work, I guess I can now understand why he is not that keen on updating Shuttlefleet.

In that light, I'd say you work against your own interest here.
 

Slaintemaith

Old Timer
Joined
Jul 5, 2011
Messages
76
Reaction score
0
Points
0
I don't know what hardware you use
An Origin Eon 17 SLX with a GeForce GTX 980M.

Orbiter 2010 and 2016 both run stable.
While I don't doubt this in your case, there are issues getting it to run out-of-the-box on my machine, since, without the DX9 client, it drops dead trying to run in my native resolution of 3840x2160. So I have to disagree with you there.

It seems like you mistake Shuttlefleet for Orbiter as a whole. Just because one set of addons is unstable doesn't mean the whole system to be so.
I've been using Orbiter since 2002. Back when the Earth was literally a green/blue ball without any landmarks at all. I know the difference between the program itself and add-ons.

Your rant at post 3 of a help request topic is showing a very impatient mind.
No, just a very annoyed one, as I've spent the past few weeks trying to get this (two separate installs) to run in a stable fashion all the while doing the things I want. Never mind that my 3D printer broke yesterday and another program I had high hopes for wouldn't even install on my computer.

Given that you are one of the louder fans of David413's work, I guess I can now understand why he is not that keen on updating Shuttlefleet.
I have no idea what this means or what you mean by it? I don't think it matters regardless.

In that light, I'd say you work against your own interest here.
What is my interest? I'm fed up with trying, so I'm done. How does this work against my own lack of interest in messing with it anymore? *Boggles*
 
Last edited:

PhantomCruiser

Wanderer
Moderator
Tutorial Publisher
Joined
Jan 23, 2009
Messages
5,495
Reaction score
20
Points
113
Location
Cleveland
Orbiter 2010 is less stable? Most of us had the Shuttle Fleet working flawlessly with 2010. In addition to AutoFCS along with most of what is on your list.

Given that Orbiter 2016 is still quite new I can see some (OK many) things not running with it, that's why I haven't shifted all my stuff over yet. But I don't get the 2010 less stable bit. :shrug:
 

Urwumpe

Not funny anymore
Addon Developer
Donator
Joined
Feb 6, 2008
Messages
35,773
Reaction score
261
Points
173
Location
Langendernbach
Orbiter 2010 is less stable? Most of us had the Shuttle Fleet working flawlessly with 2010. In addition to AutoFCS along with most of what is on your list.

Given that Orbiter 2016 is still quite new I can see some (OK many) things not running with it, that's why I haven't shifted all my stuff over yet. But I don't get the 2010 less stable bit. :shrug:

I plan getting completely to Orbiter 2016 development when I finish the installation of my notebook... the whole Visual Studio stuff is still at home, 400 km away from my current workplace.

Yes, there are issues. But I think those will disappear faster, the more people use 2016 and develop add-ons for it.
 

Nikogori

Donator
Donator
Joined
Mar 14, 2015
Messages
149
Reaction score
14
Points
33
Location
Osaka
Website
orbinaut.blogspot.com
I believe you should use JSGME to install/uninstall mods. JSGME is a simple tool...It just overwrites existing files with mod files. But it helps me a lot to find out what causes the problem.
 

Slaintemaith

Old Timer
Joined
Jul 5, 2011
Messages
76
Reaction score
0
Points
0
Orbiter 2010 is less stable? Most of us had the Shuttle Fleet working flawlessly with 2010. In addition to AutoFCS along with most of what is on your list.

Given that Orbiter 2016 is still quite new I can see some (OK many) things not running with it, that's why I haven't shifted all my stuff over yet. But I don't get the 2010 less stable bit. :shrug:

I too had the entire shuttle fleet working with all those addons. On a different computer. In 2006. Hell, if you can reproduce that, awesome! Zip up the directory and let me download it! Problem solved!
On my current machine of 2017, however, and as I don't have a procedure list for what order to install the Shuttle Fleet and related addons, it is far less stable/functional, since, although readme files and documentation do say how the individual addons work, they tend not to say anything about order of installation or what files overwrite others or which versions are required. (and where)
2010 might be very stable (were it, again, not for the insta-crash I get trying to run in my native resolution without the DX9 client) but for the things I wanted to do with my specific install--it's very much the opposite of that.

---------- Post added at 03:26 PM ---------- Previous post was at 03:24 PM ----------

I believe you should use JSGME to install/uninstall mods. JSGME is a simple tool...It just overwrites existing files with mod files. But it helps me a lot to find out what causes the problem.

I'm familiar with JSME--used it for the venerable Silent Hunter series... Maybe I'll do that when I feel like messing with it again in a few years. =)
 
Last edited:

Face

Addon Developer
Addon Developer
Beta Tester
Joined
Mar 18, 2008
Messages
4,153
Reaction score
94
Points
73
Location
Vienna
What is my interest? I'm fed up with trying, so I'm done. How does this work against my own lack of interest in messing with it anymore? *Boggles*

Well, your interest is to get a question answered, right? "Is there a known way to get the old Shuttle Fleet working with any version of Orbiter with all the happy addons...?" That was your very own topic post.

Then proclaiming that Orbiter is oh so unstable and you are fed up with trying will not exactly convince people in even trying to answer that question.

You see, it works for most, but not for you. Those who are still interested in answering your question will have to work with YOU on the subject in order to fix it for YOU. YOU are supposed to try things out that people might suggest. But hey, if you are fed up already, anyway, why even suggest something? To get your angry rant back? Doesn't make sense, now does it?

But another question: did you try to contact David413 through DanSteph's forums already? Being the author, he might have better suggestions. I see you already did that. It will be interesting to see if, when, and how David responds to it.
 
Last edited:

Slaintemaith

Old Timer
Joined
Jul 5, 2011
Messages
76
Reaction score
0
Points
0
You're confusing present tense with past tense.
I wanted a question answered.
I really don't care so much anymore. To the point where I'm not even going to bother finishing this sente
 

Face

Addon Developer
Addon Developer
Beta Tester
Joined
Mar 18, 2008
Messages
4,153
Reaction score
94
Points
73
Location
Vienna
You're confusing present tense with past tense.
I wanted a question answered.
I really don't care so much anymore. To the point where I'm not even going to bother finishing this sente

And so much for impatience: question posted on 15-01-17 19:35, "don't care" on 17-01-17 03:02.

And hurray for a lame joke. :thumbup:
 

Marpilot

New member
Joined
May 6, 2020
Messages
37
Reaction score
0
Points
0
Hello,
now we have 2020 may :)
Does anybody know how to instal Shuttle Fleet 4.8 on clean Orbiter 2016 so all the scenarios open and don't crash?
A list of needed add-ons woulb be very appraciated.
And what to overite or not.
Thank you very much :)
 

Abloheet

Addon Developer
Addon Developer
Joined
Apr 18, 2009
Messages
179
Reaction score
5
Points
33
Location
Kolkata,West Bengal
2010 might be very stable (were it, again, not for the insta-crash I get trying to run in my native resolution without the DX9 client) but for the things I wanted to do with my specific install--it's very much the opposite of that

Then I guess you don't know that the default dx7 client doesn't support resolutions above 2048*1536. If you try 2160p using the default graphics, then it will insta crash, like you say

That's why the dx9 client was developed, to bring orbiter graphics support upto the modern age. It's still not complete, a work in progress, but miles better than dx7 could ever be.

Dx7 itself is not fully and properly supported in modern os like windows 7 and above.
It's a legacy api, which doesn't run fully optimised and stably after windows Vista.

That's why, you will see dx9 orbiter running at much higher fps than dx7 orbiter, even with more eye candy and higher resolutions, with the same graphics hardware.

And orbiter is mostly cpu single thread speed limited.

So please know the complete picture, before assuming
 
Top