problems with add-on installs

kennyak47bass

New member
Joined
Nov 29, 2018
Messages
4
Reaction score
0
Points
0
hello anyone/everyone....totally new here....i have tried using a native file unzipper...i have tried using 7zip...i have unzipped addons into a separate folder and gonr thru each one looking to see that (examole) config. files go where they are supposed to....the default ships and scenarios work just fine....i am posting a copy of my "orbiter.log" file, which shows a particular cofig file as 'missing'.....i found a file with that name and put it where i thought it belongs, but all i get is a fatal error message, then the program terminates....any ideas would be appreciated highly THANKS!

**** Orbiter.log
000000.000: Build Aug 28 2016 [v.160828]
000000.000: Timer precision: 4.63768e-007 sec
000000.000: Found 0 joystick(s)
000000.000: Devices enumerated: 6
000000.000: Devices accepted: 5
000000.000: [ ] RGB Emulation (SW)
000000.000: [ ] Direct3D HAL (HW)
000000.000: [x] Direct3D T&L HAL (HW)
000000.000: [ ] Direct3D HAL (Intel(R) UHD Graphics 620) (HW)
000000.000: [x] Direct3D T&L HAL (Intel(R) UHD Graphics 620) (HW)
000000.000: Module AtlantisConfig.dll .... [Build 160828, API 160828]
000000.000: Module AtmConfig.dll ......... [Build 160828, API 160828]
000000.000: Module DGConfigurator.dll .... [Build 160828, API 160828]
000000.000:
000000.000: **** Creating simulation session
000000.000: DirectDraw interface OK
000000.000: Direct3D interface OK
000000.000: Graphics: Viewport: Window 1360 x 739 x 32
000000.000: Graphics: Hardware T&L capability: Yes
000000.000: Graphics: Z-buffer depth: 32 bit
000000.000: Graphics: Active lights supported: 8
000000.000: Loading 15382 records from star database
000000.000: ---------------------------------------------------------------
000000.000: >>> ERROR: DDraw error DDERR_BLTFASTCANTCLIP
000000.000: >>> [OrbiterGraphics::clbkBlt | .\OGraphics.cpp | 1633]
000000.000: ---------------------------------------------------------------
============================ ERROR: ===========================
While initialising solar system ProjectApollo/Sol_VirtualAGC:
>>> File not found: .\Config\ProjectApollo/Sol_VirtualAGC.cfg
[Orbiter::CreateRenderWindow | .\Orbiter.cpp | 756]
===============================================================
000000.000: >>> TERMINATING <<<
 

PhantomCruiser

Wanderer
Moderator
Tutorial Publisher
Joined
Jan 23, 2009
Messages
5,472
Reaction score
3
Points
113
Location
Cleveland
Jonesoft Generic Mod Enabler is a "must use" thing IMHO, another thing that is gaining some traction is [ame="https://www.orbithangar.com/searchid.php?ID=7213"]Orbiter Addons Manager (OAD)[/ame], but I've not tried it myself (yet)

It's really easy for a new Orbinaut to get overwhelmed by the number of addons, some of which "step" on each other and cause some incompatability issues.

What addon specifically is giving you fits?
 

bcbarnes

New member
Joined
Nov 17, 2017
Messages
58
Reaction score
0
Points
0
In addition to what PhantomCruiser suggested, I always install add-ons one at a time and verify that it works before moving on to the next one. It can be slow and painful, but it makes isolating issues much easier.
 

kennyak47bass

New member
Joined
Nov 29, 2018
Messages
4
Reaction score
0
Points
0
hi and thanks for asking...ive been trying to install all of the original nasa flights, from the mercury series thru the apollo series...the package ive tried to install first is "Project-Apollo-NAASP-V7.0"....but none of the addons have worked at all so far....i get similar messages from all of them, however, the defaults all seem to work fine....as i stated before, i have used 7zip to install each zipped package directly into the Orbiter2016 directory....after which, i tried unzipping the packages and going thru the file folders separately to install them manually....so far, no-go.....each time ive done this i started over with a clean install, including searches for any 'leftover' config files.....pretty damn frustrating, but i dont give up too easy....i really like this sim, also use flightgears sim with no problems at all.....thanks for your time!
 

garyw

O-F Administrator
Administrator
Addon Developer
Tutorial Publisher
Joined
May 14, 2008
Messages
10,416
Reaction score
14
Points
113
Location
Kent
Website
blog.gdwnet.com
ERROR: ===========================
While initialising solar system ProjectApollo/Sol_VirtualAGC:
>>> File not found: .\Config\ProjectApollo/Sol_VirtualAGC.cfg
[Orbiter::CreateRenderWindow | .\Orbiter.cpp | 756]
===============================================================
000000.000: >>> TERMINATING <<<
It helps to learn to read the errors and dig through configs. This error tells me that you have installed a custom solar system and the file "virtualagc.cfg" is missing.
When I install an add-on, I always unzip to a temp folder to check that all the folders extracted correctly. Once I've checked that, I lift and drop the whole lot in my orbiter folder.
 

kennyak47bass

New member
Joined
Nov 29, 2018
Messages
4
Reaction score
0
Points
0
thanks for answering...i have tried that, but im not really sure what would constitute a bad extraction....or what theyre supposed to be.....i did manually extract all, and looked at each folder....for instance , if there was a folder marked ;meshes' in the addon, i would use 7zip to add its contents to the meshes folder already extant in the orbiter installalled directory with that specific label....as well as all the others, match names and include......so far no go...i DID try this thing called "orbiter addons manager". couldnt make that work either (so far)....im using orbiter 2016....is it possible a lot of addons arent compatible?

---------- Post added at 12:36 AM ---------- Previous post was at 12:30 AM ----------

this addon is particularly large....inclusive of ALL the missions....should all cfg files be in the same places? as well as/or bin files? i ask because there are a LOT of these in many different folders..
 

bcbarnes

New member
Joined
Nov 17, 2017
Messages
58
Reaction score
0
Points
0
The Mercury and Gemini add-ons don't work in 2016. The newest NASSP does work, and I've been using it and having a good time.

If you have 7Zip, and it is integrated into the right click menu, you can do the following:

1) Download the ZIP file for the add on into your 'downloads' directory
2) Open a file explorer window to your 'downloads' directory. You should see the ZIP file.
3) Open a second file explorer window to your orbiter install directory. Probably something like 'C:\Orbiter2016'. You should see lots of folders (such as 'config', 'doc', 'meshes', scenarios', 'textures', etc.) Plus, you should see 'orbiter.exe' and 'orbiter_ng'.exe.
4) Right click and hold down the mouse on the ZIP file in the first explorer window.
5) Drag the mouse (stilling holding down the right button) over to the second explorer window.
6) Release the right mouse button. You should see a popup menu with a 7Zip open, and a submenu that has 'Extract Here' in it. Select 'Extract Here'.

The add-on should now be installed.
 

kennyak47bass

New member
Joined
Nov 29, 2018
Messages
4
Reaction score
0
Points
0
thanks for answering again...i have done exactly that, to the letter.....honestly dont know wtf.....BUT i'll try it again...
 

Zandy12

Add-on Developer
Donator
Joined
Nov 19, 2017
Messages
168
Reaction score
0
Points
0
Location
Port St. Lucie
Website
www.zaneswackyblog.com
Make sure when installing an add-on, double check to make sure you have all the dependencies needed to make it work and that it is tested in Orbiter 2016. Install each add-on one at a time before installing the next one. Make sure all the files are in the proper place and read the instructions. Sometimes the issue is a very simple mistake in an installation that causes the software to crash. Hope this helped.

- Zane
 
Top