Orbiter Beta Log

jackswigert1970

New member
Joined
Jan 28, 2019
Messages
39
Reaction score
0
Points
0
Hey guys,

I'm trying to play Orbiter 2016 Beta but it keeps crashing. I was told I need to post the log so people can see what's wrong with it.

I have installed NASSP 8.0 into the folder as well as that is the reason I am trying to play Orbiter Beta.

Here is the entire log that I found in the orbiter.log file:

**** Orbiter.log
000000.000: Build Feb 20 2019 [v.190220]
000000.000: Timer precision: 4.26667e-07 sec
000000.000: Found 0 joystick(s)
000000.000: Devices enumerated: 6
000000.000: Devices accepted: 5
000000.000: [ ] RGB Emulation (SW)
000000.000: [ ] Direct3D HAL (HW)
000000.000: [x] Direct3D T&L HAL (HW)
000000.000: [ ] Direct3D HAL (Intel(R) HD Graphics 630) (HW)
000000.000: [x] Direct3D T&L HAL (Intel(R) HD Graphics 630) (HW)
000000.000: Module AtlantisConfig.dll .... [Build 190220, API 190220]
000000.000: Module AtmConfig.dll ......... [Build 190220, API 190220]
000000.000: Module DGConfigurator.dll .... [Build 190220, API 190220]
000000.000: Module ProjectApolloConfigurator.dll [Build 170130, API 160828]
000000.000: Module DialogTemplate.dll .... [Build 190220, API 190220]
000000.000: Module LaunchpadParamTemplate.dll [Build 190220, API 190220]
000000.000: Module Meshdebug.dll ......... [Build 190220, API 190220]
000000.000: Module TrackIR.dll ........... [Build 190220, API 190220]
000000.000: TrackIR module not found.
000000.000: Module CustomMFD.dll ......... [Build 190220, API 190220]
000000.000: Module LuaMFD.dll ............ [Build 190220, API 190220]
000000.000: Module MFDTemplate.dll ....... [Build 190220, API 190220]
000000.000: Module ProjectApolloMFD.dll .. [Build 170130, API 160828]
000000.000: Module transx.dll ............ [Build 190220, API 190220]
000000.000: Module ApolloRTCCMFD.dll ..... [Build 170130, API 160828]
000000.000: Module LuaConsole.dll ........ [Build 190220, API 190220]
000000.000: Module ScriptMFD.dll ......... [Build 190220, API 190220]
000000.000: Module ExtMFD.dll ............ [Build 190220, API 190220]
000000.000: Module FlightData.dll ........ [Build 190220, API 190220]
000000.000: Module Framerate.dll ......... [Build 190220, API 190220]
000000.000: Module Rcontrol.dll .......... [Build 190220, API 190220]
000000.000: Module ScnEditor.dll ......... [Build 190220, API 190220]
000000.000:
000000.000: **** Creating simulation session
000000.000: DirectDraw interface OK
000000.000: Direct3D interface OK
000000.000: Graphics: Viewport: Window 1904 x 1041 x 32
000000.000: Graphics: Hardware T&L capability: Yes
000000.000: Graphics: Z-buffer depth: 32 bit
000000.000: Graphics: Active lights supported: 8
000000.000: Loading 15382 records from star database
000000.000: Module Sun.dll ............... [Build 190220, API 190220]
000000.000: VSOP87(E) Sun: Precision 1.0e-06, Terms 554/6634
000000.000: Module Mercury.dll ........... [Build 190220, API 190220]
000000.000: VSOP87(B) Mercury: Precision 1.0e-05, Terms 167/7123
000000.000: Module Venus.dll ............. [Build 190220, API 190220]
000000.000: Module VenusAtm2006.dll ...... [Build 190220, API 190220]
000000.000: VSOP87(B) Venus: Precision 1.0e-05, Terms 79/1710
000000.000: Module Earth.dll ............. [Build 190220, API 190220]
000000.000: Module EarthAtmJ71G.dll ...... [Build 190220, API 190220]
000000.000: VSOP87(B) Earth: Precision 1.0e-08, Terms 2564/2564

Hope someone can help me out. Thanks
 

GLS

Addon Developer
Addon Developer
Joined
Mar 22, 2008
Messages
3,877
Reaction score
11
Points
38
The log stops somewhere between loading the Earth and loading the Moon (might not even get there)... did you "install" Orbiter beta over the Orbiter 2016? You need to do so, as the beta doesn't have any Earth textures.
 

jackswigert1970

New member
Joined
Jan 28, 2019
Messages
39
Reaction score
0
Points
0
The log stops somewhere between loading the Earth and loading the Moon (might not even get there)... did you "install" Orbiter beta over the Orbiter 2016? You need to do so, as the beta doesn't have any Earth textures.
How do I install it over the Orbiter 2016? Do I just install it in the same folder as Orbiter 2016 or is it something else?
 
Last edited:

jackswigert1970

New member
Joined
Jan 28, 2019
Messages
39
Reaction score
0
Points
0
Ok I've extracted the textures I used in normal Orbiter into my Beta folder but next to most of the textures there is a red exclamation mark and there isn't an orbiter beta file anymore. When I opened the orbiter.exe file it just sent me to normal Orbiter.
 

kuddel

Donator
Donator
Joined
Apr 1, 2008
Messages
1,467
Reaction score
7
Points
38
The red exclamation marks indicate that you have "local changes" (subversion).
This is due to the fact that you have overwritten the (newer) beta files with the older) Orbiter 2016 files.
But that's not a big problem.
You should have only extracted the "Textures/" folder from the Orbiter 2016 package... but again, no worries!

Just right-click on your Orbiter root folder and select "Revert..." from the "TortoiseSVN" context menu. Select all listed files in the dialog (many!) and click O.K.
That will revert your "working copy" back to r85 state and the red exclamation marks should disappear.

Now you should be able to run Orbiter again (BETA that is).
 

jackswigert1970

New member
Joined
Jan 28, 2019
Messages
39
Reaction score
0
Points
0
Okay. Beta runs now it just crashes sometimes and I'm trying to play NASSP but when I launch either the Saturn V falls over or the screen immediately goes into space and then it crashes.
 

kuddel

Donator
Donator
Joined
Apr 1, 2008
Messages
1,467
Reaction score
7
Points
38
As Orbiter BETA is in constant development it might be that NASSP was build for an older (r84?!) release.
I haven't done much NASSP lately, but for the most current Orbiter BETA I always got the best results when I compiled NASSP trunk myself.
The "official" downloads (binary builds) however were made for Orbiter-2016, I believe...
 

jackswigert1970

New member
Joined
Jan 28, 2019
Messages
39
Reaction score
0
Points
0
I’m using NASSP 8.0 alpha. I downloaded the newest version off of source forge I think. I was told I need orbiter beta to run NASSP properly.
 

kuddel

Donator
Donator
Joined
Apr 1, 2008
Messages
1,467
Reaction score
7
Points
38
...don't know for sure :shrug:, so if you have more reliable sources whether NASSP 8.0 alpha is for 2016 or BETA, trust them!:thumbup:
 

jackswigert1970

New member
Joined
Jan 28, 2019
Messages
39
Reaction score
0
Points
0
Looking through the orbiter.log again I noticed I have many many pages of error messages. I don't know if I should post the log because it is so long due to all the errors in it but if someone can help me with the errors then I will post it.
 

kuddel

Donator
Donator
Joined
Apr 1, 2008
Messages
1,467
Reaction score
7
Points
38
If you post the log between [code]...[/code]-Tags it should be fine
 
Top