Problem Orbiter 2016 linux XR2 display problem

Derek Trotter

New member
Joined
Jun 12, 2017
Messages
3
Reaction score
0
Points
0
I have Orbiter 2016 installed on my computer running Ubuntu 18 and wine 3.0. Several months ago I had Orbiter installed and running, but a hard drive failure took care of that. Now I've reinstalled Orbiter 2016 and the XR2 Ravenstar addon that I had before. This time I ran into a problem i dealt with over a year ago. I have the 2D panel showing, but the bits where you can have different data showing (map, orbit, etc) are blank. Wine is configured to emulate windows 7. I had this problem once before, but I forgot what i did to fix it. I have a screenshot here:

http://ladmo.asuscomm.com/images/orbiter.jpg

Thanks for any help you can offer
 

turtle91

Active member
Joined
Nov 1, 2010
Messages
319
Reaction score
7
Points
33
I have the same with some MFD's. (Ubuntu 16.04 LTS, Wine 3.2)
In my case, this happens with all 2D scaled-down MFD's, as long as anti-aliasing is enabled (D3D9 client...video-tab).
I also got degraded performance when using the XR-default-cockpit-view (regardless of MFD-refresh-rate)
So my workaround: Not using AA and using glass-cockpit whenever possible to keep my FPS high enough.
 

Derek Trotter

New member
Joined
Jun 12, 2017
Messages
3
Reaction score
0
Points
0
How to disable anit aliasing

I have the same with some MFD's. (Ubuntu 16.04 LTS, Wine 3.2)
In my case, this happens with all 2D scaled-down MFD's, as long as anti-aliasing is enabled (D3D9 client...video-tab).
I also got degraded performance when using the XR-default-cockpit-view (regardless of MFD-refresh-rate)
So my workaround: Not using AA and using glass-cockpit whenever possible to keep my FPS high enough.

Is there some way to disable anti aliasing in orbiter?
 

spacecadet

New member
Joined
Jul 11, 2010
Messages
11
Reaction score
0
Points
0
Solution

I've solved this in Ubuntu 18.04 and here is how I did it. In Orbiter Launchpad select the "Extra" tab. Expand the "Instruments and panels" section of the tree. Double-click "MFD parameter configuration."

My settings are:
Enforce pow2 MFD display texture sizes: = No
Switch to hires texture at MFD = 256
MFD texture size: virtual cockpits = 512x512

These settings causes the MFDs to display correctly in the XR2 2D panel. I've changed the screen sizes a few times and the MFDs continue to display correctly. I haven't tested these settings with other vessels.

I hope this helps others!

[edit] I should clarify that I'm running stock Orbiter 2016 without a graphical client (i.e. I'm not running D3D9).
 
Last edited:

turtle91

Active member
Joined
Nov 1, 2010
Messages
319
Reaction score
7
Points
33
>Is there some way to disable anti aliasing in orbiter?
Yes...check the Video-Tab

I found only one solution to use AA and scaled-down MFD's (i.e. XR-vessel-cockpit), after endless testing:

Wine version 2.22-staging + "CSMT" should be enabled in WINE-Registry to avoid texture-loading issues (i.e. part of KSC appears in the sky when flying to the moon..)
CSMT takes care about the draw-order, to avoid such issues (with a performance cost of course).

I tested plenty of WINE 3.x releases, and all of them are causing issues with scaled down MFD's, esp BASESYNC or AEROBRAKE-MFD. The MFDs keep blank (just black) the the FPS goes down from 50 to 5....No issues in glass-cockpit...
 
Top