Software Error: Initialising 3D Environment Using A Hardware Device Failed.

skraeyling

New member
Joined
Jun 9, 2020
Messages
1
Reaction score
0
Points
0
While trying to boot up the simulator for the first time, I got this error:
Initialising 3D environment using a hardware device failed. Try again with a software device.
I checked online but I can't find anything that works.

I am using an RTX 2080, i7 9700k, and 16GB ddr4 RAM.
I haven't installed any add-ons yet, I just started it up and it hasn't yet worked.
Any ideas on how to solve it?
 

dbeachy1

O-F Administrator
Administrator
Moderator
Addon Developer
Donator
Beta Tester
Joined
Jan 14, 2008
Messages
8,916
Reaction score
926
Points
203
Location
VA
Website
alteaaerospace.com
:welcome: to Orbiter-Forum!

The first thing I would try is to go into the Orbiter Launchpad -> Video section -> set 3D device to "Direct3D T&L HAL" and click the Window button to set windowed mode.

Note that the default Orbiter video client uses DirectX 7, so you could (should?) try the DirectX 9 (D3D9) video client for Orbiter instead: http://users.kymp.net/~p501474a/D3D9Client/ The D3D9 video client supports higher video resolutions than the default Orbiter video client, and it has much better performance as well.
 

jfri

New member
Joined
May 19, 2021
Messages
1
Reaction score
0
Points
1
Location
Kungälv
I also have this problem and none of the suggestions here solved the problem for me. I have installed the suggested DirectX 9 client
My orbiter log
**** Orbiter.log
000000.000: Build Aug 28 2016 [v.160828]
000000.000: Timer precision: 1e-007 sec
000000.000: Found 6 joystick(s)
000000.000: Devices enumerated: 6
000000.000: Devices accepted: 5
000000.000: [ ] RGB Emulation (SW)
000000.000: [ ] Direct3D HAL (HW)
000000.000: [x] Direct3D T&L HAL (HW)
000000.000: [ ] Direct3D HAL (NVIDIA GeForce RTX 2070 SUPER) (HW)
000000.000: [x] Direct3D T&L HAL (NVIDIA GeForce RTX 2070 SUPER) (HW)
000000.000: Module AtlantisConfig.dll .... [Build 160828, API 160828]
000000.000: Module AtmConfig.dll ......... [Build 160828, API 160828]
000000.000: Module DGConfigurator.dll .... [Build 160828, API 160828]
000000.000:
000000.000: **** Creating simulation session
000000.000: DirectDraw interface OK
000000.000: ERROR: Could not create D3DDevice
000000.000: ERROR: Could not initialize 3D environment
 

DaveS

Space Shuttle Ultra Project co-developer
Addon Developer
Donator
Beta Tester
Joined
Feb 4, 2008
Messages
9,083
Reaction score
353
Points
173
Are you using Orbiter or Orbiter_ng? To use D3D9Client, you need to use Orbiter_ng and enable D3D9Client in the Modules tab.
 

kuddel

Donator
Donator
Joined
Apr 1, 2008
Messages
1,724
Reaction score
246
Points
63
I am pretty sure that you forgot to install the DirectX 9 runtimes (see \Doc\D3D9Client.pdf page 2).

If you have installed the runtimes, another try could be to check if "Always enumerate devices" is checked:
  • Start Orbiter.exe (!) Note: NOT Orbiter_NG.exe (!)
  • check that under the "Video" tab "Always enumerate devices" is checked
  • close Orbiter.exe (Exit)
AlwaysEnumerateDevices.png

Now start Orbiter_NG.exe again and select your "3D Device" (...Direct3D T&L HAL (NVIDIA GeForce RTX 2070 SUPER) (HW) I assume).
Sometimes that helps
 
Last edited:
Top