General Question DDS texture on a mesh

Strathcona

Donator
Donator
Joined
Jun 30, 2016
Messages
7
Reaction score
4
Points
3
Location
Alberta
Hello,

I've made a mesh of Saturn's moon Mimas based on a shape model of the actual moon (I'll gladly upload it to Orbit Hangar if anyone's interested in it). It appears correctly in Orbiter, is accurately scaled, and is oriented correctly relative to Saturn, but the DDS texture does not get applied and I'm wondering why.

I have the required information about the DDS in the mesh file:

Code:
MSHX1
GROUPS 1   ;Exporter: Msh export 070514;
LABEL mesh01
MATERIAL 1     ;Material.003;
TEXTURE 1   ;Mimas2;
GEOM 32830 65528
And at the end,

Code:
MATERIALS 1
Material.003
MATERIAL Material.003
0.800000 0.800000 0.800000 1.000000
0.800000 0.800000 0.800000 1.000000
1.000000 1.000000 1.000000 1.000000   0
0.000000 0.000000 0.000000 1.000000
TEXTURES 1
Mimas2.dds
Now, I have the file Mimas2.dds saved in the textures folder. I created it using the tool which came with Orbiter. It's 4096 x 2048.

Does anyone know why it is not applied to the mesh?
 

GLS

Addon Developer
Addon Developer
Joined
Mar 22, 2008
Messages
3,965
Reaction score
84
Points
73
Hi!
Did you save the texture in DXT1 or DXT5 format?
Does anything show up in the log?
Does it not work in both MOGE (the default graphics client) and D3D9?
 

Strathcona

Donator
Donator
Joined
Jun 30, 2016
Messages
7
Reaction score
4
Points
3
Location
Alberta
I used GIMP to save two versions, one using BC3 / DXT5 compression and the other using BC1 / DXT1 compression. Neither worked.

There's no abnormalities in orbiter.log when I run the sim.

The texture does not appear in either graphics client. I notice that if I change the material in Anim8or ("material.003" in the mesh file), and then export the .msh file, it will appear in Orbiter in whatever colour I chose in Anim8or. But for some reason the texture simply will not appear.

Where am I going wrong? I'm sure it's something stupid I've overlooked.
 

asbjos

tuanibrO
Addon Developer
Joined
Jun 22, 2011
Messages
621
Reaction score
45
Points
43
Location
This place called "home".
I edit textures in Paint.NET, and I then have to save them using DxTex (ORBITER_ROOT\Utils) afterwards to make them work in inline client.
They still work for me in the D3D9 client without this extra "conversion", though.

1. Open the DDS in DxTex
2. Format->Change image format->Either DTX1 or DTX5
3. Save
 

GLS

Addon Developer
Addon Developer
Joined
Mar 22, 2008
Messages
3,965
Reaction score
84
Points
73
I used GIMP to save two versions, one using BC3 / DXT5 compression and the other using BC1 / DXT1 compression. Neither worked.

There's no abnormalities in orbiter.log when I run the sim.

The texture does not appear in either graphics client. I notice that if I change the material in Anim8or ("material.003" in the mesh file), and then export the .msh file, it will appear in Orbiter in whatever colour I chose in Anim8or. But for some reason the texture simply will not appear.

Where am I going wrong? I'm sure it's something stupid I've overlooked.
Try changing the texture name in the mesh file to use a texture that is shipped with Orbiter (a LDEF or DG texture), to see if those show up.
Never had issues with GIMP (still on 2.8.22).

Please escuse the silly question but, you did the UV mapping, right? Please confirm that in the mesh vertex list you have 8 numbers per line (x y z nx ny nz u v), and the last 2 are not always "0 0" or "0 1".
 

Strathcona

Donator
Donator
Joined
Jun 30, 2016
Messages
7
Reaction score
4
Points
3
Location
Alberta
I figured it out. I wasn't UV mapping the mesh correctly. I tried it in Blender instead, and it textures now. I think some normals need adjusting (see below, the second picture), but it should look great.

Now I'll try to learn the current method for irregular body rendering, rather than using meshes.

Thank you again!

mimas.JPG

mimas2.JPG
 
Top