Question D3D9Client Lost Device

ACH0002

New member
Joined
Apr 11, 2016
Messages
19
Reaction score
0
Points
1
Hello,

I'm using Orbiter 160828 and have problems with the D3D9Client. Very often when flying the XR2, I will get a crach and will see that little window:

D3D9Client Lost Device
Connection to Direct3DDevice is lost
Exit the simulation with Ctrl+Q and restart.
Alt-Taping not supported in atrue fullscreen mode.
Dialog windows won’t work with multi-sampling in a true fullscreen
mode.


I have tried it in "True Full Screen (no alt-tab)", in "Full Screen Window" and in "Window with Taskbar" mode. Also in different Resolutions. But no luck.

Any Idea? Thanks in advance.
Best regards
Norbert
 

kuddel

Donator
Donator
Joined
Apr 1, 2008
Messages
1,486
Reaction score
18
Points
38
As [Alt]+[Tab] is usually the reason for this and you seem to know this, I can only think of any (background) application trying to get "attention".
Have you any mail- or chat-client running that might like to "steal" focus?
I assume you don't have any kind of screen-saver active, right?
 

Samuel Edwards

Clever title.
Moderator
Addon Developer
Joined
Apr 6, 2010
Messages
1,588
Reaction score
16
Points
38
Location
Somewhere, but not here.
I assume you don't have any kind of screen-saver active, right?
I am particularly interested in this as well because I've had problems with the d3d9 client essentially losing the device from a screen-saver activating. Additionally, if you lock your computer with Orbiter running, you will experience this problem too.
 

ACH0002

New member
Joined
Apr 11, 2016
Messages
19
Reaction score
0
Points
1
At first, thank you for your answer. You are right. I don`t use any screen saver. So I will have a look, if there is a (background) application trying to get "attention".
 
Top