Problem 2016 + d3d9 + Linux = screen artifacts

johnnymanly

Donator
Donator
Joined
Mar 17, 2008
Messages
55
Reaction score
23
Points
8
Location
Southwest Pennsylginia
Hello, I'm running Orbiter 2016 with Arch Linux.
Using the d3d9 client I'm getting artifacts in the form of dark squares randomly flashing on the screen.
Have any other Linux users seen such a thing?
Frame rates are good and everything looks fine otherwise.
 

dundun92

Member
Joined
Feb 18, 2012
Messages
42
Reaction score
29
Points
18
I have the same issue running it through proton
 

Boxx

Mars Addict
Addon Developer
Donator
Joined
Nov 15, 2009
Messages
213
Reaction score
138
Points
58
Location
Paris Area
Hello, I'm running Orbiter 2016 with Arch Linux.
Using the d3d9 client I'm getting artifacts in the form of dark squares randomly flashing on the screen.
Hi, no explanation but just a feeling while looking at your video: is it really random?
It looks like the patches are at a few places only, isn't it some drawing of a background picture like a planet, that would be hidden behind a foreground (atmosphere or surface)? You could turn on the display options for planets and moons in the planetarium panel, maybe.
Anyway, bravo for these tests with Linux!
 

johnnymanly

Donator
Donator
Joined
Mar 17, 2008
Messages
55
Reaction score
23
Points
8
Location
Southwest Pennsylginia
Still no luck. The squares aren't on the ecliptic but along the horizon. They're in the fore ground as well, that is, if they appear where a ship is they are in front of the ship.
 
Top