Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Web Forum
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Orbiter Web Forum A forum for general Orbiter-related comments and discussion. Post your questions about Orbiter and addons in the appropriate forums below. Upload your Orbiter screen shots to our gallery HERE!

Reply
 
Thread Tools
Old 09-14-2016, 06:27 PM   #1
SpaceCowboyJoe
Orbinaut
Default Restless Spacecraft in Orbiter 2016

Hello everyone. I tested Orbiter 2016 for a couple flight (XR2 vessel basically) and I'm having so much fun.

I've noticed it's almost impossible to stop a spacecraft. This is particulary evident with the XR2 but it happens the same to me with the Shuttle-A.

It's obviously a bug and I see other mentioning it. Here is more about solving the problem "temporary" untill it will be fixed.

I've considered the possibility to manually change the spacecraft status in the .scn from orbiting to landed.

Does any of you know/imagine how to deal with it?
SpaceCowboyJoe is offline   Reply With Quote
Thanked by:
Old 09-14-2016, 06:43 PM   #2
Kyle
Armchair Astronaut
 
Kyle's Avatar
Default

Slamming on the breaks seems to work to get the XR2 to stop.
Kyle is offline   Reply With Quote
Old 09-14-2016, 07:02 PM   #3
SpaceCowboyJoe
Orbinaut
Default

Quote:
Originally Posted by Kyle View Post
 Slamming on the breaks seems to work to get the XR2 to stop.
Does it? Because once getting to about 0.2 / 0.3 meter per second it starts back twisting and moving around...
and on the moon is even worse
SpaceCowboyJoe is offline   Reply With Quote
Old 09-14-2016, 07:14 PM   #4
turtle91
Orbinaut
Default

Maybe you could report this here ?

http://www.orbiter-forum.com/showthr...6&postcount=33

It seems to be, we both have the same issue.
turtle91 is offline   Reply With Quote
Old 09-14-2016, 07:20 PM   #5
SpaceCowboyJoe
Orbinaut
Default

I managed to make this stop happening when I can totally stop the vessel. But it's very hard to reproduce.
Basically when the vessel totally stopped (tass 0.00) it will not move anymore...
very weird.

In any case I'm going to report as you suggest
SpaceCowboyJoe is offline   Reply With Quote
Thanked by:
Old 09-14-2016, 07:24 PM   #6
turtle91
Orbinaut
Default

Yes, I have had such issues on the moon, too.(RCS+brake helped after many many tries)
A really good testing area is the recenly released Ascension-Island scenery.
The landing-pad sits on some bumpy terrain.
I was able top stop all default-vessles, but got no luck with XR2 and XR1.
turtle91 is offline   Reply With Quote
Old 09-14-2016, 08:14 PM   #7
jedidia
shoemaker without legs
 
jedidia's Avatar
Default

Sounds like Doug should tweak the friction parameters for the landing gear a bit.
jedidia is offline   Reply With Quote
Old 09-14-2016, 08:38 PM   #8
dbeachy1
O-F Administrator
 
dbeachy1's Avatar


Default

It's not a matter of the friction settings -- see this post. This appears to be an Orbiter core issue, and it happens in the Shuttle-A as well.
dbeachy1 is offline   Reply With Quote
Thanked by:
Old 09-14-2016, 09:10 PM   #9
turtle91
Orbinaut
Default

Strange, I was not able to reproduce the issue, using the (full loaded) ShuttleA, Atlantis, ShuttlePB and the DG + DG-S.

I have tested this locations:
Moon: Brighton Beach Pad 1 = all default vessels can be stopped using brakes
Mars: Olympus Pad 1 = same like above
KSC RW 33: same like above
Ascension Island Pad 1 ( as an extreme test) = same as above

In XR2 ad XR1 there is no (default/non-cheating) way for me to stop the vessels using brakes at:
Ascension Island Pad1
Moon Brighton Beach various pads
KSC: no problem, brakes can stop the vessels until "landed/IDLE" state has been registered in Orbiter.
turtle91 is offline   Reply With Quote
Old 09-15-2016, 04:42 PM   #10
SpaceCowboyJoe
Orbinaut
Default

For whoever gets to this thread I found thiw workaround till we have a better solution:


- Dont pause the game
- Open the scenario Editor (in 2016 you have it enabled in the function button toolbar on top center screen)
- Leave everithing as default and just add one hour and return back to current time and...
SpaceCowboyJoe is offline   Reply With Quote
Thanked by:
Old 09-18-2016, 09:19 PM   #11
Eduard
Orbinaut
Default

One problem with incompletely stopped vessels is that time warp is very unstable.
An incompletely stopped vessels often shoots in to space when timewarping to fast.
Orbiter cannot correctly handle that.


I have now reported a related problem with the "Atmospheric wind effects" here:
http://www.orbiter-forum.com/project.php?issueid=1287

I also added a reference to this thread, so that martins will can read this problem too.
Eduard is offline   Reply With Quote
Thanked by:
Old 09-20-2016, 08:13 PM   #12
Floater
Orbinaut
Default

Confirming: there is a problem with stopping vessels in 2016 version. XR vessels has been patched but the problem still occurs for other crafts, for example for the cargo.

When the vessel is placed by means of ScnEditor everything is ok, but if it is placed by means of unloading - even small degree of terrain inclination is enough for the vessel to never stop - it slides away instead.

Such a vessel is not considered landed. It can be seen in the Lua script and in the scenario file (if such a file is saved while the vessel is sliding).

Last edited by Floater; 09-21-2016 at 02:00 PM.
Floater is offline   Reply With Quote
Thanked by:
Old 09-22-2016, 04:25 AM   #13
replicant
The Wanderer
 
replicant's Avatar
Default

I will confirm that also. I was trying the titan rocket in orbiter 2016. As part of the guidance file, the engine is set to go about 20% for a few seconds to simulate ignition and runup. This makes the rocket drift and it will not stop. even 1% power will make it drift and keep sliding, as if there is no landed friction at all. This is at cape Kennedy, and there is very slight terrain elevation there.

Also curious thus far why the multistage 2015 HUD seems to CTD 2016
replicant is offline   Reply With Quote
Old 09-22-2016, 09:50 AM   #14
fred18
Addon Developer

Default

Quote:
Originally Posted by replicant View Post
 I will confirm that also. I was trying the titan rocket in orbiter 2016. As part of the guidance file, the engine is set to go about 20% for a few seconds to simulate ignition and runup. This makes the rocket drift and it will not stop. even 1% power will make it drift and keep sliding, as if there is no landed friction at all. This is at cape Kennedy, and there is very slight terrain elevation there.

Also curious thus far why the multistage 2015 HUD seems to CTD 2016
you have to update the module of multistage2015 to the new orbiter version. it's still work in progress but almost done, you can download it from here :

http://www.orbiter-forum.com/showthr...&postcount=521

It will be released officially soon anyway
fred18 is online now   Reply With Quote
Thanked by:
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Web Forum


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 11:47 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.