Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Visualization Project
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Orbiter Visualization Project Orbiter external graphics development.

Reply
 
Thread Tools
Old 04-16-2017, 02:37 AM   #1
kywnicho
Orbinaut
Default Trying to use an external graphics client but keep getting error codes

Hello everyone. I first tried to install Orbiter 2010P1 (zip install) and load the D3DX9. Right after I check the box under modules, I get this error:

Orbiter Launchpad: Orbiter.exe - Entry Point Not Found
?ElevationGrid@GraphicsClient@oapi@@OBE_NPAXHHHHHH PAF1PAN@Z could
not be located in the dynamic link library Orbiter.exe

I've looked at the orbiter log and because it happens when I activate it in the modules tab, there is nothing in the log. My computer is a AMD 6 core with 16GB ram, Radeon Sapphire r9 280x video card. If I open orbiter.exe, it detects this video card using stock graphics client.

I've also tried a fresh 2010P1 with a beta upgrade to 111105. I then load the D3DX11. When I open Orbiter_ng I activate it in the Modules tab then nothing happens. No video tab. If I try to open a scenario, I get the command line. Can anyone decipher the error message? Or is my video card not compatible? Thanks for the help! Kyle
kywnicho is offline   Reply With Quote
Old 04-16-2017, 06:49 AM   #2
Face
Beta Tester
 
Face's Avatar

Default

Quote:
Originally Posted by kywnicho View Post
 Hello everyone. I first tried to install Orbiter 2010P1 (zip install) and load the D3DX9. Right after I check the box under modules, I get this error:

Orbiter Launchpad: Orbiter.exe - Entry Point Not Found
?ElevationGrid@GraphicsClient@oapi@@OBE_NPAXHHHHHH PAF1PAN@Z could
not be located in the dynamic link library Orbiter.exe

I've looked at the orbiter log and because it happens when I activate it in the modules tab, there is nothing in the log. My computer is a AMD 6 core with 16GB ram, Radeon Sapphire r9 280x video card. If I open orbiter.exe, it detects this video card using stock graphics client.

I've also tried a fresh 2010P1 with a beta upgrade to 111105. I then load the D3DX11. When I open Orbiter_ng I activate it in the Modules tab then nothing happens. No video tab. If I try to open a scenario, I get the command line. Can anyone decipher the error message? Or is my video card not compatible? Thanks for the help! Kyle
The first problem looks like you are trying to use a 2016 OVP client with a 2010 Orbiter. Of course that can't work because the old Orbiter did not know about ElevationGrid.

Some arbitrary beta with the (very old) D3D11 OVP client is also a combination that I would expect to fail hard, for the same reason: version incompatibilities.

Is there any reason why you don't use the 2016 D3D9 on a 2016 Orbiter?
Face is offline   Reply With Quote
Old 04-16-2017, 09:00 AM   #3
orb
O-F Administrator
Ninja
 
orb's Avatar

Default

The first issue is incorrect version of the D3D9Client used in Orbiter 2010-P1. I think you used the graphics client for Orbiter 2016 in Orbiter 2010-P1, and they aren't compatible.

The second issue is I'm not exactly sure what, but there should be an error code logged in Orbiter.log next to D3D11Client.dll. I guess you are missing some dependencies / runtime libraries.
orb is offline   Reply With Quote
Old 04-16-2017, 02:57 PM   #4
Ripley
Tutorial translator
 
Ripley's Avatar
Default

D3D11 is very old and not maintained.
Go with D3D9 instead.
Ripley is offline   Reply With Quote
Old 04-16-2017, 03:34 PM   #5
kywnicho
Orbinaut
Default

Ok so I have a combination of incompatible client software. I just downloaded the newest from the codeplex website. I just fount under the download tab more clients intended for the older orbiter. I would like to have a 2010p1 install with D3D9 for mods and NASSP. I've tried to load mods onto the new 2016 version and it crashes. Is there a way to make these mods work on the newer orbiter 2016?
kywnicho is offline   Reply With Quote
Old 04-16-2017, 04:18 PM   #6
Face
Beta Tester
 
Face's Avatar

Default

Quote:
Originally Posted by kywnicho View Post
 I've tried to load mods onto the new 2016 version and it crashes. Is there a way to make these mods work on the newer orbiter 2016?
If the add-ons in question are open source, you can try to make them compatible for yourself by means of recompiling them for the new API. Often a recompile already suffice. Sometimes you also have to change some code to make it work again.
If they are closed source, or you don't have a clue about programming at all, you are most probably stuck with waiting for the add-on author to update them.
However, some add-ons made for 2010 work for 2016, too. Sometimes in a limited form (e.g. SC4, OS4), but better than nothing. There is a thread here highlighting these addons, but mostly it is a trial&error approach to work with them.
Face is offline   Reply With Quote
Old 04-16-2017, 04:24 PM   #7
Ripley
Tutorial translator
 
Ripley's Avatar
Default

Latest released D3D9 versions are also hosted on my squadron's website:
http://www.tuttovola.org/index.php?a...wnloads;cat=64
Ripley is offline   Reply With Quote
Old 04-16-2017, 04:58 PM   #8
kywnicho
Orbinaut
Default

Thank you for all the help. I did get orbiter 2010P1 to work with D3D9.
kywnicho is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Visualization Project


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 03:35 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.