Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Beta
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Orbiter Beta Topics related to Beta releases of Orbiter and Orbiter development.

Reply
 
Thread Tools
Old 10-23-2012, 10:51 AM   #16
Izack
Non sequitur
 
Izack's Avatar
Default

Quote:
Originally Posted by boogabooga View Post
 So, does this mean that if you impact, say, the moon, at high speed, you will stop, instead of bouncing and scraping along the surface indefinitely?
With the new higher sampling rate and inherent instability, my guess is that even more 'fun' will occur in extreme situations like that.
Izack is offline   Reply With Quote
Thanked by:
Old 10-23-2012, 10:55 AM   #17
orb
O-F Administrator
Ninja
 
orb's Avatar

Default

It all now depends on stiffness and dumping of the new touchdown points. Vessels using the legacy touchdown points will most likely still bounce like they did, but I haven't checked that yet (I only used stock vessels).
orb is offline   Reply With Quote
Old 10-23-2012, 12:14 PM   #18
dansteph
Addon Developer
 
dansteph's Avatar

Default

Maybe there is something wrong in my install (Installed over previous beta which was installed on a fresh 2010+P1) but in all scenario the Atlantis ready on launchpad Sky rocket without any command turning like a mad at mach 3 as soon as I launch the scenario. Also many "old style" ground object start to slide or sky rocket.

When the Atlantis land after some "elastic bounce" however it stop more realisticly than before.
UMmu slide on ground at 20km/h without stop on earth (2023 scenario) and sky rocket with any command. Cars make exactly the same. (2001 scenario slide without stop and sky rocket with any command issued)
The DeltaGlider and ShuttleA work fine. Landing on one side gear is much more realistic (but a bit rough given DeltaGlider's weight)

I had a computer freeze trying a side landing with an old style vessel with contact point.
It started to sunk in ground then complete computer freeze. (FullScreen)

Last edited by dansteph; 10-23-2012 at 12:45 PM.
dansteph is offline   Reply With Quote
Thanked by:
Old 10-23-2012, 01:33 PM   #19
RacerX
Donator
 
RacerX's Avatar
Default

ok a couple of issues I have found. I read somewhere that the new beta may "break" some addons (using vanilla install with the typical ucgo,sound,ummu and ALL XR vessels)
1: XR1,XR2 crashes. Suspect it is the Dll's modules
2: (Orbiter beta specific) Go to any scenario and run then use scenario editor and change the "HOUR" in the date tab. Instant CTD
RacerX is offline   Reply With Quote
Old 10-23-2012, 01:48 PM   #20
dbeachy1
O-F Administrator
 
dbeachy1's Avatar



Default

Quote:
Originally Posted by RacerX View Post
 1: XR1,XR2 crashes. Suspect it is the Dll's modules
I tested the XRs with the new beta last night and fixed the CTD. The cause was that Orbiter now invokes clbkLoadPanel before invoking clbkPostCreation, and the current XRs don't initialize their instrument panels until clbkPostCreation. The fix was to move the XR panel initialization code up to clbkSetClassCaps.

There is one more issue involving SetTouchdownPoints that is being worked on (landed XRs get bounced into deep space), but I'll upload some beta-compatible XR DLL zip files to my site once that is sorted out.

I'm also getting errors trying to play custom wav files in the beta using OrbiterSound 3.5. RequestLoadVesselWave3 succeeds, but then trying to play it with PlayVesselWave3 always fails (returns false). The default OrbiterSound sounds (e.g., base radar) work, though -- it's only sounds loaded with RequestLoadVesselWave3 that won't play. I'll retest that when the new OrbiterSound version is released, though.
dbeachy1 is offline   Reply With Quote
Old 10-23-2012, 02:07 PM   #21
RacerX
Donator
 
RacerX's Avatar
Default

were you able by chance to confirm the "Hour" change error in my above post dbeachy?

Last edited by RacerX; 10-23-2012 at 02:14 PM.
RacerX is offline   Reply With Quote
Old 10-23-2012, 02:10 PM   #22
orb
O-F Administrator
Ninja
 
orb's Avatar

Default

I'm able to confirm it in Linux. I'll check it later in debug build of Scenario Editor in Windows.
orb is offline   Reply With Quote
Thanked by:
Old 10-23-2012, 02:27 PM   #23
dansteph
Addon Developer
 
dansteph's Avatar

Default

Quote:
Originally Posted by dbeachy1 View Post
 clbkLoadPanel before invoking clbkPostCreation
Mhhh, if this is true I would suggest to Martin not changing such order, as many addons may be broken or have unstable behaviour.

I think it's possible to keep backward compatibility without renouncing to improvement. Vessel compiled with older version would
stay with previous collision and only the newer made with the new SDK would have it, we would have the best of both.



---------- Post added at 02:27 PM ---------- Previous post was at 02:22 PM ----------

Quote:
Originally Posted by dbeachy1 View Post
 I'm also getting errors trying to play custom wav files in the beta using OrbiterSound 3.5. RequestLoadVesselWave3 succeeds, but then trying to play it with PlayVesselWave3 always fails (returns false). The default OrbiterSound sounds (e.g., base radar) work, though -- it's only sounds loaded with RequestLoadVesselWave3 that won't play. I'll retest that when the new OrbiterSound version is released, though.
OrbiterSound is initialised in clbkPostCreation, that may be a side effect of changing callback order.
I cannot change the order as it would mean recompiling all the addons made since years.

Last edited by dansteph; 10-23-2012 at 03:07 PM.
dansteph is offline   Reply With Quote
Old 10-23-2012, 03:36 PM   #24
sorindafabico
Orbinaut
 
sorindafabico's Avatar
Default

Quote:
Originally Posted by orb View Post
 I can't reproduce your issue on a very old laptop not supporting hardware T&L, neither in windowed nor in full screen, with or without local light sources enabled (this works just fine for me with -1 supported lights since 100905). Did you run it on default settings? Does it close with some error dialog box, or just CTD?
If I did not forget anything, I changed only the options like nonspherical gravity, radiation pressure, etc. in Parameters, the ambient light level (to zero), and from window to full screen.

I can try again with "full" default settings when at home.

Last edited by sorindafabico; 10-23-2012 at 05:30 PM.
sorindafabico is offline   Reply With Quote
Old 10-23-2012, 03:49 PM   #25
orb
O-F Administrator
Ninja
 
orb's Avatar

Default

Quote:
Originally Posted by orb View Post
 I'm able to confirm it in Linux. I'll check it later in debug build of Scenario Editor in Windows.
The exception is caused by oapiSetSimMJD. The access violation exception while writing at 0x00000000 (trying to store a double value at address from pointer at offset 0xC of some class, which is NULL at that time) is thrown every time in Orbiter 121023 (built-in graphics client) at 0x004601cc (in 2nd function called from the 2nd function called from the function called from oapiSetSimMJD). It doesn't matter what MJD (it can be the same as the current SimMJD taken from oapiGetSimMJD) or pmode is set.
orb is offline   Reply With Quote
Thanked by:
Old 10-23-2012, 05:46 PM   #26
sorindafabico
Orbinaut
 
sorindafabico's Avatar
Default

Still getting CTD, even with full default settings. Maybe it's my four years old notebook...


"Orbiter.exe stopped working."

The log:

Quote:
**** Orbiter.log
Build Oct 21 2012 [v.121021]
Timer precision: 6.98413e-008 sec
Found 0 joystick(s)
Devices enumerated: 4
Devices accepted: 3
[ ] RGB Emulation (SW)
[x] Direct3D HAL (HW)
[x] Direct3D HAL (Mobile Intel(R) 4 Series Express Chipset Family) (HW)
Module AtlantisConfig.dll .... [Build 121021, API 121021]
Module AtmConfig.dll ......... [Build 121021, API 121021]
Module DGConfigurator.dll .... [Build 121021, API 121021]

**** Creating simulation session
DirectDraw interface OK
Direct3D interface OK
Graphics: Viewport: Window 1274 x 774 x 32
Graphics: Hardware T&L capability: No
Graphics: Z-buffer depth: 32 bit
Graphics: Active lights supported: -1
---------------------------------------------------------------
>>> ERROR: DDraw error DDERR_BLTFASTCANTCLIP
>>> [OrbiterGraphics::clbkBlt | .\OGraphics.cpp | 1554]
---------------------------------------------------------------
sorindafabico is offline   Reply With Quote
Old 10-23-2012, 05:53 PM   #27
orb
O-F Administrator
Ninja
 
orb's Avatar

Default

Quote:
Originally Posted by sorindafabico View Post
What does "Exibir detalhes do problema" say?

Quote:
Originally Posted by sorindafabico View Post
 ERROR: DDraw error DDERR_BLTFASTCANTCLIP
I have the same error in the log with GeForce 285 GTX, in both Linux and Windows XP, but it isn't causing any crash.
orb is offline   Reply With Quote
Old 10-23-2012, 06:03 PM   #28
sorindafabico
Orbinaut
 
sorindafabico's Avatar
Default

Quote:
Originally Posted by orb View Post
 What does "Exibir detalhes do problema" say?

Quote:
Signature of the problem:
Problem Event Name: BEX
Application Name: orbiter.exe
Application Version: 0.0.0.0
Stamp Date / Time of Application: 50847130
Fault Module Name: MSVCR90.dll
Fault Module Version: 9.0.30729.6161
Stamp Date / Time Fault Module: 4dace5b9
Exception Offset: 00030655
Exception Code: c0000417
Exception Data: 00000000
OS Version: 6.0.6002.2.2.0.768.2
Locale ID: 1046
Additional Information 1: 4fb6
Additional Information 2: e2ff9e923411eadbefdd45fc51411671
Additional Information 3: B9B9
Additional Information 4: 04e216871634d87989c8de9edda7ef60

I don't have MSVCR90.dll in beta folder (I have a MSVCR71.dll in 2010P1 folder), is this normal?
sorindafabico is offline   Reply With Quote
Old 10-23-2012, 06:09 PM   #29
orb
O-F Administrator
Ninja
 
orb's Avatar

Default

Quote:
Originally Posted by sorindafabico View Post
 I don't have MSVCR90.dll in beta folder (I have a MSVCR71.dll in 2010P1 folder), is this normal?
It's normal. That file should be in the %SystemRoot%\WinSxS\x86_microsoft.vc90.crt_<some tokens> folder.

Try (re-)installing Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package MFC Security Update (x86 version).
orb is offline   Reply With Quote
Thanked by:
Old 10-23-2012, 06:24 PM   #30
Spacethingy
Multitasker
 
Spacethingy's Avatar
Default

The playbacks seem slightly scrambled. E.g. the Atlantis launch starts with the launcher and shuttle spinning madly in mid air; while at wheel-stop in the landing playback the shuttle teleports to a spot about a mile away.

Aside, I never imagined getting so emotional about a totalled, yet gloriously upside-down landed ShuttleA!
Spacethingy is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Beta


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 02:15 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.