Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Support & Bugs
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Addon Support & Bugs Support & bug reports for Orbiter addons.

Reply
 
Thread Tools
Old 06-08-2017, 07:36 AM   #1
Wolf
Donator
 
Wolf's Avatar
Default DRD9 Antialiasing setting

I have installed what I believe is the latest version (D3D9Client2016-R2) in two different Orbiter2016 installs. The problem is in one of them I am unable to use the "Antialias" function in the Video/advanced menu, the related button does not work and also looks disabled. On the second Orbiter install it does work though...
Click image for larger version

Name:	Antialias.jpg
Views:	14
Size:	228.9 KB
ID:	15244

Any suggestion?

Thanks
Wolf is offline   Reply With Quote
Thanked by:
Old 06-08-2017, 11:30 AM   #2
turtle91
Orbinaut
Default

I have this issue even in Orbiter 2010.
At least when using full-screen-mode.
If I want AA in Orbiter-fullscreen, I used my graphics-card-config-utility to setup-up AA.
This worked for me. (tested with ATI/AMD and NVIDIA)
However, the D3D9-AA-button should be active if using any of the 2 non-"real"-full-screen-modes.
turtle91 is offline   Reply With Quote
Thanked by:
Old 06-08-2017, 12:47 PM   #3
Wolf
Donator
 
Wolf's Avatar
Default

Thanks,
as you said the AA is inhibited in Full Screen mode but it works in full screen window mode.
I wonder if this is a GC issue and if the y will fix it
Wolf is offline   Reply With Quote
Thanked by:
Old 06-08-2017, 11:02 PM   #4
kuddel
Donator
Default

Quote:
Originally Posted by Wolf View Post
 On the second Orbiter install it does work though...
That's strange. Assuming that those two installations are (more or less) equal.

Could you try to "re enumerate devices"?
I think you have to therefore start Orbiter.exe (not Orbiter_NG.exe!) once on both installations and make sure that "Always enumerate devices" is checked (see Attachment).

After "re enumerate devices" ran on both installations you might get equal results on both Orbiter_NG runs...
Attached Thumbnails
Orbiter Launchpad.png  
kuddel is offline   Reply With Quote
Old 06-09-2017, 12:46 AM   #5
jarmonik
Beta Tester

Default

Anti-aliasing is disabled if a "True fullscreen" mode is selected or a backbuffer "GDI compatibility" mode is enabled.

This is because the true full screen mode cannot handle AA at the same time with dialog boxes open on a screen, also a GDI compatible backbuffer doesn't support AA.

Of course, the AA can be forced from a driver control center, since the driver can do things that the DirectX can't.
jarmonik is offline   Reply With Quote
Old 06-09-2017, 09:25 AM   #6
Wolf
Donator
 
Wolf's Avatar
Default

Quote:
Originally Posted by kuddel View Post
 That's strange. Assuming that those two installations are (more or less) equal.

Could you try to "re enumerate devices"?
I think you have to therefore start Orbiter.exe (not Orbiter_NG.exe!) once on both installations and make sure that "Always enumerate devices" is checked (see Attachment).

After "re enumerate devices" ran on both installations you might get equal results on both Orbiter_NG runs...
Thanks for the tip, but actually the reason was only one of the two installs was running on Full Screen Mode, hence AA not available (for the reason stated above by Jarmonik)
Wolf is offline   Reply With Quote
Thanked by:
Reply

  Orbiter-Forum > Orbiter Addons > Addon Support & Bugs


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 02:55 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.