Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Beta
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Orbiter Beta Topics related to Beta releases of Orbiter and Orbiter development.

Reply
 
Thread Tools
Old 03-23-2016, 04:13 PM   #151
4throck
Enthusiast !
 
4throck's Avatar
Default

Quote:
Originally Posted by martins View Post
  I hope this is down to the beta getting stable, but it's probably just because everybody is getting sick of bug reporting.
Not so sure. I'm in love with the Beta's terrain, but after I land I miss UMMU+UCGO. So I end up spending more time on Orbiter 2010.

Don't wish to discuss backward compatibility (specially since most issues are down to badly designed add-ons**) but I think it does have an influence on the amount of feedback.

** - Ex: Spacecraft4 example DG lands OK, but not other existing vessels. Copy/paste of landing points to the affected vessels gets stable landings with the craft "upside down". So.. those add-ons might be reversed regarding vessel coordinates, meshes, engine direction vectors, etc. This is not beta related, but it may show itself only now...
4throck is offline   Reply With Quote
Old 03-25-2016, 04:13 PM   #152
Eduard
Orbinaut
Default

Let's report some bugs:
- When pressing Ctrl+0 or Ctrl+ to control the auxiliary pods of the Shuttle-A, the slide button on the 2D panel is not updated. I need to use F8 to switch to the other cockpitviews and back to get it refreshed. This is an old bug already present in Orbiter 2010.
- Radiator of the Deltaglider automatically closes after (re)starting a scenario.
- Parashutes of the Shuttle-A Payloads do not always close (go away) after landing.

Something else:
When starting Rev 53 with the Welcome to Orbiter 2016 scenario (first time start or later), it crashes inmediately. This scenario is not working anymore.
I already copied the hi-res textures to it before starting.

Last edited by Eduard; 03-25-2016 at 04:35 PM.
Eduard is offline   Reply With Quote
Thanked by:
Old 03-25-2016, 04:43 PM   #153
Face
Beta Tester
 
Face's Avatar

Default

Quote:
Originally Posted by 4throck View Post
 ** - Ex: Spacecraft4 example DG lands OK, but not other existing vessels. Copy/paste of landing points to the affected vessels gets stable landings with the craft "upside down".
I've heard that vinka already has SC5 in stock, but it is not released yet. Perhaps he just waits for Martin to release Orbiter, which produces a cute little deadlock of sorts: SC4 not compatible with O2016 means less bug reports, but O2016 not being released means no SC5 which might fix problems as shown above, or even displays bugs that could be show-stoppers.

Maybe that scheme is also true for other projects?
Face is offline   Reply With Quote
Old 03-26-2016, 02:18 AM   #154
jarmonik
Beta Tester

Default

Quote:
Originally Posted by martins View Post
 I'll compile both orbiter.exe and orbiter_ng with the LARGEADDRESSAWARE flag for the next beta to see if that cures the problem (at least until somebody also hits the 4GB ceiling).
Thanks for adding the LARGEADDRESSAWARE flag. I can confirm that it's working as expected, there is at least 3GB of memory available now and we should be doing fine with that pretty long. I also noticed that we had an implementation error in D3D9, the resolution bias range was -3 to 3 instead of -2 to 2 which pushed the memory consumption higher on maximum settings.

I also tried to designed my own LOD control function and quickly realized that there aren't any room for control since the tile levels must be matched with texture levels to get the textures appear nice and clear.
jarmonik is offline   Reply With Quote
Old 03-26-2016, 08:52 PM   #155
jarmonik
Beta Tester

Default Tile Resolution Bias

Based on what I have learned about the LOD control, I would say that the "tile resolution bias" setting is mostly about a calibration of the tile distance based LOD control function to match the texture resolutions. I have also added this slider in the D3D9Debug Controls from where it can be adjusted in realtime, although the setting isn't saved.

Here are three screen shots:

1st) The bias slider is in left most position: textures appear blurry due to under biasing.

2nd) When the bias is increased the yellow "arrows" behind the delta-glider as well as the far-end of the runway will appear naturally sharp.

3rd) The bias slider is pushed to right most position; the far-end of the runway is over sharp, the lines in a runway have partially disappeared and they are flickering/tearing due to over biasing like the terrain all around. If a mipmaps are enabled, then the far terrain is rendered using the second mipmap and the flickering/tearing won't appear.

Mipmaps will significantly increase loading times and runways may appear blurry when viewed from a very shallow angle.

In the screen shots, anisotropic filter is set to 16 and tile mipmaps are disabled. Mesh resolution is 32. Mesh resolution shouldn't have any effect to the resolution bias. The resolution bias will greatly effect in performance but as far as I can tell that's merely a side effect.
Attached Thumbnails
Calib1.jpg   Calib2.jpg   Calib3.jpg  
jarmonik is offline   Reply With Quote
Old 03-26-2016, 09:01 PM   #156
jarmonik
Beta Tester

Default D3D9ClientBeta 22

Here is a new build for Orbiter Beta rev 53. Compiled with the LARGEADDRESSAWARE flag. There are some animation, MFD, configuration fixes as well as code optimizations. Also the statistics panel has been cleaned up Ctrl+Shift+C, nothing major.

EDIT: Report D3D9 related issues in the D3D9 thread.
Attached Files
File Type: zip D3D9ClientBeta22-forRev53.zip (1.67 MB, 67 views)
jarmonik is offline   Reply With Quote
Old 03-27-2016, 02:01 AM   #157
jarmonik
Beta Tester

Default

There is a report of anomalous panel behavior in D3D9 thread. Seems to be effecting in inline and D3D9 in latest Beta and Orbiter 2010-P1. When the panel scale from a parameters tab is set to 2.0 some of the panels in XR2 and DGIV are not working. They are stretching instead of scrolling. Based on how it looks it's likely a problem in target rectangle while blitting a panel on screen. There's no change in target rectangle only in source rectangle.

Also, in stock delta-glider the main panel doesn't scroll up far enough to become fully visible (in that configuration panel scale 2.0)
jarmonik is offline   Reply With Quote
Old 03-27-2016, 04:09 AM   #158
DaveS
Addon Developer
 
DaveS's Avatar


Default

One bug I have noticed with the default Atlantis is that the nose landing gear doesn't fully extend. I have checked things over and it seems to be due to a misplaced rotation point that causes this. Currently it seems to be at the mid-pöint of the actual NLG strut when it should be further aft, at the aft points of Y-branch.
DaveS is online now   Reply With Quote
Old 03-28-2016, 05:24 PM   #159
Eduard
Orbinaut
Default

Oke, I still have two questions:

- Is there a new way in the new beta how I can set the target base of the Surface HUD? Because changing the target base on a map MFD does not affect the HUD target base anymore. Or is this still something which yet has to be fixed?

- After a travel from Brighton to the Luna-OB1, I found this Wheel spinning extremely fast in all directions instead of rotating as it should do. So something clearly goes wrong with it.
And when I restart some other of my saved scenerio's and I select the Luna-OB1, i see the same problem.
Maybe it's onother a timewarp problem, I don't know.
Is this a known problem for anyone else?

B.t.w. still many, many thanks for all the work on Orbiter. It becomes more and more magnificent.
Eduard is offline   Reply With Quote
Old 03-28-2016, 10:53 PM   #160
Hlynkacg
Aspiring rocket scientist
 
Hlynkacg's Avatar


Default

Was orbitersdk.h accidentally removed from the latest revision? All my add-ons have spontaneously stopped compiling and it's not showing up in file search.

False alarm, svn overwrote my file paths in the property sheet.

Last edited by Hlynkacg; 03-28-2016 at 11:04 PM.
Hlynkacg is offline   Reply With Quote
Old 03-28-2016, 10:57 PM   #161
Ripley
Tutorial translator
 
Ripley's Avatar
Default

---deleted---

Last edited by Ripley; 03-28-2016 at 11:00 PM. Reason: sorry, posted in wrong section
Ripley is offline   Reply With Quote
Old 04-02-2016, 12:21 AM   #162
Hlynkacg
Aspiring rocket scientist
 
Hlynkacg's Avatar


Default

I have a question about the ComponentVessel class that the DG is derived from. I'm trying adapt the Dragonfly and my own LM to use the panelelement framework but am a little confused about what exactly should be passed to the "DEVMESHHANDLE hMesh" of clbkVCRedrawEvent and clbkResetVC
Hlynkacg is offline   Reply With Quote
Old 04-02-2016, 11:02 PM   #163
martins
Orbiter Founder
Announcement New Orbiter Beta Released (r.54, Apr 2 2016)

Change log:
  1. Bug fix: 2D panels (old style): scaled panels would erroneously stretch instead of scroll out at top
  2. Bug fix: 2D panels (new style): can now scroll through entire panel if larger than viewport height
  3. Bug fix: Camera: elevation cache was not cleared after switching ground mode reference object
  4. ElevationManager: bug fix: incorrect mask flags
  5. ElevationManager::Elevation and ElevationManager::ElevationGrid: linear interpolation: modified algorithm (bilinear instead of splitting into 2 triangles). Fixes CTD due to pelev out of range read access
  6. Bug fix: SuperVessel: typo causing CTD in playback of docked assemblies
  7. DeltaGlider: bug fix: radiator retracted erroneously on scenario start
  8. Shuttle-A: bug fix: aux pod throttle levers in 2D panel not animated when controlled by key shortcut
  9. Shuttle-A payload: bug fix: chute visuals not always removed on touchdown
  10. New 2016 scenario: Solar system

This update contains fixes for some recently reported bugs.

Points 1 and 2 should address this report.

Point 5 should address this report.

Points 6, 7, 8 and 9 should address this report.

There is also a new but uncritical OVP commit (r.50).
martins is offline   Reply With Quote
Thanked by:
Old 04-02-2016, 11:40 PM   #164
kuddel
Donator
Default

Hmmm is it just me or can anybody confirm that Orbiter_NG (r54) doesn't start a simulation session at all?
Launchpad starts up O.K. but any scenario will just close Orbiter_NG.

Last edited by kuddel; 04-02-2016 at 11:45 PM.
kuddel is offline   Reply With Quote
Old 04-03-2016, 12:22 AM   #165
martins
Orbiter Founder
Default

Quote:
Originally Posted by kuddel View Post
 Hmmm is it just me or can anybody confirm that Orbiter_NG (r54) doesn't start a simulation session at all?
Launchpad starts up O.K. but any scenario will just close Orbiter_NG.
Is this only with the D3D9 client, or also with the latest D3D7 client?

Maybe the OVP change wasn't as uncritical as I thought ...
martins is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Beta


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 06:57 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright ©2007 - 2017, Orbiter-Forum.com. All rights reserved.