Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Support & Bugs
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Addon Support & Bugs Support & bug reports for Orbiter addons.

Reply
 
Thread Tools
Old 11-19-2018, 03:39 AM   #1
bcbarnes
Orbinaut
 
bcbarnes's Avatar
Default Orbiter2016, Win10, IMFD odd CTD problem

I have been having a problem with IMFD in orbiter2016 so I decided to do a clean install, and then install only IMFD. The problem persists, and goes like this:

I run the orbiter launchpad, everything is good. I load and run any scenario, typically the deltaglider at KSC. I set one of the MFDs to IMFD. I then save the scenario and exit completely out of orbiter.

Then, I relaunch orbiter, and load the scenario from above. Everything is fine. I exit the scenario, and then relaunch the same scenario again, and it starts to load, and then just crashes to the desktop. Always the same pattern: Load scenario first time and all is OK. Attempt to load it a second time (without exiting orbiter) and it CTDs. The orbiter launchpad just shuts down as if nothing was wrong.

I have attached the orbiter log (not much help) and the information from EventViewer when the crash happens. I've researched the MSVCR90 dll mentioned in the eventviewer log and tried several fixes without success. Also, this happens with IMFD57, IMFD55, and IMFD53.

Any clues anyone might have would be appreciated.
Attached Files
File Type: txt EventViewer.txt (625 Bytes, 0 views)
File Type: log Orbiter.log (8.6 KB, 0 views)

Last edited by bcbarnes; 11-19-2018 at 03:52 AM. Reason: Forgot attachments ...
bcbarnes is offline   Reply With Quote
Old 11-19-2018, 08:32 AM   #2
Marijn
Orbinaut
 
Marijn's Avatar
Default

Inspect the scenario files before and after saving. Maybe some value is saved which causes the problem. Not sure what you would do about that if that's the case.
Marijn is offline   Reply With Quote
Old 11-19-2018, 09:19 AM   #3
Face
Beta Tester
 
Face's Avatar

Default

Quote:
Originally Posted by bcbarnes View Post
 Attempt to load it a second time (without exiting orbiter) and it CTDs. The orbiter launchpad just shuts down as if nothing was wrong.
If you use deallocate memory as shutdown option, this could be some memory problem in the addon. Unfortunately, the speed of the terminate-and-respawn option and its consequential use in debugging scenarios often hides such problems.
If you already use the terminate-and-respawn method, and the problem still occurs, I also think that it is some persistent state (e.g. inside scenario file or MFD-mode specific config files) that causes the shutdown.
Face is offline   Reply With Quote
Thanked by:
Old 11-19-2018, 07:28 PM   #4
bcbarnes
Orbinaut
 
bcbarnes's Avatar
Default

Thanks guys. I don't think it is in the scenario, because after a crash, I restart orbiter and load the same scenario and it works once, but will again fail on a second attempt.

I am currently using the terminate/respawn option and that works well but feels like a "band-aid" on what might be a more serious problem (as this is obviously not a common issue with folks).

Thanks again.

Last edited by bcbarnes; 11-19-2018 at 07:56 PM.
bcbarnes is offline   Reply With Quote
Old 11-19-2018, 08:03 PM   #5
Marijn
Orbinaut
 
Marijn's Avatar
Default

I have Terminate Orbiter process selected in the Shutdown options. Also check the font smoothing options and try a different setting.

My Orbiter fails to launch properly 1 out of 10 times. Then I have to terminate the process using the taskbar.
Marijn is offline   Reply With Quote
Old 11-19-2018, 10:06 PM   #6
bcbarnes
Orbinaut
 
bcbarnes's Avatar
Default

Just tested against Orbiter beta 180904 and I see the same problem. None of the font smoothing options made any difference.
bcbarnes is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Addons > Addon Support & Bugs


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 04:53 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.