Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Visualization Project
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Orbiter Visualization Project Orbiter external graphics development.

Reply
 
Thread Tools
Old 06-17-2013, 10:21 AM   #2491
Loru
Moderator
 
Loru's Avatar


Default

In oversimplified way: yes.
Loru is offline   Reply With Quote
Thanked by:
Old 06-17-2013, 10:49 AM   #2492
Staiduk
Orbinaut
Default

(chuckle) 'Oversimplified' is about the most advanced I can understand at this level. But I sense my questions are not appropriate for this thread; I'll stop asking them. Let me merely express my admiration and gratitude for the development of the d3d9Client software. Truly impressive work.
Staiduk is offline   Reply With Quote
Old 06-22-2013, 01:23 PM   #2493
jarmonik
Beta Tester

Default

Quote:
Originally Posted by astrosammy View Post
 I have the same problem in R10 and R11 (R9 works):
GPU: ATI Mobility Radeon HD 5650
Are the surfaces normal mapped or not ?
jarmonik is offline   Reply With Quote
Old 06-24-2013, 10:19 PM   #2494
Disconnect
Orbinaut
Default

Quote:
Originally Posted by jarmonik View Post
 Are the surfaces normal mapped or not ?
Nope
Disconnect is offline   Reply With Quote
Thanked by:
Old 06-27-2013, 06:18 PM   #2495
jbsheridan
Orbinaut
Default

I am having image flickering, (looks black), every 3 or 4 seconds. Especially obvious on space ship.

Running Win XP D3D9.



Any ideas?


jb
jbsheridan is offline   Reply With Quote
Old 06-27-2013, 09:23 PM   #2496
kuddel
Donator
Default

Hi jarmonik,

in case you want to update your SVN Client to Version 1.8, I recommend to not do this
It seems that the new TortoiseSVN client (version 1.8.0) has problems in "talking" to the codeplex server ("XML parsing failed: (400 Bad Request) Error")
With the previous version (1.7.14) everything seems to work O.K.
It is not 100% clear whether the client is to blame or the server.

Unfortunately I've updated all my working copies to 1.8-Version and there is no "downgrade" option So I had to re-checkout all of them again...

Just in case you planned to upgrade your cSVN-lient...

As soon as there is news on this issue I'll post again.

/Kuddel
kuddel is offline   Reply With Quote
Old 06-28-2013, 10:13 AM   #2497
jarmonik
Beta Tester

Default

Quote:
Originally Posted by jbsheridan View Post
 I am having image flickering, (looks black), every 3 or 4 seconds. Especially obvious on space ship.
Does it occur if the environment mapping is disabled. By setting: Video Tab->Advanced->Environment Mapping->Rendering Mode to "Disable" ?

---------- Post added at 13:13 ---------- Previous post was at 13:12 ----------

Quote:
Originally Posted by kuddel View Post
 Hi jarmonik,
in case you want to update your SVN Client to Version 1.8, I recommend to not do this
Thanks for the warning. Haven't updated the client yet. I'll be skipping the update then.
jarmonik is offline   Reply With Quote
Old 06-28-2013, 11:39 AM   #2498
Face
Beta Tester
 
Face's Avatar

Default

Quote:
Originally Posted by kuddel View Post
 in case you want to update your SVN Client to Version 1.8, I recommend to not do this
It seems that the new TortoiseSVN client (version 1.8.0) has problems in "talking" to the codeplex server ("XML parsing failed: (400 Bad Request) Error")
With the previous version (1.7.14) everything seems to work O.K.
It is not 100% clear whether the client is to blame or the server.
I strongly suspect that the Codeplex server is doing something outside the SVN specification there, because repos on Codeplex always need the "stupid" mode in my HG client, whereas other SVN remotes (Sourceforge, @work) never had that need.
Face is offline   Reply With Quote
Old 06-28-2013, 03:47 PM   #2499
kuddel
Donator
Default

Quote:
Originally Posted by Face View Post
 I strongly suspect that the Codeplex server is doing something outside the SVN specification there...
me too, but that doesn't change my recommendation

If you search the net for this issue, it seems that it has to do with some changes in the HTTP client library ('serf' instead of' neon') but that is way over my head.
Whether codeplex fixes/changes something or tortoiseSVN fixes/changes something is more or less irrelevant for me now :-/

Nevertheless, the 1.7.x client does most of the job anyway.
kuddel is offline   Reply With Quote
Old 06-29-2013, 08:51 AM   #2500
Face
Beta Tester
 
Face's Avatar

Default

Quote:
Originally Posted by kuddel View Post
 Whether codeplex fixes/changes something or tortoiseSVN fixes/changes something is more or less irrelevant for me now :-/
Yeah, but that's why I've mentioned that a dissimilar implementation in a different VCS environment struggles with the same issues. Just more evidence for it being the server, not TortoiseSVN.

Isn't the underlying system at Codeplex TFS? I guess the bridging to SVN is the culprit, then. Is anybody of you actually using it via TFS?
Face is offline   Reply With Quote
Old 06-29-2013, 09:08 AM   #2501
SolarLiner
It's necessary, TARS.
 
SolarLiner's Avatar
Default

That, maybe, is why I can't commit to sourceforge anymore: TortoiseSVN 1.8
Meh, if I knew it...
SolarLiner is offline   Reply With Quote
Old 06-29-2013, 04:16 PM   #2502
orb
O-F Administrator
Ninja
 
orb's Avatar

Default

"XML parsing failed: (400 Bad Request)" will be fixed in Subversion 1.8.1:
http://subversion.1072662.n5.nabble....-td182428.html
orb is offline   Reply With Quote
Thanked by:
Old 06-29-2013, 04:18 PM   #2503
Noeyedeer
Orbinaut
 
Noeyedeer's Avatar
Default D3D9 Crashes.

Every time I try to run Orbiter in D3D9 client it says "Critical error has occured. See orbiter.log for details." So I pull up orbiter.log with the notepad and it says:
D3D9Client:WARNING: [Hardware has only a limited non-power of 2 texture support]
D3D9Client:WARNING: [Insufficient Vertex Shader. Attempting software vertex processing...]
D3D9Client:WARNING: [Not a pure device]
D3D9Client:WARNING: [No Hardware T&L]
D3D9Client:WARNING: [No Hardware MipMap auto generation]
I have no clue what this means and how to fix the problem.
Noeyedeer is offline   Reply With Quote
Old 06-29-2013, 04:35 PM   #2504
orb
O-F Administrator
Ninja
 
orb's Avatar

Default

Quote:
Originally Posted by Noeyedeer View Post
 I have no clue what this means and how to fix the problem.
What is your graphics card?
orb is offline   Reply With Quote
Old 06-29-2013, 05:27 PM   #2505
Noeyedeer
Orbinaut
 
Noeyedeer's Avatar
Default

Quote:
Originally Posted by orb View Post
 What is your graphics card?
I'm not very good at computers so I think by graphics card you mean 3d device as shown in the video section of the launchpad.
If so: Mobile Intel(R) 945 Express Chipset Family
Not the best so I won't be too surprised if d3d9 won't work on my computer.
Noeyedeer is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Visualization Project

Tags
d3d9client, graphicsclient


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 07:09 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.