Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Beta
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Orbiter Beta Topics related to Beta releases of Orbiter and Orbiter development.

Reply
 
Thread Tools
Old 10-23-2012, 07:24 PM   #31
RacerX
Donator
 
RacerX's Avatar
Default

v121023 has same issues with XR vehicles and changing the time or day in scenerio editor still results in CTD. This is a update to post #19 above
Is this where we post bug reports for a alpha/beta or is there some official place for that?

Last edited by RacerX; 10-23-2012 at 07:30 PM.
RacerX is offline   Reply With Quote
Old 10-23-2012, 07:33 PM   #32
orb
O-F Administrator
Ninja
 
orb's Avatar

Default

Quote:
Originally Posted by RacerX View Post
 v121023 has same issues with XR vehicles and changing the time or day in scenerio editor still results in CTD. This is a update to post #19 above
That's because nothing was changed in it to fix it yet. The beta 121023 was already available this morning [UTC], but only recently it was uploaded to OHM by Vash. My tests confirming the Scenario Editor crash were already made with 121023.
orb is offline   Reply With Quote
Old 10-23-2012, 07:37 PM   #33
orb
O-F Administrator
Ninja
 
orb's Avatar

Default

Quote:
Originally Posted by RacerX View Post
 Is this where we post bug reports for a alpha/beta or is there some official place for that?
The official bug tracker is in ORBITER: 2010-P1 project. You can select either of both recently released beta versions when you create a bug report.

You can still post your observations/bugs in this thread.
orb is offline   Reply With Quote
Thanked by:
Old 10-23-2012, 09:05 PM   #34
martins
Orbiter Founder
Default

Quote:
Originally Posted by RacerX View Post
 2: (Orbiter beta specific) Go to any scenario and run then use scenario editor and change the "HOUR" in the date tab. Instant CTD
This should be fixed in the next beta.
martins is offline   Reply With Quote
Old 10-23-2012, 10:13 PM   #35
Columbia42
Orbinaut
 
Columbia42's Avatar
Default

The new collision system is really cool but unfortunately I'm getting significant framerate drops in this beta compared to all previous versions. Is anyone else experiencing this?
Columbia42 is offline   Reply With Quote
Old 10-23-2012, 10:19 PM   #36
kuddel
Donator
Default

Has anyone tried just to view the "2010 Edition\Welcome" scenario?
The Shuttle launch seems to be quite wierd (Shuttle and rest of the Stack start disconnected...) and after the pitchover (of only the shuttle ) a CTD occurrs.

Nothing else was installed, so only plain 100830 overwritten by orbiter121023-100830diff.7z

By the way, there are several 0-Byte sized files in the patch (and in 108030 as well). Are they in there to mimic a kind of delete operation? Or are some of them 0-sized by accident?

I'll try some other testing later. For now: Thanks for this new beta!!!
/Kuddel
kuddel is offline   Reply With Quote
Old 10-23-2012, 10:39 PM   #37
Ripley
Tutorial translator
 
Ripley's Avatar
Default

Quote:
Originally Posted by kuddel View Post
 ...By the way, there are several 0-Byte sized files in the patch...
Many empty folders too.
Ripley is offline   Reply With Quote
Old 10-23-2012, 10:50 PM   #38
SolarLiner
It's necessary, TARS.
 
SolarLiner's Avatar
Default

A pack error? Hum, that can explain problems I have so.
SolarLiner is offline   Reply With Quote
Old 10-23-2012, 11:00 PM   #39
orb
O-F Administrator
Ninja
 
orb's Avatar

Default

Quote:
Originally Posted by kuddel View Post
 By the way, there are several 0-Byte sized files in the patch (and in 108030 as well).
I found only these (not in the patch but in complete Orbiter installation):
Code:
$ find . -empty
./Config/transx.cfg
./Config/Vessels/Galileo.cfg
./Flights/DG-ISS Sync Dock/Mir.atc
./Flights/Glider in orbit 1/system.dat
./Flights/Smack! Rescue/ISS.atc
./Flights/Smack! Rescue/Luna-OB1.atc
./Flights/Smack! Rescue/Mir.atc
./Meshes/Hyperion.msh
From which the .atc files are 0 bytes most likely intentionally, and the only, I think, should be non-empty, are: "./Config/Vessels/Galileo.cfg" and "./Meshes/Hyperion.msh". But they were already empty in 100830.
orb is offline   Reply With Quote
Old 10-23-2012, 11:07 PM   #40
martins
Orbiter Founder
Default

Quote:
Originally Posted by kuddel View Post
 Has anyone tried just to view the "2010 Edition\Welcome" scenario?
The Shuttle launch seems to be quite wierd (Shuttle and rest of the Stack start disconnected...) and after the pitchover (of only the shuttle ) a CTD occurrs.

Nothing else was installed, so only plain 100830 overwritten by orbiter121023-100830diff.7z
Old playbacks containing Atlantis are no longer compatible with the new Atlantis setup, so I will eventually have to re-do these.

Quote:
By the way, there are several 0-Byte sized files in the patch (and in 108030 as well). Are they in there to mimic a kind of delete operation? Or are some of them 0-sized by accident?

I'll try some other testing later. For now: Thanks for this new beta!!!
/Kuddel
This is a result of the 7-zip diff file generation. This should be ok as long as there are no zero-size files left in your orbiter installation after you applied the diff.

FYI, this is the command I use (inside the up-to-date orbiter installation directory) to generate the diffs:

Code:
7z.exe u ..\orbiter%oldver%.7z -u- -up0q3r2x0y2z0w2!..\orbiter%newver%-%oldver%diff.7z *
If there are any 7-zip experts around who can spot a problem, please let me know!

Edit:
Quote:
Originally Posted by orb
 I found only these (not in the patch but in complete Orbiter installation):
I can confirm those. I'll try to track down why the msh and cfg went AWOL.
martins is offline   Reply With Quote
Old 10-23-2012, 11:18 PM   #41
kuddel
Donator
Default oapiGetGbodyCount() & oapiGetBaseCount() return strange values

Hi again,

I would not be much concerned about the zero-sized files. I just wanted to know if they are meant to be 'to be deleted' files...

Another more serious issue is when I try to run the external graphic client on the new release.
After re-compiling it against the (changed?) API-headers I found that these two methods return very unusual high values:
oapiGetGbodyCount()
oapiGetBaseCount()
The values returned are way to high!
Out of curiosity, I tried to cut the lower half of the result via HIWORD( ... ) and I was able to start with the D3D9Client...
For example:
PHP Code:
    DWORD npl HIWORDoapiGetGbodyCount() );
    
// instead of the 'original':
    
DWORD npl oapiGetGbodyCount();// <= _very_ high values!! 
I did not (yet) check whether those 'cut' values are reasonable (or all zero), but I think there is something fishy there.

Thanks for looking at this,
Kuddel
kuddel is offline   Reply With Quote
Old 10-23-2012, 11:27 PM   #42
martins
Orbiter Founder
Default

I get 32 from oapiGetGbodyCount() in my installation - how many do you get?? Does this also happen with the inline client or the D3D7 client?
martins is offline   Reply With Quote
Old 10-23-2012, 11:59 PM   #43
kuddel
Donator
Default

Quote:
Originally Posted by martins View Post
 I get 32 from oapiGetGbodyCount() in my installation - how many do you get?? Does this also happen with the inline client or the D3D7 client?
It was something like over 300 thousand!
But currently I can't even run the scenario (I always test with "Delta-glider\DG Mk4 in orbit.scn") which did run after my previous changes....hmmm

Maybe it's some of those "VisualStudio needs to rebuild sometimes" problems.
Unfortunately I don't have any more time to look any deeper into it, but be assured that I will report back as soon as I have any news.

Ah by the way: I was debugging the D3D9Client.

I will re-start from scratch tomorrow and report what happens here.
For now I can not even get the "uncut" values of oapiGetGbodyCount(). It crashes somewhere else now. I think it's best to do a complete re-compile and fresh start tomorrow.

Thanks for the quick response and good night,
Kuddel

---------- Post added at 01:59 ---------- Previous post was at 01:40 ----------

Hi again,

I couldn't go to sleep with this

The oapiGetGbodyCount() does indeed return 32!

But oapiGetBaseCount() returns 1098137279 !

This is the basic code I ran:
PHP Code:
    DWORD npl oapiGetGbodyCount();
    for (
DWORD p=0;p<npl;p++) {
        
OBJHANDLE hPl oapiGetGbodyByIndex(p);
        if (
hPl) {
            
DWORD nbs oapiGetBaseCount(hPl); // this returns 1098137279 !
            
for (DWORD b=0;b<nbs;b++) {
                
OBJHANDLE hBs oapiGetBaseByIndex(hPlb);
                ; 
// do something
            
}
        }
    } 
Nevertheless, I go to bed now ... really!

/Kuddel
kuddel is offline   Reply With Quote
Old 10-24-2012, 12:18 AM   #44
martins
Orbiter Founder
Default

Well, the first Gbody is the sun, and oapiGetBaseCount() is only supported for planets and moons. I'll put a safeguard into oapiGetBaseCount for the next beta to catch this.

However, this shouldn't have worked with previous orbiter versions either. Did you use this code before?
martins is offline   Reply With Quote
Old 10-24-2012, 02:38 AM   #45
shangding
Orbinaut
Default

Quote:
Originally Posted by sorindafabico View Post
 Still getting CTD, even with full default settings. Maybe it's my four years old notebook...

{image}
"Orbiter.exe stopped working."

The log:
I also have this CTD,and I don't know how to fix it.
shangding is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Beta


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 09:28 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.