Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addons
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Addons A repository for Orbiter addons contributed by users. Developers & members may announce new releases here and discuss any Orbiter addon.

Reply
 
Thread Tools
Old 07-07-2008, 06:37 AM   #76
toodoo213
Orbinaut
Default

Quote:
Originally Posted by davewave View Post
 When you enter the IP Address in the main view, make sure this is set to the computer running the orbiter program.

Make sure that you have the latest OrbConnect installed and enable as a plugin in orbiter. You can get it from: http://www.orbithangar.com/searchid.php?ID=3395 This addon must be installed on the Orbiter computer you wish to connect to.

Make sure that the OrbConnect.cfg file (found in your config directory) has a port number matching the one you are trying to connect to in the orbiter window.

Finally, if all else fails, its usually due to a sneaky firewall which even when "disabled" still blocks traffic.

Hope that helps

Thank you so much for your help. it connects. it was just my IP address:whistle:.
toodoo213 is offline   Reply With Quote
Old 07-07-2008, 10:11 PM   #77
toodoo213
Orbinaut
Default

Quote:
Originally Posted by Arrowstar View Post
 I get an error when attempting to connect to my local orbiter session:

"Value cannot be null
parameter name: image"

I'm using my local IP address and OrbConnect is obviously running the background of Orbiter. Orbiter runs fine until I attempt to connect. When connecting, Orbiter CTDs with one of XP's generic-looking memory errors and MCOF crashes with what I posted above.
Are you with Earth's SOI? I tried 2 scenarios, one within Earth's SOI & another en route to Jupiter. The 1st can connect without error but the issue happens for 2nd one.
toodoo213 is offline   Reply With Quote
Old 07-07-2008, 10:21 PM   #78
Chupacabra
Orbinaut
Default

I believe my problem is the same. However it occurred with craft both in Earth's SOI and The Moon's SOI.

Of course my problem allows me to continue the connection...
Chupacabra is offline   Reply With Quote
Old 07-08-2008, 09:39 AM   #79
davewave
Addon Developer
 
davewave's Avatar
Default

Quote:
Originally Posted by toodoo213 View Post
 Are you with Earth's SOI? I tried 2 scenarios, one within Earth's SOI & another en route to Jupiter. The 1st can connect without error but the issue happens for 2nd one.
I haven't programmed for SOI other then earth or the moon so it probably won't work yet. I did say this was a beta, almost an alpha.

Give me more time to work on this.
davewave is offline   Reply With Quote
Old 07-08-2008, 07:16 PM   #80
Chupacabra
Orbinaut
Default

Thank you for the effort you put into this. I hope the comments are of some use to you.
Chupacabra is offline   Reply With Quote
Old 07-08-2008, 08:15 PM   #81
nasakid
Space Nut
 
nasakid's Avatar
Default

Sign Me Up!
nasakid is offline   Reply With Quote
Old 07-25-2008, 05:07 PM   #82
jocgame
Orbinaut
Default

nice it looks cool!
jocgame is offline   Reply With Quote
Old 07-25-2008, 05:11 PM   #83
ar81
Orbinaut
Default

Is there a way to have a single player MC to play offline?
ar81 is offline   Reply With Quote
Old 07-26-2008, 03:39 AM   #84
Chupacabra
Orbinaut
Default

ar81: I assume you mean how to use MC on the same PC that you are running Orbiter on?

Simple:
1.Start Orbiter with the OrbConnect module loaded.
2.Start MC
3.Open a command prompt. (From start menu, click on "Run". Then type "cmd" (no quotes)
4.In the command prompt type "ipconfig"
5.Use the given IP address and copy it into the connect screen of MC.

Hope this is what you are looking for.
Any progress davewave? You've surprised me with the current v1.
Chupacabra is offline   Reply With Quote
Old 08-28-2008, 08:33 PM   #85
highflyer23
Orbinaut
Default

Hi I am new to the forums here But have been using orbiter sim for quite awhile now although I still do not understand the concepts of physics so mainly just use the autopilot on the delta glider Iv from dan steph which i must say is an incredible addon. I know most of the functions of the plane how to power up and down etc... But even with all the tutorial it seems you must have some knowledge of math and physics to achieve orbit lol. so to the point of this question I downloaded the mission control addon and installed it per instruction i also installed orbconnect and activated it inside the modules section of orbiter. I know my Ip adress and when i enter it inside mc and click connect i get this error

An unhandled exception has occured in your application with the following details



See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.
************** Exception Text **************
System.ArgumentNullException: Value cannot be null.
Parameter name: image
at System.Drawing.Graphics.DrawImage(Image image, RectangleF destRect, RectangleF srcRect, GraphicsUnit srcUnit)
at orbiterMC.Form1.renderMap()
at orbiterMC.Form1.Timer1_Tick(Object sender, EventArgs e)
at System.Windows.Forms.Timer.OnTick(EventArgs e)
at System.Windows.Forms.Timer.Callback(IntPtr hWnd, Int32 msg, IntPtr idEvent, IntPtr dwTime)

************** Loaded Assemblies **************
mscorlib
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.2407
CodeBase: file:///c:/windows/microsoft.net/fra...2/mscorlib.dll
----------------------------------------
orbiterMC
Assembly Version: 1.0.3096.28220
Win32 Version: 1.0.3096.28220
CodeBase: file:///C:/Documents%20and%20Setting.../orbiterMC.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.2032
CodeBase: file:///c:/windows/assembly/gac/syst...dows.forms.dll
----------------------------------------
System
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.2407
CodeBase: file:///c:/windows/assembly/gac/syst...089/system.dll
----------------------------------------
System.Drawing
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.2032
CodeBase: file:///c:/windows/assembly/gac/syst...em.drawing.dll
----------------------------------------
Microsoft.VisualBasic
Assembly Version: 7.0.5000.0
Win32 Version: 7.10.6001.4
CodeBase: file:///c:/windows/assembly/gac/micr...isualbasic.dll
----------------------------------------
Accessibility
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.573
CodeBase: file:///c:/windows/assembly/gac/acce...essibility.dll
----------------------------------------
System.Xml
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.2032
CodeBase: file:///c:/windows/assembly/gac/syst...system.xml.dll
----------------------------------------
************** JIT Debugging **************
To enable just in time (JIT) debugging, the config file for this
application or machine (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.
For example:
<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>
When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the machine
rather than being handled by this dialog.


any help would be greatly appreciated.
highflyer23 is offline   Reply With Quote
Old 08-29-2008, 01:15 PM   #86
HiPotOk1978
ReFuel L.L.C CEO
 
HiPotOk1978's Avatar
Default

This is wonderful. I can't wait to see where you take this thing. Would be cool to see voice support w/ time delay added to this app once get though a few versions.... that is if it is possible...

Now how are people going to meet up and use this... cause well.... I wanna do something
HiPotOk1978 is offline   Reply With Quote
Old 09-28-2008, 11:38 PM   #87
deltawing777
Orbinaut
Default

well as far as voice i use teamtalk and have it setup in preferences/sound events/hotkey pressed and pointed in the direction of the "beep" file (like a nasa "beep" sound.i got mine from space shuttle mission 2007) anyways i setup the server/service on computer A and ran teamtalk 127.0.0.0 locally on it then connected with computer B ...now when i call computer A with computer B the "beep" comes through computer A speakers just like real nasa communications....now we just need a more feature rich mission control.....cant wait for davewave's next version.my 11 year old cant wait to play "nasa" with daddy lol
deltawing777 is offline   Reply With Quote
Old 09-29-2008, 02:03 AM   #88
Hielor
Defender of Truth

Default

For voice, I would recommend Ventrilo rather than Teamspeak. You can have up to 8 people on a server for free, and in my experience the quality is *significantly* higher than teamspeak.
Hielor is offline   Reply With Quote
Old 09-30-2008, 01:13 AM   #89
deltawing777
Orbinaut
Default

i agree ventrillo is another good proggy for voice...used it for bf2 problem is how do i assign a custom *wav "beep" to the other computer A when i key mike on computer B on a lan/internet?...i know it has binds but i dont know how to use it...can you tell me how to setup vent to do this hielor?
deltawing777 is offline   Reply With Quote
Old 09-30-2008, 02:05 AM   #90
Hielor
Defender of Truth

Default

Quote:
Originally Posted by deltawing777 View Post
 i agree ventrillo is another good proggy for voice...used it for bf2 problem is how do i assign a custom *wav "beep" to the other computer A when i key mike on computer B on a lan/internet?...i know it has binds but i dont know how to use it...can you tell me how to setup vent to do this hielor?
I have no idea, I've never used binds in vent...
Hielor is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Addons > Addons


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 04:29 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.