Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addons
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Addons A repository for Orbiter addons contributed by users. Developers & members may announce new releases here and discuss any Orbiter addon.

Reply
 
Thread Tools
Old 09-06-2016, 08:12 AM   #16
fred18
Addon Developer

Default

could you please just list what appears not to work? so we can avoid to use those programs
fred18 is offline   Reply With Quote
Thanked by:
Old 09-10-2016, 09:58 PM   #17
Ripley
Tutorial translator
 
Ripley's Avatar
Default

I see this warning in Orbiter2016 log regarding your AttitudeIndicatorMFD.dll (both in IMFD and LTMFD)
(useless log removed)

Last edited by Ripley; 10-10-2016 at 02:50 PM. Reason: Log removed. I was wrong. Forget this post.
Ripley is offline   Reply With Quote
Old 09-10-2016, 10:12 PM   #18
turtle91
Orbinaut
Default

From where do you have this "Modules\Plugin\AttitudeIndicatorMFD.dll" from ?
In both downloads, IMFD and LTMFD I can only see "AttitudeControl.dll", which is in the Orbiter\modules-folder...
I found nothing in "modules\plugin" regarding "attitude" (in IMFD and LTMFD).

Maybe you mean: http://www.orbiter-forum.com/attachm...9&d=1470579481

Last edited by turtle91; 09-10-2016 at 10:15 PM.
turtle91 is offline   Reply With Quote
Thanked by:
Old 09-10-2016, 10:27 PM   #19
Ripley
Tutorial translator
 
Ripley's Avatar
Default

Quote:
Originally Posted by turtle91 View Post
 From where do you have this "Modules\Plugin\AttitudeIndicatorMFD.dll" from ?
Sorry, my bad! I mixed apples and oranges.
It's time I get some sleep.

---------- Post added at 00:27 ---------- Previous post was at 00:17 ----------

Anyway, I got it from here
http://www.orbiter-forum.com/showthread.php?t=37317

Ripley is offline   Reply With Quote
Old 09-17-2016, 02:47 PM   #20
Ripley
Tutorial translator
 
Ripley's Avatar
Default

Sometimes (quite randomly) I see this error "Earth or Moon is missing from CSol":



For example in this quicksave (right after TLI burn)

Code:
BEGIN_DESC
Orbiter saved state at T = 27671
END_DESC

BEGIN_ENVIRONMENT
  System Sol
  Date MJD 51982.9888387837
  Help CurrentState_img
END_ENVIRONMENT

BEGIN_FOCUS
  Ship GL-01S
END_FOCUS

BEGIN_CAMERA
  TARGET GL-01S
  MODE Cockpit
  FOV 34.00
END_CAMERA

BEGIN_HUD
  TYPE Orbit
  REF AUTO
END_HUD

BEGIN_MFD Left
  TYPE User
  MODE LunarTransferMFD
  DataA1 2 0 1 0 1 0 0 0
  DataB1 1853000 51985.76873924739 4.71238898038469 0 -0.5835944686356039 0.717766654882668
  DataB2 51985.81873924739 51982.98590571657 51982.6685767396 0 120000 0
  DataB3 0 0 0 0
END_MFD

BEGIN_MFD Right
  TYPE User
  MODE LunarTransferMFD
  DataA1 1 0 0 0 0 0 -1 0
  DataB1 0 0 4.71238898038469 0 0 0
  DataB2 0 0 51982.6685767396 0 120000 0
  DataB3 0 0 0 0
END_MFD

BEGIN_PANEL
END_PANEL

BEGIN_SHIPS
ISS:ProjectAlpha_ISS
  STATUS Orbiting Earth
  RPOS 4877121.357 4094724.905 -2175722.013
  RVEL 5085.3955 -5753.5399 580.0523
  AROT -160.856 30.150 28.070
  VROT 0.0335 -0.0146 -0.1426
  AFCMODE 7
  PRPLEVEL 0:1.000000
  IDS 0:588 10 1:586 10 2:584 10 3:582 10 4:580 10
  NAVFREQ 0 0
  XPDR 466
END
Mir:Mir
  STATUS Orbiting Earth
  RPOS -2365727.712 -402224.312 -6228580.449
  RVEL 7230.9671 -92.5016 -2714.4411
  AROT -179.818 -30.117 -79.113
  VROT -0.0489 -0.0001 0.0022
  AFCMODE 7
  IDS 0:540 100 1:542 100 2:544 100
  XPDR 482
END
Luna-OB1:Wheel
  STATUS Orbiting Moon
  RPOS -1271712.776 1843046.950 -65.834
  RVEL -1217.9149 -840.3813 -0.0273
  AROT 0.000 -0.000 144.305
  VROT -0.0000 0.0000 10.0000
  AFCMODE 7
  IDS 0:560 100 1:564 100
  XPDR 494
END
GL-01S:DG-S
  STATUS Orbiting Earth
  RPOS -3754906.055 129165.999 6301765.396
  RVEL -9423.3018 360.3195 -4314.3378
  AROT -163.312 72.424 -152.754
  RCSMODE 2
  AFCMODE 1
  PRPLEVEL 0:1.000000 1:0.810733 2:0.999317
  NAVFREQ 524 94 84 114
  XPDR 0
  HOVERHOLD 0 1 0.0000e+000 0.0000e+000
  TRIM -0.035696
  AAP 0:0 0:0 0:0
  PSNGR 2 3 4
  PANELCOL 4
  TANKCONFIG 1
END
SH-03:ShuttleA
  STATUS Landed Earth
  BASE Habana:4
  POS -82.3982414 23.0005396
  HEADING 70.00
  ALT 2.912
  AROT 50.119 -65.937 19.478
  AFCMODE 7
  PRPLEVEL 0:1.000000 1:1.000000
  NAVFREQ 0 0
  XPDR 0
  PODANGLE 0.0000 0.0000
  DOCKSTATE 0 0.0000
  GEAR 0 0.0000
  PAYLOAD MASS 0.0 0
  ATTREF 0 0 0
  ADI_LAYOUT 0
END
PB-01:ShuttlePB
  STATUS Landed Earth
  BASE Habana:1
  POS -82.4000000 22.9994604
  HEADING 22.00
  ALT 1.287
  AROT 62.913 -18.678 7.875
  AFCMODE 7
  PRPLEVEL 0:1.000000
  NAVFREQ 0 0
END
GL-02:DeltaGlider
  STATUS Landed Mars
  BASE Olympus:3
  POS -135.4299995 12.7366186
  HEADING 359.97
  ALT 2.533
  AROT 81.143 -8.838 -45.371
  AFCMODE 7
  PRPLEVEL 0:1.000000 1:1.000000
  NAVFREQ 0 0 0 0
  XPDR 0
  HOVERHOLD 0 1 0.0000e+000 0.0000e+000
  GEAR 1.0000 0.0000
  AAP 0:0 0:0 0:0
END
SH-01:ShuttleA
  STATUS Landed Moon
  BASE Brighton Beach:1
  POS -33.4375000 41.1184067
  HEADING 0.00
  ALT 3.027
  AROT 64.274 33.319 48.978
  AFCMODE 7
  PRPLEVEL 0:1.000000 1:1.000000
  NAVFREQ 0 0
  XPDR 0
  PODANGLE 0.0000 0.0000
  DOCKSTATE 0 0.0000
  GEAR 0 0.0000
  PAYLOAD MASS 0.0 0
  ATTREF 0 0 0
  ADI_LAYOUT 0
END
END_SHIPS

BEGIN_ExtMFD
END

Last edited by Ripley; 09-17-2016 at 02:54 PM. Reason: scenario added
Ripley is offline   Reply With Quote
Old 10-10-2016, 03:57 PM   #21
JonnyBGoode
Sky Marshal
 
JonnyBGoode's Avatar
Default

Last night, I was running the Europa to Callisto tutorial scenario. Everything went by the numbers until I got to the orbit insert burn. The engine never shut off after zero eccentricity was reached and I ended up in a collision course with the moon. I thought I had done something wrong until I came here and discovered it was an apparent IMFD glitch.

Which is fine, there's no big skill involved in manual orbital insertion burns.
JonnyBGoode is offline   Reply With Quote
Old 12-18-2016, 03:36 PM   #22
Eduard
Orbinaut
Default

Hi, I see that IMFD has been updated yesterday, I don't know exactly what changed. But it reminds me of something important that I wanted to report already a few months ago (it still applies to the newest version as well):

The Delta Velocity program does not work properly.
The remaining DV in the BV view does not count down well and never reaches zero. And therefore the Autoburn also never cuts off.
But even when doing the burn manually, when not using Autoburn, the remaining DV never counts down. So this is not an AB problem, but this is a problem specific to the Delta Velocity program.
I compared the same testscenario between IMFD in Orbiter 2010 and IMFD in Orbiter 2016 to be certain about this before posting it here.
Eduard is offline   Reply With Quote
Old 12-18-2016, 03:41 PM   #23
boogabooga
Bug Crusher
 
boogabooga's Avatar
Default

That's exactly what just got fixed, as well as Orbit Insert, etc.

http://www.orbiter-forum.com/showthread.php?t=37864
boogabooga is offline   Reply With Quote
Old 12-18-2016, 04:16 PM   #24
Eduard
Orbinaut
Default

Quote:
Originally Posted by boogabooga View Post
 That's exactly what just got fixed, as well as Orbit Insert, etc.

http://www.orbiter-forum.com/showthread.php?t=37864
Ok, thank you, I didn't see that there is a new thread.

But I just tested it with version 5.7 installed and I am still experiencing this bug. I also removed the 5.6 dll to be shure that I am using the newest version.
I don't understand what I'm doing wrong.
B.t.w. I tested it using the DG-EX vessel, because I had a good saved scenario with this vessel.
Eduard is offline   Reply With Quote
Old 12-18-2016, 04:24 PM   #25
boogabooga
Bug Crusher
 
boogabooga's Avatar
Default

It's working for me. (delta glider).
boogabooga is offline   Reply With Quote
Old 12-18-2016, 05:05 PM   #26
Eduard
Orbinaut
Default

Quote:
Originally Posted by boogabooga View Post
 It's working for me. (delta glider).
Ok, see the attachment. I made this scenario file. I edited it so that I am using a default Deltaglider now and not the DG-EX anymore.
It's a mid-course correction to align the trajectory with Brighton Beach.

It still doesn't work for me in Orbiter 2016 with IMFD 5.7.
I only see it working correctly in Orbiter 2010.

Does this scenario do the burn correctly in your 2016 installation?

Update: When I just do a simple test with a Deltaglider in low earth orbit and then do a simple test with the DV program doing a random short burn, then this indeed works and the remaining DV drops correctly ending with a correct AB cut-off.
But that is very different with the added scenario here.
Attached Files
File Type: scn Deltaglider_Earth_to_Moon01.scn (2.8 KB, 5 views)

Last edited by Eduard; 12-18-2016 at 05:27 PM.
Eduard is offline   Reply With Quote
Old 12-18-2016, 06:02 PM   #27
boogabooga
Bug Crusher
 
boogabooga's Avatar
Default

Weird.

I can confirm the error when I use Eduard's scenario. But it has been working for me otherwise.

I haven't found anything different about Eduard's scenario, except altitude.
boogabooga is offline   Reply With Quote
Old 12-19-2016, 12:40 AM   #28
jarmonik
Beta Tester

Default

The DeltaVelocity appears to be working if the reference frame is changed from "Vel.Frame" to "P30 LVLH". But I have no idea what's going on there and from where the problems are originating. I really haven't touched that code during the past 10 years.
jarmonik is offline   Reply With Quote
Old 12-19-2016, 06:19 PM   #29
Eduard
Orbinaut
Default

Quote:
Originally Posted by jarmonik View Post
 The DeltaVelocity appears to be working if the reference frame is changed from "Vel.Frame" to "P30 LVLH". But I have no idea what's going on there and from where the problems are originating. I really haven't touched that code during the past 10 years.
Ah, now we can start understanding things ...

I tried the "P30 LVLH" setting in my testscenario now and it works indeed well (of course to get the right trajectory correction I had to ajust all settings again, but it works).

Very important detail: The screnario is just outside of Earth's major SOI, so the dominant body is the Sun there.

Realising this leads us to the following question:
When we forward until whe are in the Moon's major SOI, does "Vel.Frame" work correctly then?
Yes, it does. I tested it, the remaining DV goes down in the right way and the AB automatically cuts off.

This SOI issue explains why the burns in LEO go well.
Only when the Sun is the dominant body, "Vel.Frame" goes wrong.
Eduard is offline   Reply With Quote
Thanked by:
Old 12-21-2016, 02:16 AM   #30
boogabooga
Bug Crusher
 
boogabooga's Avatar
Default

Out of curiosity, what happens if you disable the wind or terrain? If the problem is specific to Orbiter 2016, perhaps the cause is as well. If IMFD somehow assumes smooth spheres with no wind, even if unintentionally, there will be problems.

Something to test.

---------- Post added at 09:16 PM ---------- Previous post was at 07:24 PM ----------

Edit:
Disabling wind and terrain had no effect.

Quote:
Originally Posted by Eduard View Post
 Very important detail: The screnario is just outside of Earth's major SOI, so the dominant body is the Sun there....Only when the Sun is the dominant body, "Vel.Frame" goes wrong.

The "Vel. Frame" reference does work again if you switch the reference body in "Delta Velocity" to "sun". So probably from now on we just have to be careful in IMFD to make sure our reference is actually the same as our actual current major body. This was probably always a good idea, but seems there was more tolerance in Orbiter 2010.
boogabooga is offline   Reply With Quote
Thanked by:
Reply

  Orbiter-Forum > Orbiter Addons > Addons


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 12:55 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.