Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Support & Bugs
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Addon Support & Bugs Support & bug reports for Orbiter addons.

Reply
 
Thread Tools
Old 05-28-2015, 08:16 PM   #1
Wolf
Donator
 
Wolf's Avatar
Default ISS AtoZ S6 truss

I noticed that one of the grapple points of the S6_PV truss (grapple fixture n.2 - "bottom") has something wrong in the values (direction or rotation values) that make it impossible to grapple. This also shown when enabling the "show grapple fixture" function using the RMS: the related red arrow points into the opposite direction (from inside the truss towards the fixture and not vice versa) hence making it impossible to grapple from the correct direction.
The "top" S6 grapple fixture works ok (Arrow pointing in the right direction) as well as the other station trusses (like P6_PV)
Is there a way to fix this?
It might sound like a trivial issue but the bottom grapple fixture is needed in order to perform the S6 handoff from Canadarm2 to the shuttle RMS during STS-119 mission: this is where I am stuck now with the mission: unable to supply full power to the ISS

Last edited by Wolf; 05-28-2015 at 08:18 PM.
Wolf is offline   Reply With Quote
Old 05-28-2015, 09:47 PM   #2
Donamy
Beta Tester


Default

I'll check it out, and get back to you.

---------- Post added at 09:47 PM ---------- Previous post was at 09:08 PM ----------

Try adding this to the pv_S6.cfg in Config/Vessels

Code:
 
BEGIN_ATTACHMENT
P 0 -2.2 -9.145   0 -1 0    0 0 1   XS
P -1.34 1.79 4.62  -0.719205 0.643202 0.262746  -0.00332244 0.377162 
-0.926142  GS
P 1.589 -0.711 4.62  0.866325 -0.000860616 0.49948  0.00315054  
-0.999938 -0.0107259  GS
P 0 0.39 6.97   0 1 0    0 0 1   XS
END_ATTACHMENT
Donamy is offline   Reply With Quote
Thanked by:
Old 05-29-2015, 07:11 PM   #3
Wolf
Donator
 
Wolf's Avatar
Default

Quote:
Originally Posted by Donamy View Post
 I'll check it out, and get back to you.

---------- Post added at 09:47 PM ---------- Previous post was at 09:08 PM ----------

Try adding this to the pv_S6.cfg in Config/Vessels

Code:
 
BEGIN_ATTACHMENT
P 0 -2.2 -9.145   0 -1 0    0 0 1   XS
P -1.34 1.79 4.62  -0.719205 0.643202 0.262746  -0.00332244 0.377162 
-0.926142  GS
P 1.589 -0.711 4.62  0.866325 -0.000860616 0.49948  0.00315054  
-0.999938 -0.0107259  GS
P 0 0.39 6.97   0 1 0    0 0 1   XS
END_ATTACHMENT
It doesn't work for me. The red grapple point Arrow is there now and it points towards the fixture from outside the truss (like it should be) but the RMS can't grapple it.
Don't know if it is related but when enabling the "show grapple points" feature from the RMS dialog box the red Arrow has a weird shape (like it is slightly out of square and subject to distortion)

here is the grapple attempt with RMS (as you can see in the RMS dialog box grappling is NOT enabled despite the LEE being in correct position)

Attachment 13735

and here is how the grapple arrow looks

Attachment 13736

Last edited by Wolf; 05-31-2018 at 10:09 AM.
Wolf is offline   Reply With Quote
Old 05-29-2015, 07:48 PM   #4
Donamy
Beta Tester


Default

This is what I see.

What S6 are you using ?

Also, why does the RMS have a red and blue arrow? Is it attached to something already ?
Attached Thumbnails
s6grapple.jpg  

Last edited by Donamy; 05-29-2015 at 07:53 PM.
Donamy is offline   Reply With Quote
Old 05-30-2015, 05:29 PM   #5
Wolf
Donator
 
Wolf's Avatar
Default

Quote:
Originally Posted by Donamy View Post
 What S6 are you using ?
Also, why does the RMS have a red and blue arrow? Is it attached to something already ?
I use the S6 truss that comes with ISS AtoZ (S6_PV:pv_s6)

I believe the red arrow on the RMS is due to the fact that I am using the RMS light with the Shuttle Fleet RMS(deleting the light also deletes the red arrow)

I took a shot of the S6 with a perspective similar to yours and the Arrow looks definetly misaligned


Attachment 13740

Last edited by Wolf; 05-31-2018 at 10:09 AM.
Wolf is offline   Reply With Quote
Old 05-30-2015, 06:47 PM   #6
Donamy
Beta Tester


Default

If you placed the attachments into the .cfg properly, then I am stumped.

Poscik coded the S6_pv from my SC3 one. That's why you have to add the attachments
Donamy is offline   Reply With Quote
Old 05-30-2015, 07:17 PM   #7
Wolf
Donator
 
Wolf's Avatar
Default

This is the cfg/vessel/pv_s6 modified with the attachment.
Is there anything wrong I've done with it?




Code:
ClassName = pv_s6
Module = pv_s6


BEGIN_ATTACHMENT
P 0 -2.2 -9.145   0 -1 0    0 0 1   XS
P -1.34 1.79 4.62  -0.719205 0.643202 0.262746  -0.00332244 0.377162 
-0.926142  GS
P 1.589 -0.711 4.62  0.866325 -0.000860616 0.49948  0.00315054  
-0.999938 -0.0107259  GS
P 0 0.39 6.97   0 1 0    0 0 1   XS
END_ATTACHMENT
I also have a question: do you have the same problem with this grapple point without editing the Cfg./vessel with the attachment?

Last edited by Wolf; 05-30-2015 at 07:23 PM.
Wolf is offline   Reply With Quote
Old 05-30-2015, 07:22 PM   #8
DaveS
Addon Developer
 
DaveS's Avatar


Default

Try this instead:

Code:
ClassName = pv_s6
Module = pv_s6


BEGIN_ATTACHMENT
P 0 -2.2 -9.145   0 -1 0    0 0 1   XS
P -1.34 1.79 4.62  -0.719205 0.643202 0.262746  -0.00332244 0.377162 -0.926142  GS
P 1.589 -0.711 4.62  0.866325 -0.000860616 0.49948  0.00315054  -0.999938 -0.0107259  GS
P 0 0.39 6.97   0 1 0    0 0 1   XS
END_ATTACHMENT
This has the attachment points on one line, something Donamy's code paste didn't. By not having all of the data on one line could confuse Orbiter.
DaveS is online now   Reply With Quote
Thanked by:
Old 05-30-2015, 07:25 PM   #9
Wolf
Donator
 
Wolf's Avatar
Default

Thanks Dave I'll try that

It does work now!

Thank you Dave for your tip! and thanks Donamy for your patience and support to my issues with ISS AtoZ

Last edited by Wolf; 05-30-2015 at 07:30 PM.
Wolf is offline   Reply With Quote
Thanked by:
Reply

  Orbiter-Forum > Orbiter Addons > Addon Support & Bugs


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 01:29 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.