Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > MFD Questions & Help
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

MFD Questions & Help Post your questions here for help with the Multi-Function Displays.

Reply
 
Thread Tools
Old 06-19-2018, 09:49 PM   #1
ReSoTe
Orbinaut
Default Can't get MMExt add-ons to work

Hi! I tried to install some add-ons but the ones which use Module Messaging Extended library don't work. Game starts as intended but when I click on the TransX button on Module Select Screen - program crashes.
Code:
**** Orbiter.log
000000.000: Build Aug 28 2016 [v.160828]
000000.000: Timer precision: 3.01349e-007 sec
000000.000: Found 1 joystick(s)
000000.000: Module AtlantisConfig.dll .... [Build 160828, API 160828]
000000.000: Module AtmConfig.dll ......... [Build 160828, API 160828]
000000.000: Module DGConfigurator.dll .... [Build 160828, API 160828]
000000.000: Module D3D9Client.dll ........ [Build 170705, API 160828]
000000.000: Module OrbiterSound.dll ...... [Build 121120, API 100830]
000000.000: Module TransX2.dll ........... [Build 180405, API 160828]
000000.000: Module BurnTimeMFD.dll ....... [Build 180514, API 160828]
=====================================================
000000.000: Finished initialising status
000000.000: Finished initialising camera
000000.000: Finished setting up render state
000000.000: D3D9: [Scene Initialized]
000000.000: Finished initialising panels
000000.000: ---------------------------------------------------------------
000000.000: >>> WARNING: Obsolete API function used: VESSEL::GetHorizonAirspeedVector
000000.000: At least one active module is accessing an obsolete interface function.
000000.000: Addons which rely on obsolete functions may not be compatible with
000000.000: future versions of Orbiter.
000000.000: ---------------------------------------------------------------
D3D9: ERROR: SurfHandle=0x8613138, Never use Sketchpad::GetDC() hDC not available
When I try to start Orbiter with BurnTimeCalcMFD it won't even get to the end of the loading screen.
I've already tried installing different versions of the VS redistributable files (32-bit), it doesn't seem to make any difference.

Thanks and I hope it's possible to solve this problem.
Attached Files
File Type: log TransX2.log (5.8 KB, 4 views)
File Type: log With BurnTimeMFD.log (5.3 KB, 1 views)
ReSoTe is offline   Reply With Quote
Thanked by:
Old 06-20-2018, 12:15 AM   #2
ADSWNJ
Scientist
 
ADSWNJ's Avatar
Default

Did you install this: https://www.orbithangar.com/searchid.php?ID=6889 ?

I cannot see any reference to this in your logs, so I suspect not. Happy to help you get this working, as one of the co-authors of this utility.
ADSWNJ is offline   Reply With Quote
Old 06-20-2018, 08:57 AM   #4
ReSoTe
Orbinaut
Default

Quote:
Originally Posted by ADSWNJ View Post
 Did you install this: https://www.orbithangar.com/searchid.php?ID=6889 ?

I cannot see any reference to this in your logs, so I suspect not. Happy to help you get this working, as one of the co-authors of this utility.
Sorry, didn't notice that I unchecked it. I tried different combinations of modules because there was no information about some of them in the instruction I followed. The list of modules I used for TransX-MMExt.log is in the modules.png

Enjo, yes, all of them work.
And I made a mistake - didn't install BaseSync before BurnTimeCalc. But even after that I can't get the program to load properly.
Installed the Service Pack and tried again, the result is still the same.
Then it must be something about TransX and BurnTimeCalc?
Attached Thumbnails
modules.png  
Attached Files
File Type: log TransX-MMExt.log (5.0 KB, 2 views)
File Type: log BaseSync.log (5.7 KB, 1 views)
File Type: log Glideslope.log (6.9 KB, 1 views)
File Type: log BurnTime with BaseSync.log (6.2 KB, 2 views)
ReSoTe is offline   Reply With Quote
Old 06-21-2018, 03:36 AM   #5
ADSWNJ
Scientist
 
ADSWNJ's Avatar
Default

ok good - we are making progress! You can now see the expected MMExt lines in the logs, and you have a good install there.

Next thing you can do: in the simulation, bring up the MMExt MFD. You can see two types of things in here: the data elements (with values when they are non-struct data types), and the activity log.

See what you see in the activity log. Bring up MMExt first, then BurnTime, then BaseSync, and see what happens.
ADSWNJ is offline   Reply With Quote
Old 06-21-2018, 07:05 AM   #6
Enjo
Mostly harmless
 
Enjo's Avatar


Default

Quote:
Originally Posted by ReSoTe View Post
 Then it must be something about TransX and BurnTimeCalc?
It appears so. I will be at my development PC on the 7th of July. I'll see what I can do for you then.
Enjo is offline   Reply With Quote
Old 06-21-2018, 07:50 AM   #7
ReSoTe
Orbinaut
Default

Quote:
Originally Posted by ADSWNJ View Post
 See what you see in the activity log. Bring up MMExt first, then BurnTime, then BaseSync, and see what happens.
Can't activate BurnTime cause the program doesn't launch with it. But the activity log of BaseSync is in the Activity.png
My mistake, BurnTime with BaseSync.log would've to be named BurnTime with MMExt MFD.
Found another bug (?): if the log in MMExt MFD is already clear and you press Next or Previous buttons - program crashes. Is it reproducible on other machines? The log is in the attachments.

Enjo, thank you! But it appears that no one else has this problem, at least I didn't find it on the forum. Maybe it's possible to fix it on my side.
Attached Thumbnails
Activity.png  
Attached Files
File Type: log Orbiter.log (6.8 KB, 4 views)

Last edited by ReSoTe; 06-21-2018 at 08:26 AM.
ReSoTe is offline   Reply With Quote
Old 06-22-2018, 01:32 AM   #8
ADSWNJ
Scientist
 
ADSWNJ's Avatar
Default

mmext mfd crashing on a next/prev with no data ... that's on me!
ADSWNJ is offline   Reply With Quote
Thanked by:
Old 06-22-2018, 05:03 PM   #9
Enjo
Mostly harmless
 
Enjo's Avatar


Default

I think I know where the problem is. See here:
https://www.orbiter-forum.com/showth...9&postcount=38

Please be available in two weeks for a retest.
Enjo is offline   Reply With Quote
Thanked by:
Old 06-22-2018, 06:33 PM   #10
ReSoTe
Orbinaut
Default

Quote:
Originally Posted by Enjo View Post
 I think I know where the problem is. See here:
https://www.orbiter-forum.com/showth...9&postcount=38

Please be available in two weeks for a retest.
Will be!
Does it matter that the actions described here are causing the same problem, wasn't it fixed?
Quote:
Originally Posted by turtle91 View Post
 -load "DG-S ready o take off to ISS" or any other default scenario
-open HudDrawerMFD
=no issues
-open another MFD to move HudDrawerMFD out of the picture
-open LaunchMFD
-open again...HudDrawerMFD
=CTD

Same scenario again, but other procedure-order:
-open LaunchMFD
-open HudDrawerMFD
=CTD
ReSoTe is offline   Reply With Quote
Old 06-24-2018, 10:04 PM   #11
ADSWNJ
Scientist
 
ADSWNJ's Avatar
Default

See updated v2.1d versions of ModuleMessagingExt in the Orbithangar (for Orbiter 2010 and 2016), fixing the PRV/NXT with no data bug.
ADSWNJ is offline   Reply With Quote
Thanked by:
Old 06-25-2018, 04:38 AM   #12
Enjo
Mostly harmless
 
Enjo's Avatar


Default

Quote:
Originally Posted by ReSoTe View Post
 Will be!
Does it matter that the actions described here are causing the same problem, wasn't it fixed?
Yes. I had broken it by bundling the VC++ redistributable into my modules. Then I forgot about this and made the same mistake again.
Enjo is offline   Reply With Quote
Thanked by:
Old 06-26-2018, 12:13 AM   #13
ADSWNJ
Scientist
 
ADSWNJ's Avatar
Default

Quote:
Originally Posted by Enjo View Post
 Yes. I had broken it by bundling the VC++ redistributable into my modules. Then I forgot about this and made the same mistake again.
What specifically is breaking, Enjo? Interested in what you have found here.
ADSWNJ is offline   Reply With Quote
Old 06-26-2018, 06:58 AM   #14
Enjo
Mostly harmless
 
Enjo's Avatar


Default

Andrew: See here.
Enjo is offline   Reply With Quote
Old 07-06-2018, 01:55 PM   #15
Enjo
Mostly harmless
 
Enjo's Avatar


Default

ReSoTe:
Please test the attached pre-releases.
Thanks in advance!
Attached Files
File Type: zip TopographicMapMFD-v.0.7-2016.zip (701.1 KB, 3 views)
File Type: zip TransX-2018.05.06-VCpp-2016.zip (1,005.6 KB, 2 views)
File Type: zip BurnTimeCalcMFD-v.3.1.0-2016.zip (4.37 MB, 2 views)
File Type: zip LaunchMFD-v.1.6.6-2016.zip (4.62 MB, 5 views)
File Type: zip HUDDrawerSDK-v.0.5-2016.zip (226.7 KB, 5 views)
Enjo is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > MFD Questions & Help

Tags
crash, modulemessagingext, transx


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 03:00 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.