Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Hardware & Software Help
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Hardware & Software Help Hardware & Software related questions & help.

Reply
 
Thread Tools
Old 08-22-2008, 05:38 AM   #1
Spacedoughnut
Civil Air Patrol Graduate
 
Spacedoughnut's Avatar
Default Orbiter Crash bug

Hi, I'm new to the site and fairly new to orbiter and I recently found a fatal bug.
This all began when I started a week ago(Orbiter 06 latest version plus patch), I had the DGIV(and requirements) with Hires Planet Textures in the install. I was in low orbit around mars in a DGIV when my computer suddenly restarts for no reason. I didn't know the cause and decided to restart the launch pad and a different scenario. Nothing, I played play DG with no sound or editor or nothing and it still crashed. I did a clean install with the backup in my files and tried it on a completely clean install (base +patch latest, I apologise for not being more specific). And it Restarts my computer again. Any advise

I'm not very good at submitting bug reports. But long story short about 5 seconds after I start any scenario on a clean install it reboots my computer.
I checked and my DirX ver. is correct and I'm not entirely sure how to get system specs.

I hope that was enough.
-Space Doughnut

Last edited by Spacedoughnut; 08-22-2008 at 06:26 AM. Reason: Wrong Location*Fixed*
Spacedoughnut is offline   Reply With Quote
Old 08-22-2008, 06:08 AM   #2
dbeachy1
O-F Administrator
 
dbeachy1's Avatar


Default

No worries, I moved the thread.

What operating system are you running; e.g., is it Windows XP? Also, what video card do you have? If you are running XP and your computer reboots spontaneously, 90% of the time it is due to hardware problems. However, it could also be caused by a buggy video card driver, although that will usually cause a blue screen instead of a reboot. Do you ever get blue screens or reboots in other apps, such as games?

In any case, if your system is rebooting it is a driver/hardware problem and not an Orbiter/add-on problem. Did your system used to work and now it doesn't?
dbeachy1 is offline   Reply With Quote
Old 08-22-2008, 06:25 AM   #3
Spacedoughnut
Civil Air Patrol Graduate
 
Spacedoughnut's Avatar
Default

Strangely it only happens in orbiter. I'm Running Windows Xp. It doesn't happen in other games.(They're just slow I don't know if that has anything to do with it). I started playing it mid July and started playing again about a week ago and the problem started 3 or so days ago.

(I'm getting my rig off my Xfire page sorry about it being so big, I cant figure out how to resize it.)
Manufacturer: Dell Inc.
Processor: Intel(R) Pentium(R) 4 CPU 3.20GHz
Memory: 1022MB RAM
Hard Drive: 320 GB
Video Card: NVIDIA GeForce 6800 Series GPU
Monitor: Plug and Play Monitor
Sound Card: SB Audigy 2 ZS Audio [DCC0]
Speakers/Headphones: somthing really good
Keyboard: USB Root Hub
Mouse: USB Root Hub
Mouse Surface: Dell.com comfort pad
Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_gdr.070227-2254)
Motherboard:
Computer Case:
Spacedoughnut is offline   Reply With Quote
Old 08-22-2008, 06:34 AM   #4
SlyCoopersButt
Orbinaut
Default

Looks like a nice computer. Try posting your orbiter.txt log which is a text file in the directory of orbiter installation. May be a chance it could say something that could help diagnose the issue.
SlyCoopersButt is offline   Reply With Quote
Old 08-22-2008, 06:37 AM   #5
Spacedoughnut
Civil Air Patrol Graduate
 
Spacedoughnut's Avatar
Default

Quote:
Originally Posted by SlyCoopersButt View Post
 Looks like a nice computer. Try posting your orbiter.txt log which is a text file in the directory of orbiter installation. May be a chance it could say something that could help diagnose the issue.
Thanks, but the 56k connection just kills it.

**** Orbiter.log
Build Sep 29 2006 [v.060929]
Found 0 joystick(s)
Module AtlantisConfig.dll [API v.060425]
Module DGConfig.dll [API v.060425]
Module ScnEditor.dll [API v.060425]
Module TrackIR.dll [API v.060425]
TrackIR module not found.
Module Rcontrol.dll [API v.050206]
Module OrbiterSound.dll [API v.060425]
Module Meshdebug.dll [API v.060425]
Module Framerate.dll [API v.050206]
Module FlightData.dll [API v.050206]
Module ExtMFD.dll [API v.060425]
Module CustomMFD.dll [API v.060425]

**** Creating simulation session
DirectDraw interface OK
Direct3D interface OK
Zbuffer: 16 bit
Render device: Fullscreen 800 x 600
Device has no hardware T&L capability
Module Sun.dll [API v.050206]
VSOP87(E) Sun: Precision 1e-006, Terms 554/6634
Module Mercury.dll [API v.050206]
VSOP87(B) Mercury: Precision 1e-005, Terms 167/7123
Module Venus.dll [API v.050206]
VSOP87(B) Venus: Precision 1e-005, Terms 79/1710
Module Earth.dll [API v.050206]
VSOP87(B) Earth: Precision 1e-008, Terms 2564/2564
Module Moon.dll [API v.041022]
ELP82: Precision 1e-005, Terms 116/829
Module Mars.dll [API v.060425]
VSOP87(B) Mars: Precision 1e-005, Terms 405/6400
Module Phobos.dll [API v.060425]
Module Deimos.dll [API v.060425]
Module Galsat.dll [API v.041022]
Module Jupiter.dll [API v.050206]
VSOP87(B) Jupiter: Precision 1e-006, Terms 1624/3625
Module Io.dll [API v.041022]
Module Europa.dll [API v.041022]
Module Ganymede.dll [API v.041022]
Module Callisto.dll [API v.041022]
Module Satsat.dll [API v.050206]
Module Saturn.dll [API v.060425]
VSOP87(B) Saturn: Precision 1e-006, Terms 2904/6365
Module Mimas.dll [API v.050206]
SATSAT Mimas: Terms 113
Module Enceladus.dll [API v.050206]
SATSAT Enceladus: Terms 33
Module Tethys.dll [API v.050206]
SATSAT Tethys: Terms 101
Module Dione.dll [API v.050206]
SATSAT Dione: Terms 59
Module Rhea.dll [API v.050206]
SATSAT Rhea: Terms 68
Module Titan.dll [API v.050206]
SATSAT Titan: Terms 100
Module Hyperion.dll [API v.050206]
SATSAT Hyperion: Terms 595
Module Iapetus.dll [API v.050206]
SATSAT Iapetus: Terms 605
Module Uranus.dll [API v.050206]
VSOP87(B) Uranus: Precision 1e-006, Terms 1827/5269
Module Miranda.dll [API v.060425]
Module Ariel.dll [API v.060425]
Module Umbriel.dll [API v.060425]
Module Titania.dll [API v.060425]
Module Oberon.dll [API v.060425]
Module Neptune.dll [API v.050206]
VSOP87(B) Neptune: Precision 1e-006, Terms 391/2024
Module Triton.dll [API v.060425]
Finished initialising world
Module DeltaGliderIV.dll [API v.060425]
>>> ERROR: Missing texture: U_mmu.dds
>>> [C:\Source\Orbiter\Texture.cpp / 781]
>>> ERROR: Missing texture: U_mmu2.dds
>>> [C:\Source\Orbiter\Texture.cpp / 781]

Finished initialising status
Finished initialising camera
Finished initialising panels
Finished setting up render state

I'm assuming the bold part is the problem?
(in my latest version I have DGIV and all stuff needed for that installed. But it still happens on a clean install)
Spacedoughnut is offline   Reply With Quote
Old 08-22-2008, 06:49 AM   #6
simonpro
Beta Tester
Default

Perhaps your PC is overheating? It's most likely not an orbiter issue, so it could be hardware.
simonpro is offline   Reply With Quote
Old 08-22-2008, 06:51 AM   #7
SlyCoopersButt
Orbinaut
Default

Can't be sure, Not a file I can find with my Ummu. And since you tried a clean install Ummu can't be related. I don't know what it means by the other error line. Someone else might be able to tell you what that is.
SlyCoopersButt is offline   Reply With Quote
Old 08-22-2008, 07:00 AM   #8
Spacedoughnut
Civil Air Patrol Graduate
 
Spacedoughnut's Avatar
Default

Quote:
Originally Posted by SlyCoopersButt View Post
 Can't be sure, Not a file I can find with my Ummu. And since you tried a clean install Ummu can't be related. I don't know what it means by the other error line. Someone else might be able to tell you what that is.
:chair: <<< What I currently want to do to my computer XD
Spacedoughnut is offline   Reply With Quote
Old 08-22-2008, 07:27 AM   #9
SlyCoopersButt
Orbinaut
Default

Out of pure curiosity you might want to try out the latest Orbiter Beta and see if that causes any issue. If that fails on a clean install then there's almost no doubt in my mind it's a computer config/hardware factor. But having dial up however, I can understand it may be very hard and tedious to get. I once had 30k something and I'll never miss it.
SlyCoopersButt is offline   Reply With Quote
Old 08-22-2008, 07:47 AM   #10
Spacedoughnut
Civil Air Patrol Graduate
 
Spacedoughnut's Avatar
Default

Would that be
http://download.orbit.m6.net/mirror.html
by chance?

The funny thing is I used orbiter to pass the time on all of my downloads since I got it. What ever happened to MP? That would have been bad.
Could you push a ship out of orbit if it was out of fuel and you docked with it? Which brings me to something else. Is there a collision addon (where if you hit the ground you loose operation of the craft or something like that).
Spacedoughnut is offline   Reply With Quote
Old 08-22-2008, 09:01 AM   #11
James.Denholm
Addon ponderer
Default

On the crash issue, I like what simonpro said. Open up your computer, voiding all warranties, and CHECK FOR DUST! If it seems dusty, CLEAN IT! But don't use water.
James.Denholm is offline   Reply With Quote
Old 08-22-2008, 09:41 AM   #12
Tschachim
Beta Tester
 
Tschachim's Avatar


Default

Quote:
Originally Posted by Spacedoughnut View Post
 **** Orbiter.log
...
Render device: Fullscreen 800 x 600
Device has no hardware T&L capability
Also you might want to check Orbiters Video configuration by checking "Always enumerate devices" and choosing the "Direct3D T&L HAL ( NVIDIA GeForce 6800)" (or something like this) device and/or check your graphic adapter driver.

Cheers
Tschachim
Tschachim is offline   Reply With Quote
Old 08-22-2008, 12:09 PM   #13
n122vu
Addon Developer
 
n122vu's Avatar

Default

Additionally, I would check your sound drivers while you're at it. Make sure you have the latest drivers for your Audigy card. It could be that Orbiter is crashing when it attempts to play a certain sound. I have seen sound drivers do funny things like this. I've also seen bad memory be the culprit in situations like this too.

It could be any number of things. I would especially look at the settings Tschachim mentioned, as that seems like the most likely culprit. I wouldMaybe even try reinstalling the DGIV package, and even though the latest comes with UMmu, maybe install the UMmu standalone package as well just to see if it removes the missing dds errors from the log. (That's probably not really necessary, just me being AR/OCD, but hey, it couldn't hurt )
n122vu is offline   Reply With Quote
Old 08-22-2008, 03:03 PM   #14
Arrowstar
Probenaut
 
Arrowstar's Avatar
Default

It does look like you're missing UMMU files from that Orbiter log you posted... perhaps try installing the latest version of UMMU? I know DGIV is supposed to come with it, but it may help. And if not, well... then there's still what everyone else said.
Arrowstar is offline   Reply With Quote
Old 08-24-2008, 12:56 AM   #15
Spacedoughnut
Civil Air Patrol Graduate
 
Spacedoughnut's Avatar
Default

THANK YOU! The enumeration worked well and I'm now on my first trip to the moon, once I figure out how to get into orbit. To all
Spacedoughnut is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Hardware & Software Help


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 06:35 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.