Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Web Forum
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Orbiter Web Forum A forum for general Orbiter-related comments and discussion. Post your questions about Orbiter and addons in the appropriate forums below. Upload your Orbiter screen shots to our gallery HERE!

Reply
 
Thread Tools
Old 02-03-2018, 11:48 AM   #31
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Well right now. I can do ms2015 shuttle with different shuttle.dll.

But I saw the issue about reusing textures.

I am not sure about the rms arm. Can we use it?
gattispilot is offline   Reply With Quote
Old 02-03-2018, 08:25 PM   #32
Donamy
Beta Tester


Default

Would take some recoding, but yes.
Donamy is offline   Reply With Quote
Old 02-04-2018, 12:21 AM   #33
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Thanks. Trying to figure out how to open the SSU bay doors to see the difference. Also what to add vc camera on the SRB and tanks
gattispilot is offline   Reply With Quote
Old 02-04-2018, 05:01 AM   #34
DaveS
Addon Developer
 
DaveS's Avatar


Default

Quote:
Originally Posted by gattispilot View Post
 Thanks. Trying to figure out how to open the SSU bay doors to see the difference.
  1. R13L: PL BAY DOOR SYS A/SYS B "ENABLE"
  2. R13L: PL BAY DOOR "OPEN"
That's it. You have to wait for the centerline latches and the bulkhead latches to fully open before you'll see any motion of the doors.

The 16 centerline latches are grouped into so called "gangs" and each gang consists of 4 latches each. Each latch gang takes approx. 20 seconds to open/close. The centerline latches are driven in pairs of two gangs each, so the total drive time is 40 seconds.

Then there is the forward and aft bulkhead latches. These have a drive time of 30 seconds. So expect a total elapsed time of 70 seconds before you'll see any motion of the starboard door during the opening sequence.

---------- Post added at 06:01 AM ---------- Previous post was at 05:22 AM ----------

This is a demonstration video of the PLBD opening sequence:

DaveS is offline   Reply With Quote
Thanked by:
Old 02-04-2018, 12:23 PM   #35
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

So I found a scenario with the bay doors open already. Yes your rms has more detail. Not sure how to add it to the Atlantis mesh? Do you have the arm as a separate mesh or 3ds?

I got it:

Last edited by gattispilot; 02-04-2018 at 01:20 PM.
gattispilot is offline   Reply With Quote
Old 02-05-2018, 08:14 PM   #36
barrygolden
Orbinaut
 
barrygolden's Avatar
Default

Super start to the shuttle. You payload guys get ready to pitch in and make this a super addon. Thanks again gattis for your work on this.
barrygolden is offline   Reply With Quote
Thanked by:
Old 02-24-2018, 01:04 AM   #37
camelopardis
Donator
Default

Hi!

I'm old user camelopardis, I've been away from Orbiter a very long time. Some days ago user Gazza sent me a PM, and here I am again! Good to see you all are active, I recognize a lot of members from back then. Good memories.

We've been testing together to make the Pylon addon work in Orbiter2010 and 2016. I've published it in a Github repo. Here you can find the sources and compiled dlls:

https://github.com/yomboprime/Pylon

I hope it can be useful to bring old addons to life. I will be developing other things as well

Last edited by camelopardis; 02-24-2018 at 04:29 AM.
camelopardis is offline   Reply With Quote
Old 02-24-2018, 02:23 AM   #38
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Great. So should we continue with getting the shuttle updated?
gattispilot is offline   Reply With Quote
Old 02-24-2018, 02:39 AM   #39
camelopardis
Donator
Default

Quote:
Originally Posted by gattispilot View Post
 Great. So should we continue with getting the shuttle updated?
Hi gattispilot.

I think so. I only did the Pylon addon, not the STS Payloads. I haven't got a clear idea of the current state, if it is the Shuttle that is being updated, or the missions, or both. I've got a confusion on all the vessels involved, and already had it 13 years ago. User Gazza will tell you better, please talk with him. It could be great to agree and work together.
camelopardis is offline   Reply With Quote
Old 02-24-2018, 03:12 AM   #40
Gazza
Orbinaut
Default

Quote:
Originally Posted by camelopardis View Post
 Hi!

I'm old user camelopardis, I've been away from Orbiter a very long time.
Nice to see you public again camelopardis on the orbiter forum

As camelopardis already stated. Pylon is now working in O2010 and O2016. I have also been working on STS Payloads v3.

The last week, i and camelopardis have been working on the pylon fixes and bugs to get STS Payloads v2.01 stable in O2010/16 and it has been successful. There may be some smaller issues still to be fix, as O2010 and O2016 can have different results with pylon, but the main issues are so far resolved.

STS Payloads v3 will include brand new/updated meshes and textures, also updated textures to work with the D3D9 Client. Included, will be STS Payloads 'part 2', which has been sitting on my hard drive for over 10 years. This will also be updated to O2010/O2016 standards. The pylon sequences are being reworked for better performance and features and also(hopefully) my install and readme notes! STS Payloads v3 will be made for O2010 and O2016.

David413 worked really hard to get STS Payloads working in O2010 with the fleet, i will also upload a patch, so STS Payloads 2010R0 can take advantage of my new payloads. This patch will have the same missions/files but with updated meshes/textures from STS Payloads v3 and will also benefit from the D3D9 client. Before, the complete STS Payloads v2.01 had to be downloaded and installed. With this patch, it will just require the files needed to run STS Payloads 2010R0 as intended!

Obviously plans can change. If we get a new or updated fleet in orbiter 2016, then the 2010 packages probably won't be needed, but camelopardis has been busy debugging pylon for both orbiter versions. So at this time, STSPv3 will use O2010 and O2016.

The pylon launch tower is also back. ATM it uses Slats 2006.3 addon meshes and textures. I know there are more detailed launch towers out there, but we see what happens at a later time.

The STS-VC, done it's job in 2006, but it's really not needed in O2010/16. The only downside is the custom sounds will be gone. I'm unsure if Orbitersound 4 can assign sounds from one vessel to another vessel, or the pylonMFD when active, can play these sounds in a different vessel, ie the shuttle.

Quote:
Originally Posted by gattispilot View Post
 Great. So should we continue with getting the shuttle updated?
We really need a fleet for Orbiter 2016. But old members have come back, including myself and camelopardis. Vinka's SC5 is waiting around the corner, as well as others probably waiting for O2016p1.

Thanks

Last edited by Gazza; 02-24-2018 at 11:16 AM. Reason: clarity
Gazza is offline   Reply With Quote
Thanked by:
Old 02-24-2018, 05:05 AM   #41
Donamy
Beta Tester


Default

I feel like I've stepped through a time machine.
Donamy is offline   Reply With Quote
Thanked by:
Old 02-24-2018, 05:10 AM   #42
camelopardis
Donator
Default

Quote:
Originally Posted by Donamy View Post
 I feel like I've stepped through a time machine.


In what direction?
camelopardis is offline   Reply With Quote
Thanked by:
Old 02-24-2018, 01:11 PM   #43
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Well then I guess we will continue. We have Columbia with old rms arm with baylights and eva.

I am trying to get the New rms arm and camera and lights to work.

RMS works but I can't get the beacon, camera to follow the animation.

Code:
	static UINT RMSEndEffectorGrp[1] = { GRP_Endeffector };
	rms_anim[5] = new MGROUP_ROTATE(midx, RMSEndEffectorGrp, 1,
		RMS_EE_POS, _V(0, 0, 1), (float)(894 * RAD));  // -447 .. +447
	anim_arm_wr = CreateAnimation(0.5);
	parent = AddAnimationComponent(anim_arm_wr, 0, 1, rms_anim[5], parent);
	
	rms_anim[6] = new MGROUP_ROTATE(LOCALVERTEXLIST, MAKEGROUPARRAY(arm_tip), 5,
		RMS_EE_POS, _V(0, 0, 1), (float)(0.0));  // -447 .. +447
	//MGROUP_ROTATE* pRMS_ee_anim = new MGROUP_ROTATE(LOCALVERTEXLIST, MAKEGROUPARRAY(arm_tip), 6,
	//RMS_EE_POS, _V(0, 0, 1), (float)(0.0));
	anim_rms_ee =CreateAnimation(0.0);
	hAC_arm = AddAnimationComponent(anim_rms_ee, 0, 1, rms_anim[6], parent);
5 vertices of the armtip
Code:
arm_tip[0] = RMS_EE_POS;
	arm_tip[1] = RMS_EE_POS + _V(0.0, 0.0, -1.0); // to calculate EE attachment direction (-Z coordinate of attachment point is negative, so subtract 1 here)
	arm_tip[2] = RMS_EE_POS + RMS_Z_AXIS; // to calculate rot vector for attachment
	//arm_tip[3] = RMS_EE_POS + RotateVectorZ(_V(0.0, -1.0, 0.0), RMS_ROLLOUT_ANGLE); // to calculate arm_ee_rot (rot vector in IK frame)
	arm_tip[3] = RMS_EE_CAM_POS; // to calculate EE camera position
	arm_tip[4] = RMS_EE_LIGHT_POS;
then for the beacon and camera i set the position:
Code:
if (CAM == 6){
		SetCameraDefaultDirection(_V(0, 0, -1));
		SetCameraOffset(arm_tip[3]);
		sprintf(oapiDebugString(), "armtip3x  %2.2f armtip3y %2.2f armtip3z %2.2f", arm_tip[3].x, arm_tip[3].y, arm_tip[3].z);

		oapiCameraSetCockpitDir(0, 0);
	};
same for the beacon:
Code:
void Atlantis::clbkPreStep (double simt, double simdt, double mjd)
{

	spot_beacon[7].pos = &arm_tip[4];
So the points move but the beacon and camera position doesn't move fluidly. Meaning if I press the key for the camera it has moved. So I need something ?
gattispilot is offline   Reply With Quote
Old 02-24-2018, 06:40 PM   #44
Ripley
Tutorial translator
 
Ripley's Avatar
Default

Quote:
Originally Posted by Gazza View Post
 ...Vinka's SC5 is waiting around the corner...
Uh? Is it?
Ripley is offline   Reply With Quote
Old 02-24-2018, 09:10 PM   #45
Gazza
Orbinaut
Default

Quote:
Originally Posted by Ripley View Post
 Uh? Is it?
It's been mention on the forum, that a newer beta version is in the hands of a special member for testing.

On another note. Because of differences between D7 and D9 clients, there will be separate scenarios. The Dx7 scenarios will feature the pylon re-entry particle streams as DX9 already takes care of this. The re-entry and post shuttle meshes will feature on both versions.

Testing on Orbiter 2016 with the d3d9 client. I manage to get the shuttle fleet to take off, orbit and do a manual landing in one session. The fleet is much more stable with the dx9 engine, no ideal why.

Thanks
Gazza is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Web Forum


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 03:09 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.