Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Support & Bugs
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Addon Support & Bugs Support & bug reports for Orbiter addons.

Reply
 
Thread Tools
Old 07-26-2017, 12:42 AM   #1
slaver0110
Orbinaut
 
slaver0110's Avatar
Default Multistage2015 and spacecraft.dll

I finally decided to dive-in and take a shot at Multistage, and so for all has gone well. I'm using MS2015 for Orbiter2016, and thus far I have a two-stage launcher working no problem.
The problem I'm having is with the payload.
Since I'm well-familiar with Spacecraft3/4, I put together a simple mesh (for testing purposes) and a Spacecraft4 vessel (called "RakitCapsule") to go with it.
In Orbiter, the Capsule mesh shows up, and the whole vehicle launches perfectly, until it's time to jettison the payload, which results in a CTD.
The Orbiter.log file gives the following error:

Code:
000018.430: >>> ERROR: No vessel class configuration file found for:
ERROR: ===========================
Spacecraft\RakitCapsule
[Vessel::OpenConfigFile | .\Vessel.cpp | 243]
I checked the Mesh file name, and it's correlation in the Spacecraft and Multistage.ini files, and they're a match.
As nearly as I can see, all is where it's supposed to be.

In Config\Spacecraft\RakitCapsule.ini:
Code:
[PARTICLESTREAM_1]
NAME=engine
SRCSIZE=0.2
SRCRATE=1600
V0=100.0
SRCSPREAD=0.05
LIFETIME=0.5
GROWTHRATE=5
ATMSLOWDOWN=3.0
LTYPE=EMISSIVE
LEVELMAP=LVL_SQRT
LMIN=0
LMAX=1
ATMSMAP=ATM_PLOG
AMIN=1e-5
AMAX=0.1

[CONFIG]
MESHNAME="Rakit_Capsule"
SIZE=20
EMPTY_MASS=10000
FUEL_MASS=20000
MAIN_THRUST=6e5
RETRO_THRUST=3e5
ATTITUDE_THRUST=2e4
ISP=50000
TRIM=0.05
PMI=(15.5,22.1,7.7)
CW_Z_POS=0.09
CW_Z_NEG=0.09
CW_X=2.
CW_Y=1.4
CROSS_SECTION=(53.0,186.9,25.9)
COG=2.47
PITCH_MOMENT_SCALE=0.00005
BANK_MOMENT_SCALE=0.00005
ROT_DRAG=(1.5,1.5,1.5)
WING_ASPECT=0.7
WING_EFFECTIVENESS=2.5
LAND_PT1=(0,-11,9)
LAND_PT2=(-4,-11,-5)
LAND_PT3=(4,-11,-5)
VISIBLE=1
CAMERA=(0,2.5,7.5)
MAIN_PSTREAM1=engine

[EX_MAIN_0]
OFF=(0,0,-14.5)
DIR=(0,0,-1)
LENGTH=25
WIDTH=1.5
And then in Config\Multistage2015:

Code:
[MISC]
cog=5.0
GNC_Debug=0
Telemetry=0
Focus=0
Thrust_real_pos=0
Vertical_Angle=0.000

[TEXTURE_LIST]
TEX_1=Exhaust_atsme

[STAGE_1]
Height=10.0
Diameter=1.0
EmptyMass=8250
FuelMass=5755
Thrust=255788
BurnTime=120
off=(0.000,0.000,0)
MeshName=Rakit
eng_1=(0,0,-1)
eng_diameter=1.0
PITCHTHRUST=1000
YAWTHRUST=750
ROLLTHRUST=1000
speed=(0.000,0.000,-10.000)
ENG_PSTREAM1=
battery=1.500
Reignitable=0
Eng_tex=
Eng_pstream2=
Eng_dir=(0.000,0.000,1.000)
Module=Stage
Rot_speed=(0.000,0.000,0.000)

[STAGE_2]
Height=5.00
Diameter=1.00
EmptyMass=4125
FuelMass=400
Thrust=100000
BurnTime=60
off=(0.000,0.000,9.88)
MeshName=Rakit_Stage2
eng_1=(0,0,-1)
eng_diameter=1.0
PITCHTHRUST=1000
YAWTHRUST=750
ROLLTHRUST=1000
speed=(0.000,0.000,-10.000)
ENG_PSTREAM1=
battery=1.500
Reignitable=0
Eng_tex=
Eng_pstream2=
Eng_dir=(0.000,0.000,1.000)
Module=Stage
Rot_speed=(0.000,0.000,0.000)

[PAYLOAD_1]
MeshName="RakitCapsule"
off=(0,0,15.9)
Diameter=1.2
Height=1
MASS=500
Module="Spacecraft\Spacecraft3"
Name=Capsule
SPEED=(0,0,2)
RENDER=1
I have the feeling that I'm missing something simple here, but I'm at a loss to find it.
My first guess is that I've defined something incorrectly in one of the .ini files.
So, in the end-run my question comes to: how do I attach a Spacecraft.dll payload to a Multistage rocket?

Sorry if it's been asked before. Cheers, and thanks!!

Last edited by slaver0110; 07-26-2017 at 12:44 AM. Reason: Edited for spelling
slaver0110 is offline   Reply With Quote
Old 07-26-2017, 01:11 AM   #2
PhantomCruiser
Wanderer
 
PhantomCruiser's Avatar

Default

This has gotten me before. But it was many years ago and work has put most of my development processes on hold.

Try this...

Change Name=Capsule to - Name="Capsule"

That's the only thing I can see
PhantomCruiser is offline   Reply With Quote
Old 07-26-2017, 01:55 AM   #3
slaver0110
Orbinaut
 
slaver0110's Avatar
Default

Ok, made the change in Multistage\Rakit.ini.
Now, the error shows up as...
Code:
Mesh file name not provided
[MeshManager::LoadMesh | .\Mesh.cpp | 1237]
I double-checked the .msh file name, and it's right there in Orbeter\Meshes where it should be.
Confusing...
slaver0110 is offline   Reply With Quote
Old 07-26-2017, 02:16 AM   #4
boogabooga
Bug Crusher
 
boogabooga's Avatar
Default

Try this. Change:

Code:
[PAYLOAD_1]
MeshName="RakitCapsule"
off=(0,0,15.9)
Diameter=1.2
Height=1
MASS=500
Module="Spacecraft\Spacecraft3"
Name=Capsule
SPEED=(0,0,2)
RENDER=1
to:

Code:
[PAYLOAD_1]
MeshName="RakitCapsule"
off=(0,0,15.9)
Diameter=1.2
Height=1
MASS=500
Module="Spacecraft\Spacecraft3"
Name=RakitCapsule
SPEED=(0,0,2)
RENDER=1
IIRC, in Spacecraft you have to name things EXACTLY the same as the name of the spacecraft ini file.
boogabooga is offline   Reply With Quote
Old 07-26-2017, 02:31 AM   #5
slaver0110
Orbinaut
 
slaver0110's Avatar
Default

[Bangs head off of desk]
That was it...thank you.
Incorrect assumption on my part that I could be more liberal with the naming. I think that I see how this works now.

Thanks everyone so much, and CHEERS!
slaver0110 is offline   Reply With Quote
Thanked by:
Old 10-08-2017, 12:19 PM   #6
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

So I am trying to get a Atlas5 and Dreamchaser to work. I got her into space but then the issues. When I press J the adapter just disappears. And Then when I press J to release the dream chaser CTD.
Scenario before I press J to seperate the adapter.
Code:
BEGIN_SHIPS
ATLAS5:Multistage2015
  STATUS Orbiting Earth
  RPOS 1806865.937 459570.230 6300967.684
  RVEL -6948.8574 -2750.3176 2193.1340
  AROT -50.799 62.691 38.002
  AFCMODE 7
  PRPLEVEL 0:0.642962
  NAVFREQ 0 0 0 0
  XPDR 0
  CONFIG_FILE Config\Multistage2015\ATLAS5DREAM.ini
  GUIDANCE_FILE Config\Multistage2015\Guidance\DELTA4HVY_GNC.txt
  CONFIGURATION 1
  CURRENT_BOOSTER 4
  CURRENT_STAGE 2
  CURRENT_INTERSTAGE 2
  CURRENT_PAYLOAD 1
  FAIRING 0
  MET 592.567
  GNC_RUN 1
  BATTERY 5093.028384
  GROWING_PARTICLES 
  STAGE_IGNITION_TIME 285.594936
  STAGE_STATE 2
  TELEMETRY_FILE Config\Multistage2015\Telemetry\SLS_57310.61_TLM.txt
  ALT_STEPS 100.0,350.0,1400.0,35000.0
  PEG_PITCH_LIMIT 35.000
  PEG_MC_INTERVAL 0.100
END
MS_Camera:MS_Camera
  STATUS Landed Earth
  POS -80.5908600 28.6371940
  HEADING 0.00
  ALT 19.997
  AROT 61.688 4.494 8.275
  AFCMODE 7
  NAVFREQ 0 0
  TARGET ATLAS5
END
LC41:Vessels/B_SLC41/b_slc41
  STATUS Landed Earth
  POS -80.5828310 28.5834560
  HEADING 180.00
  ALT -0.183
  AROT 151.079 -8.260 -175.462
  AFCMODE 7
  PRPLEVEL 0:1.000000
  NAVFREQ 0 0
  UMB 1 1.0000
END
DREAMCHASER:Spacecraft\Spacecraft3
  STATUS Orbiting Earth
  RPOS 1806834.305 459557.573 6300978.007
  RVEL -6948.8574 -2750.3176 2193.1340
  AROT -50.799 62.691 -141.998
  ATTACHED 0:1,ATLAS5
  AFCMODE 7
  PRPLEVEL 0:1.000000
  NAVFREQ 0 0
  CONFIGURATION 1
  CURRENT_PAYLOAD 0
  SEQ 0 -2 0.000000
  SEQ 6 -2 0.000000
  SEQ 7 -2 0.000000
  SEQ 8 -2 0.000000
  SEQ 9 -2 0.000000
END
END_SHIPS
then I pressed J
Code:
BEGIN_SHIPS
ATLAS5:Multistage2015
  STATUS Orbiting Earth
  RPOS 1734271.193 430857.170 6323354.597
  RVEL -6974.7953 -2756.8398 2100.6638
  AROT -50.790 62.687 38.010
  AFCMODE 7
  PRPLEVEL 0:0.642962
  NAVFREQ 0 0 0 0
  XPDR 0
  CONFIG_FILE Config\Multistage2015\ATLAS5DREAM.ini
  GUIDANCE_FILE Config\Multistage2015\Guidance\DELTA4HVY_GNC.txt
  CONFIGURATION 1
  CURRENT_BOOSTER 4
  CURRENT_STAGE 2
  CURRENT_INTERSTAGE 2
  CURRENT_PAYLOAD 2
  FAIRING 0
  MET 602.994
  GNC_RUN 1
  BATTERY 5082.600974
  GROWING_PARTICLES 
  STAGE_IGNITION_TIME 285.594936
  STAGE_STATE 2
  TELEMETRY_FILE Config\Multistage2015\Telemetry\SLS_57310.61_TLM.txt
  ALT_STEPS 100.0,350.0,1400.0,35000.0
  PEG_PITCH_LIMIT 35.000
  PEG_MC_INTERVAL 0.100
END
MS_Camera:MS_Camera
  STATUS Landed Earth
  POS -80.5908600 28.6371940
  HEADING 0.00
  ALT 19.997
  AROT 61.688 4.494 8.275
  AFCMODE 7
  NAVFREQ 0 0
  TARGET ATLAS5
END
LC41:Vessels/B_SLC41/b_slc41
  STATUS Landed Earth
  POS -80.5828310 28.5834560
  HEADING 180.00
  ALT -0.183
  AROT 151.079 -8.260 -175.462
  AFCMODE 7
  PRPLEVEL 0:1.000000
  NAVFREQ 0 0
  UMB 1 1.0000
END
DREAMCHASER:Spacecraft\Spacecraft3
  STATUS Orbiting Earth
  RPOS 1734239.562 430844.514 6323364.923
  RVEL -6974.7953 -2756.8398 2100.6638
  AROT -50.790 62.687 -141.990
  ATTACHED 0:1,ATLAS5
  AFCMODE 7
  PRPLEVEL 0:1.000000
  NAVFREQ 0 0
  CONFIGURATION 1
  CURRENT_PAYLOAD 0
  SEQ 0 -2 0.000000
  SEQ 6 -2 0.000000
  SEQ 7 -2 0.000000
  SEQ 8 -2 0.000000
  SEQ 9 -2 0.000000
END
ADAPTER:Spacecraft\Spacecraft3
  STATUS Orbiting Earth
  RPOS 1698996.423 439105.620 6249092.961
  RVEL -1.#IND -1.#IND -1.#IND
  AROT -50.793 62.688 -141.992
  AFCMODE 7
  NAVFREQ 0 0
  CONFIGURATION 1
  CURRENT_PAYLOAD 0
END
END_SHIPS
and then when I press J I get a CTD.

ini the atlas5:
Code:
[MISC]
cog=0
GNC_Debug=0
Telemetry=0
Focus=0
Thrust_real_pos=0
Vertical_Angle=0.000

[TEXTURE_LIST]
TEX_1=Exhaust_atsme


[BOOSTER_1]
N=1
MeshName=ATLAS5SRB1
Height=50.000
Diameter=5.1
EmptyMass=26400 
FuelMass=202000 
Thrust=1688000
angle=3.142
off=(0,0.500,4.7500)
BurnTime=150
eng_1=(-2.640486, -3.891533E-02, -16.27811)
eng_diameter=1
ENG_PSTREAM1=exhaust
Speed=(-15.000,0.000,0.000)
Rot_speed=(0.000,0.400,0.000)
Eng_tex=
Eng_pstream2=contrail

[BOOSTER_2]
N=1
MeshName=ATLAS5SRB2
Diameter=5.1
EmptyMass=26400 
FuelMass=202000 
Thrust=1688000
angle=3.142
off=(0,0.000,4.75000)
BurnTime=150
eng_1=(0.000,0.000,-20.000)
eng_diameter=2
ENG_PSTREAM1=exhaust
Speed=(15.000,0.000,0.000)
Rot_speed=(0.000,-0.400,0.000)
Eng_tex=
Eng_pstream2=contrail

[BOOSTER_3]
N=1
MeshName=ATLAS5SRB3
Diameter=5.1
EmptyMass=26400 
FuelMass=202000 
Thrust=1688000
angle=3.142
off=(0,0.000,4.75000)
BurnTime=150
eng_1=(0.000,0.000,-20.000)
eng_diameter=2
ENG_PSTREAM1=exhaust
Speed=(15.000,0.000,0.000)
Rot_speed=(0.000,-0.400,0.000)
Eng_tex=
Eng_pstream2=contrail

[STAGE_1]
Height=43.03
Diameter=5.1
EmptyMass=21,054 
FuelMass=284089
Thrust=4152000
BurnTime=253
off=(0.000,0.000,4.700)
MeshName=ATLAS5CCORE
eng_1=(0, -.7402415, -16.34582)
eng_2=(0, .7402415, -16.34582)
eng_diameter=1
PITCHTHRUST=14193633.100 
YAWTHRUST=14193633.100 
speed=(0.000,0.000,-10.000)
ENG_PSTREAM1=exhaust
battery=1.500
Reignitable=1
Eng_tex=
Eng_pstream2=contrail
Eng_dir=(0.000,0.000,1.000)
Module=Stage
Rot_speed=(0.000,0.000,0.000)

[SEPARATION_12]
Meshname=atlas5adapter
Off=(0.000,0.000,4.5)
Height=5.000
Diameter=8.400
EmptyMass=5650.320
Separation_delay=15.000
Module=stage
Speed=(0.000,0.000,-2.000)
Rot_speed=(0.000,0.000,0.000)

[STAGE_2]
Height=43.03
Diameter=5.1
EmptyMass=2316
FuelMass=20830
Thrust=992000
BurnTime=842
off=(0.000,0.000,4.5)
MeshName=ATLAS5CENTAUR
eng_1=(0,0,17.462)
eng_diameter=1
PITCHTHRUST=56774532.400 
YAWTHRUST=56774532.400 
speed=(0.000,0.000,-19.000)
ENG_PSTREAM1=
battery=1.500
Reignitable=1
Eng_tex=
Eng_pstream2=
Eng_dir=(0.000,0.000,1.000)
Module=Stage
Rot_speed=(0.000,0.000,0.000)
ignite_delay=0.1000

[PAYLOAD_1]
Meshname=DreamChaser\adapter
Off=(0.000,0.000,35.100)
Rotation=(180.000,180.000,0.000)
Height=0.000
Diameter=0.000
Mass=0.000
Module=Spacecraft\Spacecraft3
Name=ADAPTER
Speed=(0.000,0.000,0.000)
Rot_speed=(0.000,0.000,0.000)
Render=1
Live=0

[PAYLOAD_2]
Meshname=DreamChaser\Dreamchaser
Off=(0.000,0.000,40)
Rotation=(180.000,180.000,0.000)
Height=0.000
Diameter=0.000
Mass=10000.000
Module=Spacecraft\Spacecraft3
Name=DREAMCHASER
Speed=(0.000,0.000,0.000)
Rot_speed=(0.000,0.000,0.000)
Render=1
Live=1
and the log:
000000.000: Finished initialising world
000000.000: Module Multistage2015.dll .... [Build 170626, API 160828]
000000.000: Multistage Version: 170506
000000.000: Load State Started
000000.000: ATLAS5: Guidance File present: Config\Multistage2015\Guidance\DELTA4HVY_GNC.txt
000000.000: ATLAS5: Orbit Call Found! Targets: Apogee:200000.0 Perigee:200000.0 Inclination:-29.6 Mode:1.0 GT initial Pitch: 89.3 Abside:200000.0
000000.000: ATLAS5: Config File: C:\Orbiter2016\Config\Multistage2015\ATLAS5DREAM.i ni
000000.000: ATLAS5: Number of Interstages in the ini file: 1
000000.000: ATLAS5: Number of stages in the ini file: 2
000000.000: ATLAS5: Number of boosters group in the ini file: 3
000000.000: ATLAS5: Number of Payloads in the ini file: 2
000000.000: ATLAS5: Texture n.1 Loaded Exhaust_atsme
000000.000: ATLAS5: booster n. 1 Tank Added: 202000.000 kg
000000.000: ATLAS5: booster n. 2 Tank Added: 202000.000 kg
000000.000: ATLAS5: booster n. 3 Tank Added: 202000.000 kg
000000.000: ATLAS5: Stage n. 2 Tank Added: 20830.000 kg
000000.000: ATLAS5: Stage n. 1 Tank Added: 284089.000 kg
000000.000: ATLAS5: Stage n.1 Engine Exhaust Stream Added: exhaust to engine n.1
000000.000: ATLAS5: Stage n.1 Engine Exhaust Stream Added: contrail to engine n.1
000000.000: ATLAS5: Stage n. 1 Engines Exhaust Added--> number of engines: 2 , diameter: 1.000, position x: 0.000 y: -0.740 z: -16.346
000000.000: ATLAS5: Stage n.1 Engine Exhaust Stream Added: exhaust to engine n.2
000000.000: ATLAS5: Stage n.1 Engine Exhaust Stream Added: contrail to engine n.2
000000.000: ATLAS5: Stage n. 1 Engines Exhaust Added--> number of engines: 2 , diameter: 1.000, position x: 0.000 y: 0.740 z: -16.346
000000.000: ATLAS5: Booster Group n.1 Engine Exhaust Stream Added: exhaust to engine n.1
000000.000: ATLAS5: Booster Group n.1 Engine Exhaust Stream Added: contrail to engine n.1
000000.000: ATLAS5: Booster Engines Exhaust Added--> Booster Group: 1 number of engines: 1 , diameter: 1.000, position x: -2.662 y: 0.316 z: -16.228
000000.000: ATLAS5: Booster Group n.2 Engine Exhaust Stream Added: exhaust to engine n.1
000000.000: ATLAS5: Booster Group n.2 Engine Exhaust Stream Added: contrail to engine n.1
000000.000: ATLAS5: Booster Engines Exhaust Added--> Booster Group: 2 number of engines: 1 , diameter: 2.000, position x: 0.000 y: 0.000 z: -19.950
000000.000: ATLAS5: Booster Group n.3 Engine Exhaust Stream Added: exhaust to engine n.1
000000.000: ATLAS5: Booster Group n.3 Engine Exhaust Stream Added: contrail to engine n.1
000000.000: ATLAS5: Booster Engines Exhaust Added--> Booster Group: 3 number of engines: 1 , diameter: 2.000, position x: 0.000 y: 0.000 z: -19.950
000000.000: ATLAS5: Stage n.1 Mesh Preloaded: ATLAS5CCORE
000000.000: ATLAS5: Stage n.1 Mesh Added Mesh: ATLAS5CCORE @ x:0.000 y:0.000 z:0.000
000000.000: ATLAS5: Stage n.2 Mesh Preloaded: ATLAS5CENTAUR
000000.000: ATLAS5: Stage n.2 Mesh Added Mesh: ATLAS5CENTAUR @ x:0.000 y:0.000 z:-0.200
000000.000: ATLAS5: Interstage Mesh Preloaded for Stage 2
000000.000: ATLAS5: Interstage Mesh Added: atlas5adapter @ x:0.000 y:0.000 z:-0.200
000000.000: ATLAS5 Payload Mesh Preloaded 1
000000.000: ATLAS5: Payload n.1 Mesh Added: DreamChaser\adapter @ x:0.000 y:0.000 z:30.400
000000.000: ATLAS5: Booster Mesh Preloaded: ATLAS5SRB1_1
000000.000: ATLAS5: Booster Mesh Added Mesh: ATLAS5SRB1_1 @ x:-0.027 y:0.499 z:0.050
000000.000: ATLAS5: Booster Mesh Preloaded: ATLAS5SRB2_1
000000.000: ATLAS5: Booster Mesh Added Mesh: ATLAS5SRB2_1 @ x:0.000 y:0.000 z:0.050
000000.000: ATLAS5: Booster Mesh Preloaded: ATLAS5SRB3_1
000000.000: ATLAS5: Booster Mesh Added Mesh: ATLAS5SRB3_1 @ x:0.000 y:0.000 z:0.050
000000.000: Load State Terminated
000000.000: Module MS_Camera.dll ......... [Build 170626, API 160828]
000000.000: MS_Camera: Target Vessel Loaded->ATLAS5
000000.000: Module b_slc41.dll ........... [Build 110328, API 100830]
000000.000: Module EmptyModule.dll ....... [Build 170626, API 160828]
000000.000: Finished initialising status
000000.000: Finished initialising camera
000000.000: Finished setting up render state
000000.000: Post Creation Started
000000.000: Module Spacecraft4.dll ....... [Build 151223, API 100830]
000000.000: ---------------------------------------------------------------
000000.000: >>> WARNING: Obsolete API function used: VESSEL::CreateVariableDragElement
000000.000: At least one active module is accessing an obsolete interface function.
000000.000: Addons which rely on obsolete functions may not be compatible with
000000.000: future versions of Orbiter.
000000.000: ---------------------------------------------------------------
000000.000: ATLAS5: Gravity Turn Initial Pitch by user: 89.300 Calculated:89.000
000000.000: RESET PEG
000000.000: ATLAS5: Planet Reference Pressure = 101325.0 Pa Atmosphere Altitude Limit:2500.0 km
000000.000: Post Creation Terminated
000000.000: Finished initialising panels
000030.065: ATLAS5 Booster n: 1 ignited @0.0
000030.065: ATLAS5 Booster n: 2 ignited @0.0
000030.065: ATLAS5 Booster n: 3 ignited @0.0
000030.557: ATLAS5 Stage n: 1 ignited @0.5
000043.020: Detached from Launchpad
000043.020: LaunchPad Deleted from Scenery
000180.171: ATLAS5: Booster n.1 jettisoned name: ATLAS5SRB1_1 @150.107
000180.220: ATLAS5: Booster n.2 jettisoned name: ATLAS5SRB2_1 @150.155
000180.300: ATLAS5: Booster n.3 jettisoned name: ATLAS5SRB3_1 @150.236
000243.348: ATLAS5: Stage n.1 jettisoned name: ATLAS5CCORE @285.595
000243.348: ATLAS5: Stage n.2 Engine Exhaust Stream Added: to engine n.1
000243.348: ATLAS5: Stage n.2 Engine Exhaust Stream Added: to engine n.1
000243.348: ATLAS5: Stage n. 2 Engines Exhaust Added--> number of engines: 1 , diameter: 1.000, position x: 0.000 y: 0.000 z: 17.462
000243.403: ATLAS5 Stage n: 2 ignited @285.6
000258.401: ATLAS5: Interstage of stage 2 jettisoned name: atlas5adapter @300.647
000316.276: RESET PEG
============================ ERROR: ===========================
Mesh file name not provided
[MeshManager::LoadMesh | .\Mesh.cpp | 1237]
================================================== =============
000373.158: ATLAS5: Payload n.1 jettisoned name: ADAPTER @599.943



I press J jettison adapter and then J again and got ctd:
000078.200: ATLAS5: Payload n.1 jettisoned name: ADAPTER @670.767
000079.891: ATLAS5: Payload n.2 jettisoned name: DREAMCHASER @672.458


And a quicksave of that. Not sure why atlas says current payload 3
BEGIN_SHIPS
ATLAS5:Multistage2015
STATUS Orbiting Earth
RPOS 1579833.879 369901.538 6367529.420
RVEL -7028.4860 -2770.1839 1904.7985
AROT -50.799 62.691 38.002
AFCMODE 7
PRPLEVEL 0:0.642962
NAVFREQ 0 0 0 0
XPDR 0
CONFIG_FILE Config\Multistage2015\ATLAS5DREAM.ini
GUIDANCE_FILE Config\Multistage2015\Guidance\DELTA4HVY_GNC.txt
CONFIGURATION 1
CURRENT_BOOSTER 12
CURRENT_STAGE 2
CURRENT_INTERSTAGE 2
CURRENT_PAYLOAD 3
FAIRING 0
MET 625.050
GNC_RUN 1
BATTERY 5060.545269
GROWING_PARTICLES
STAGE_IGNITION_TIME 285.594936
STAGE_STATE 3
TELEMETRY_FILE Config\Multistage2015\Telemetry\SLS_57310.61_TLM.t xt
ALT_STEPS 100.0,350.0,1400.0,35000.0
PEG_PITCH_LIMIT 35.000
PEG_MC_INTERVAL 0.100
END
MS_Camera:MS_Camera
STATUS Landed Earth
POS -80.5908600 28.6371940
HEADING 0.00
ALT 19.997
AROT 61.688 4.494 8.275
AFCMODE 7
NAVFREQ 0 0
TARGET ATLAS5
END
LC41:Vessels/B_SLC41/b_slc41
STATUS Landed Earth
POS -80.5828310 28.5834560
HEADING 180.00
ALT -0.183
AROT 151.079 -8.260 -175.462
AFCMODE 7
PRPLEVEL 0:1.000000
NAVFREQ 0 0
UMB 1 1.0000
END
DREAMCHASER:Spacecraft\Spacecraft3
STATUS Orbiting Earth
RPOS 1579800.664 369888.248 6367540.260
RVEL -7029.4404 -2770.5658 1905.1100
AROT -50.799 62.691 -141.998
AFCMODE 7
PRPLEVEL 0:0.999568
THLEVEL 0:0.388504
NAVFREQ 0 0
CONFIGURATION 1
CURRENT_PAYLOAD 0
SEQ 0 -2 0.000000
SEQ 6 -2 0.000000
SEQ 7 -2 0.000000
SEQ 8 -2 0.000000
SEQ 9 -2 0.000000
END
ADAPTER:Spacecraft\Spacecraft3
STATUS Orbiting Earth
RPOS 1518618.198 384358.915 6239010.477
RVEL -1.#IND -1.#IND -1.#IND
AROT -50.799 62.691 -141.998
AFCMODE 7
NAVFREQ 0 0
CONFIGURATION 1
CURRENT_PAYLOAD 0
END
END_SHIPS

Last edited by gattispilot; 10-08-2017 at 01:02 PM.
gattispilot is offline   Reply With Quote
Old 10-08-2017, 01:21 PM   #7
marcogavazzeni
Addon Developer
Default

Mesh file name not provided
[MeshManager::LoadMesh | .\Mesh.cpp | 1237]

You miss a mesh.
marcogavazzeni is offline   Reply With Quote
Old 10-08-2017, 03:16 PM   #8
Donamy
Beta Tester


Default

Too bad it doesn't tell you, which mesh is missing.
Donamy is offline   Reply With Quote
Thanked by:
Old 10-08-2017, 04:40 PM   #9
4throck
Enthusiast !
 
4throck's Avatar
Default

I always have difficulty remembering all the mesh names while developing, so I forced myself to use folders.

Much simpler to keep track of 4 or 5 meshes that way, and I can use normal names like "MyRocket\stage1.msh".

The same goes for configs, just put stuff into folders, much easier to track down what's missing.


Regarding identifying missing meshes, checking \Modules\D3D9ClientD3D9ClientLog.html may give extra info.

Last edited by 4throck; 10-08-2017 at 04:42 PM.
4throck is offline   Reply With Quote
Thanked by:
Old 10-08-2017, 08:41 PM   #10
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Thanks. I see that missing mesh common with Sc3 stuff and MS2015.

I took my ms2015 rocket out of the scn and not missing mesh message.

There are 2 payloads. 1 adapter and 2 dreamchaser.
Code:
[PAYLOAD_1]
Meshname=DreamChaser\adapter
Off=(0.000,0.000,35.100)
Rotation=(180.000,180.000,0.000)
Height=0.000
Diameter=0.000
Mass=100.000
Module=Spacecraft\Spacecraft3
Name=ADAPTER
Speed=(0.000,0.000,0.000)
Rot_speed=(0.000,0.000,0.000)
Render=1
Live=0

[PAYLOAD_2]
Meshname=DreamChaser\Dreamchaser
Off=(0.000,0.000,40)
Rotation=(180.000,180.000,0.000)
Height=0.000
Diameter=0.000
Mass=10000.000
Module=Spacecraft\Spacecraft3
Name=DREAMCHASER
Speed=(0.000,0.000,0.000)
Rot_speed=(0.000,0.000,0.000)
Render=1
Live=1
but the Atlas5 says currentpayload 3 and on the screen is says next payload adapter 10000 kg. But the next payload is the adapter at 100 kg.

gattispilot is offline   Reply With Quote
Old 10-09-2017, 12:21 PM   #11
BrianJ
thing
Default

Quote:
Originally Posted by gattispilot View Post
 Thanks. I see that missing mesh common with Sc3 stuff and MS2015.
IIRC you get the "missing mesh" error with spacecraft3.dll if you don't specify a mesh for the "virtual cockpit" in the .ini file. e.g.
Code:
[VC]
MESHNAME="MyCockpitMesh"
BrianJ is offline   Reply With Quote
Old 10-09-2017, 12:23 PM   #12
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Thanks. I don't think the mesh missing is the issue. I removed the ms2105 rocket and ran it and no missing mesh. It maybe the payload jettisoning. As there are 2 payloads but the rocket thinks there are 3
gattispilot is offline   Reply With Quote
Old 10-09-2017, 04:46 PM   #13
Donamy
Beta Tester


Default

I think the missing mesh errors, can sometimes be erroneous. Sometimes the errors have been wrong attachment points, or a missing comma. A lot of SC3 errors that don't give error messages, that are hard to find.
Donamy is offline   Reply With Quote
Old 10-10-2017, 12:18 PM   #14
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Well I got it to work. It wasn't missing a mesh at all but a cfg. So I just made a simple sc3 ini for the adapter and seems to work
gattispilot is offline   Reply With Quote
Old 10-10-2017, 04:36 PM   #15
4throck
Enthusiast !
 
4throck's Avatar
Default

Yes, remember that you can load a sc3/4 vessel by name:spacecraft/name

The name.cfg makes the sc4 vessel work as any other vessel.

Example:
spacecraft/name.cfg
Code:
ClassName = Spacecraft4
Module = Spacecraft4

This is relevant to multistage, depending on how you are calling your payloads. Those names need to be consistent.
I tend to prefer using .cfg because you can define extra vessel properties there.

Last edited by 4throck; 10-10-2017 at 04:39 PM.
4throck is offline   Reply With Quote
Thanked by:
Reply

  Orbiter-Forum > Orbiter Addons > Addon Support & Bugs


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 12:13 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.