Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > OrbitHangar Addons & Comments
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

OrbitHangar Addons & Comments Addons uploaded at Orbithangar.com will automatically generate a new thread in this forum for comments. The thread link will also be included on the addons page.

Reply
 
Thread Tools
Old 01-12-2017, 05:46 PM   #226
Tex
O-F Administrator
 
Tex's Avatar

Default

No criticism intended. I should have noticed the obvious requirements you put on OHM. I simply didn't read that. I saw Launch MFD for Orbiter 2016 and I was like, "yep, I know what that is...downloading immediately!"
Tex is offline   Reply With Quote
Old 03-21-2017, 04:30 AM   #227
qbit
Orbinaut
Default

I'm trying to use LaunchMFD on the moon with the Delta Glider. I set an escape course back to Earth with TransX. When I target LaunchMFD to TransX, everything looks good. I launch and enable the auto pilot. Ascent is good. Then at 6 km it suddenly goes vertical and just keeps going in this direction forever. Makes a huge orbit, and the TMEC counter basically stops counting down (counts very slowly). It's supposed to launch into an orbit of 20 km based on what I set in TransX. I've got this to work great when launching from Earth.

Am I doing something wrong or was it not designed to be used on the Moon? I've tried doing it with 10% throttle, and it does the same thing at about 6 km altitude.

Thanks,
Paul

Edit: I got it working. I was apparently still going too fast at what I thought was 10% throttle. Also, sorry if this should have gone into the general MFD questions forum.

Last edited by qbit; 03-21-2017 at 04:51 AM.
qbit is offline   Reply With Quote
Old 03-21-2017, 06:40 AM   #228
Enjo
Mostly harmless
 
Enjo's Avatar


Default

Quote:
Originally Posted by qbit View Post
 Edit: I got it working. I was apparently still going too fast at what I thought was 10% throttle.
Yep, you nailed it. The same thing goes for Mars, proportionally to the planet's gravitational acceleration.

Quote:
Originally Posted by qbit View Post
 Also, sorry if this should have gone into the general MFD questions forum.
No, it's perfectly fine.
Enjo is offline   Reply With Quote
Thanked by:
Old 11-19-2017, 04:09 AM   #229
Zandy12
Orbinaut
Default

Hey guys I need help. I can't see the option to open Launch MFD in the MFD selection. I did everything correctly I have VC++2005, enabled in modules, put folders in proper places, and have the 2016 version. I still can't get to work please help. I'm using Orbiter 2016 btw.
Zandy12 is offline   Reply With Quote
Old 11-22-2017, 04:07 PM   #230
boogabooga
Bug Crusher
 
boogabooga's Avatar
Default

The launch MFD HUD is not visible when flying the XR2 in Orbiter 2016. It works fine on other vessels, though. Also, works fine with XR2 in Orbiter 2010.

I'm not sure if this is a launch MFD issue or an XR issue. Anyone else notice this?
boogabooga is offline   Reply With Quote
Thanked by:
Old 12-07-2017, 07:34 AM   #231
Enjo
Mostly harmless
 
Enjo's Avatar


Default

It could be, that XR is still derived from the older VESSEL3 class, instead of VESSEL4 - now the reference, which I have to support foremost.

All (only) VESSEL3 - derived vessels are supported in Orbiter 2010 and all (only) VESSEL4 in Orbiter 2016

Last edited by Enjo; 12-07-2017 at 12:01 PM.
Enjo is offline   Reply With Quote
Thanked by:
Old 12-07-2017, 11:06 AM   #232
Ripley
Tutorial translator
 
Ripley's Avatar
Default

Did you ask dbeachy1 about this, enjo?
Ripley is offline   Reply With Quote
Old 12-07-2017, 01:07 PM   #233
Enjo
Mostly harmless
 
Enjo's Avatar


Default

Nope

---------- Post added at 02:07 PM ---------- Previous post was at 12:37 PM ----------

My question to you now would be: does it work for other vessels for you guys?
Bah. Boogabooga answered to this question. Also, the fact that HUD + XR works for Orbiter 2010 makes me more convinced about my hypothesis.

Last edited by Enjo; 12-07-2017 at 02:55 PM.
Enjo is offline   Reply With Quote
Old 12-08-2017, 04:36 PM   #234
dbeachy1
O-F Administrator
 
dbeachy1's Avatar


Default

The XR vessels still extend VESSEL3, not VESSEL4, since they neither use nor need any VESSEL4-specific methods.
dbeachy1 is offline   Reply With Quote
Thanked by:
Old 12-08-2017, 05:00 PM   #235
Enjo
Mostly harmless
 
Enjo's Avatar


Default

Then I don't have to explain to you now, that this is the only reason why HUDDrawer doesn't work for your vessels. It would be great if you did derive from VESSEL4 and provide just empty / default implementations.

Last edited by Enjo; 12-08-2017 at 07:37 PM.
Enjo is offline   Reply With Quote
Old 12-11-2017, 02:18 AM   #236
dbeachy1
O-F Administrator
 
dbeachy1's Avatar


Default

Quote:
Originally Posted by Enjo View Post
 Then I don't have to explain to you now, that this is the only reason why HUDDrawer doesn't work for your vessels. It would be great if you did derive from VESSEL4 and provide just empty / default implementations.
I have been talking with ADSWNJ about this, and he helped me test some new XR release candidates that extend VESSEL4, which I just released! Details here.
dbeachy1 is offline   Reply With Quote
Thanked by:
Reply

  Orbiter-Forum > Orbiter Addons > OrbitHangar Addons & Comments


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 07:47 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.