Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Visualization Project
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Orbiter Visualization Project Orbiter external graphics development.

Reply
 
Thread Tools
Old 12-28-2018, 05:24 PM   #4741
Donamy
Beta Tester


Default

Quote:
Originally Posted by GLS View Post
 Why not save the "original" bottom surface group for future reference, and cut a door-shaped hole on the bottom surface?

I believe I made holes in the mesh.
Donamy is offline   Reply With Quote
Old 12-28-2018, 06:09 PM   #4742
DaveS
Addon Developer
 
DaveS's Avatar


Default

Quote:
Originally Posted by Donamy View Post
 I believe I made holes in the mesh.
You did but I had to remove the original floor of the aft engine compartment as it was had a few faults, one of being noted by GLS: "aft compartment bottom isn't flat (not exactly sure how it should be, but it doesn't look good as is)".

I couldn't fix the original so I decided to start with a clean slate. And since we were already using the "clipper method" for the star trackers, midbody vent doors and the aft RCS nozzles, I thought "why not use it for the ET umbilical wells" as well?
DaveS is offline   Reply With Quote
Old 12-28-2018, 06:56 PM   #4743
Donamy
Beta Tester


Default

Do you add the flags to the mesh file ?
Donamy is offline   Reply With Quote
Old 12-28-2018, 07:05 PM   #4744
DaveS
Addon Developer
 
DaveS's Avatar


Default

Quote:
Originally Posted by Donamy View Post
 Do you add the flags to the mesh file ?
Yes. The FLAG parameter goes along with LABEL, MATERIAL, TEXTURE and GEOM. More information is available in the 3DModel.pdf document which can be found in the Doc subfolder of the main OrbiterSDK folder.
DaveS is offline   Reply With Quote
Thanked by:
Old 12-31-2018, 08:19 PM   #4745
Abdullah Radwan
Addon Developer
 
Abdullah Radwan's Avatar
Default

D3D9 client causes Orbiter to not display scenarios description. Orbiter 2016 with latest D3D9 client (r1038M). The problem occurs only on startup, which means if I started Orbiter with D3D9 de-activated then I activated it later, it works. It doesn't work only if D3D9 client is enabled on startup.

Attached Files
File Type: zip Log files.zip (1.6 KB, 0 views)
Abdullah Radwan is offline   Reply With Quote
Old 01-01-2019, 06:17 PM   #4746
Donamy
Beta Tester


Default

Is the Yahoo in Dx9 just for today ?
Donamy is offline   Reply With Quote
Old 01-02-2019, 01:08 AM   #4747
jarmonik
Beta Tester

Default

Quote:
Originally Posted by Donamy View Post
 Is the Yahoo in Dx9 just for today ?
What ???
jarmonik is offline   Reply With Quote
Old 01-02-2019, 02:03 AM   #4748
Donamy
Beta Tester


Default

Never mind. It was a message from Orbiter 2016 sound file for New years Day.
Sorry !!
Donamy is offline   Reply With Quote
Old 01-02-2019, 11:04 AM   #4749
Ripley
Tutorial translator
 
Ripley's Avatar
Default

Quote:
Originally Posted by jarmonik View Post
 ...Also a small teaser of an upcoming project OrbiterGUI is uploaded...
For those who have tested it, may I ask what is it about?
(I can't test it myself, pc not working)

---------- Post added at 11:04 ---------- Previous post was at 10:46 ----------

Quote:
Originally Posted by Ripley View Post
 I won't be able to upload the latest releases to Tuttovola.org for the next days, so grab your D3D9 from Jarmonik's post above.
Client uploaded to Tuttovola.
Ripley is offline   Reply With Quote
Old 01-02-2019, 05:28 PM   #4750
Abdullah Radwan
Addon Developer
 
Abdullah Radwan's Avatar
Default

Any help? It's a really annoying problem.
Abdullah Radwan is offline   Reply With Quote
Old 01-04-2019, 09:04 PM   #4751
kuddel
Donator
Default

Quote:
Originally Posted by Abdullah Radwan View Post
 D3D9 client causes Orbiter to not display scenarios description. Orbiter 2016 with latest D3D9 client (r1038M).
The M indicates that this is not a reproducible build (M for Modified)!
This should never have been released, although it might have been.
But that's possibly not the biggest issue here as others do not have that problem with that release.

Quote:
Originally Posted by Abdullah Radwan View Post
 The problem occurs only on startup, which means if I started Orbiter with D3D9 de-activated then I activated it later, it works. It doesn't work only if D3D9 client is enabled on startup.
D3D9Client only accesses anything from the scenario folder to read information it can not get via the API Orbiter provides.
It never purposely changes the display of scenario information in the Launchpad dialog.
Nevertheless could any incorrect programming in the client "shoot" into the routines of the main (Orbiter) program and change its behavior.
I took a very close look into that code parts that might be responsible and can not see anything obvious.

Just to make sure what's on your side:
Do you have anything "out of the normal" with your "Orbiter 2016" installation?
Like symbolic links to "shared folders" or folders that are shared between any two Orbiter installations (Orbiter BETA and Orbiter 2016 for example).
Is your Orbiter 2016 installation located in the "Program Files (x86)" or "Program Files" folder and you have not set the access rights (recursively) on all the sub-folder (UAC)?

---------- Post added at 21:04 ---------- Previous post was at 17:18 ----------

...and:
Can you reproduce the startup issue when D3D9Client is the only Module active?
kuddel is offline   Reply With Quote
Old 01-05-2019, 02:27 AM   #4752
Samuel Edwards
Decidedly Cyclical
 
Samuel Edwards's Avatar

Default

Hiya Gents,

I am writing this post as a potential bug report for the newest version of the D3D9 client for Orbiter 2016. I am not sure if this has been posted about yet, but this is a brand new installation of Orbiter 2016 and the D3D9 Client version R3.4.

I was pitching down in the stock DG when I noticed the sun shines through 3D cockpit elements including the top panel. Attached below is a screenshot of the bug(?) and one of my current D3D9 settings.




I am running Orbiter on an nVidia GeForce GTX 1060 if that information is at all necessary.

Thanks for looking into this and for developing this amazing graphics client,

Samuel
Samuel Edwards is offline   Reply With Quote
Old 01-05-2019, 10:33 AM   #4753
clipper
Orbinaut
Default

I believe that this is a result of LensFlare post processing option and is a known issue, so the easy fix is to simply switch to another option or turn off post processing altogether in your D3D9 Advanced Setup menu.
clipper is offline   Reply With Quote
Thanked by:
Old 01-05-2019, 05:57 PM   #4754
Abdullah Radwan
Addon Developer
 
Abdullah Radwan's Avatar
Default

Quote:
Originally Posted by kuddel View Post
 The M indicates that this is not a reproducible build (M for Modified)!
This should never have been released, although it might have been.
But that's possibly not the biggest issue here as others do not have that problem with that release.


D3D9Client only accesses anything from the scenario folder to read information it can not get via the API Orbiter provides.
It never purposely changes the display of scenario information in the Launchpad dialog.
Nevertheless could any incorrect programming in the client "shoot" into the routines of the main (Orbiter) program and change its behavior.
I took a very close look into that code parts that might be responsible and can not see anything obvious.

Just to make sure what's on your side:
Do you have anything "out of the normal" with your "Orbiter 2016" installation?
Like symbolic links to "shared folders" or folders that are shared between any two Orbiter installations (Orbiter BETA and Orbiter 2016 for example).
Is your Orbiter 2016 installation located in the "Program Files (x86)" or "Program Files" folder and you have not set the access rights (recursively) on all the sub-folder (UAC)?

---------- Post added at 21:04 ---------- Previous post was at 17:18 ----------

...and:
Can you reproduce the startup issue when D3D9Client is the only Module active?
I've installed this version: https://www.orbiter-forum.com/showth...postcount=4699


My Orbiter installation is working without any problems. Just this problem with D3D9. I've fixed Lua interpreter problem.


There are no symbolic links in both (2016 and Beta), just linking Beta texture directory to 2016 one. Nothing else.


Both are installed in D (Another hard drive), away from Program Files.


The problem happens also with all add-ons disabled except D3D9.


When I open Orbiter, it lags a few seconds on this view:





Then it doesn't show the scenario description. Disabling D3D9, the lag doesn't happen and I have the description.
Abdullah Radwan is offline   Reply With Quote
Old 01-05-2019, 06:34 PM   #4755
kuddel
Donator
Default

Quote:
Originally Posted by Abdullah Radwan View Post
 I've installed this version: https://www.orbiter-forum.com/showth...postcount=4699

My Orbiter installation is working without any problems. Just this problem with D3D9. I've fixed Lua interpreter problem.

There are no symbolic links in both (2016 and Beta), just linking Beta texture directory to 2016 one. Nothing else.

Both are installed in D (Another hard drive), away from Program Files.
That seems to be all fine so far


Quote:
Originally Posted by Abdullah Radwan View Post
 The problem happens also with all add-ons disabled except D3D9.

When I open Orbiter, it lags a few seconds on this view:
[...]
Then it doesn't show the scenario description. Disabling D3D9, the lag doesn't happen and I have the description.
That is a very strange behavior...and I can't see why D3D9Clients activation has such an impact.
I've created a local setup here to re-create your "installation" and I can not reproduce anything like that.

Is there any Virus-scanner blocking the DLL from being loaded?
Any graphic-card special settings for the Orbiter_ng executable?

I'm out of ideas to be honest

I would recommend to make a complete clean 2016 setup with only D3D9Client as extra add-on[1] and see what happens.


[1] not even installing Textures, as the issue already starts waaaaay earlier at the launchpad dialog
kuddel is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Visualization Project

Tags
d3d9client, graphicsclient


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 04:35 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.