Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Development
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Addon Development Developers post news, updates, & discussions here about your projects in development.

Reply
 
Thread Tools
Old 04-19-2017, 09:51 PM   #736
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

-10=Orbit(185,185)
-3=engine(0,100,3.0)


Nope this launch and then also first and second stage separate and 3 stage never fired.
gattispilot is offline   Reply With Quote
Old 04-20-2017, 11:01 PM   #737
boogabooga
Bug Crusher
 
boogabooga's Avatar
Default

Quote:
Originally Posted by gattispilot View Post
 -10=Orbit(185,185)
-3=engine(0,100,3.0)


Nope this launch and then also first and second stage separate and 3 stage never fired.
Could you please elaborate? Did you get into orbit at least?

If you are modeling Saturn V, it is entirely possible that the third stage is not needed to get into orbit. The real Saturn V was capable of getting a "small" payload to orbit on only two stages and did exactly that with skylab. The third stage was mostly there to get to the moon.
boogabooga is offline   Reply With Quote
Old 04-20-2017, 11:45 PM   #738
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

No. on orbit
LAUNCH

1ST STAGE Seperated

2nd stage separated and stage 3 never fired.

2nd stage interface still there.
gattispilot is offline   Reply With Quote
Old 04-21-2017, 12:24 AM   #739
boogabooga
Bug Crusher
 
boogabooga's Avatar
Default

Do the stages run out of fuel before they separate?

Please just zip everything that I would need to get this running (meshes, textures, configs, etc), post it, and I will take a look myself.
boogabooga is offline   Reply With Quote
Old 04-21-2017, 10:34 AM   #740
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

here you go:
https://drive.google.com/open?id=0B0...k5na0FPNUFLLU0
gattispilot is offline   Reply With Quote
Old 04-21-2017, 01:52 PM   #741
fred18
Addon Developer

Default

I had a quick run and it seems that first of all the thrust values must be multiplied by 1000!!!

then careful with attachment manager as it can creates issues.



RELEVANT TO SOUND SUPPORT

I made a couple of tests and it seems that the "PlaySound(...)" command included in c++ does not actually interfere with orbiter sound (maybe it can happen that ATC of orbiter sound and the playsound command comes one on top of the other, but there seems to be no technical obstacle)

I'll implement this into Multistage, if any of the experts of coding know anything against it please let me know!

fred18 is offline   Reply With Quote
Old 04-21-2017, 01:54 PM   #742
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

So ok. I was going with real values.
gattispilot is offline   Reply With Quote
Old 04-21-2017, 01:59 PM   #743
fred18
Addon Developer

Default

Quote:
Originally Posted by gattispilot View Post
 So ok. I was going with real values.
It's not a metter of real or unreal, it's a matter of using newtons and not kilonewtons...
fred18 is offline   Reply With Quote
Thanked by:
Old 04-21-2017, 02:03 PM   #744
DaveS
Addon Developer
 
DaveS's Avatar


Default

Quote:
Originally Posted by gattispilot View Post
 So ok. I was going with real values.
Was your source listing things in the US Imperial measurement system? If so you need to convert them into the SI system which Orbiter uses. For example, the US measures thrust in pounds-force (lbf) while SI/Orbiter measures it in Newtons (N).
DaveS is offline   Reply With Quote
Old 04-21-2017, 02:13 PM   #745
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

So when we used Velco. 1st stage was:
EmptyMass=51944.392
FuelMass=1101259.734
Thrust=10898383.375

The real spec:
Empty mass 287,000 lb (130,000 kg)
Gross mass 5,040,000 lb (2,290,000 kg)
Thrust 7,891,000 lbf (35,100 kN) sea level

This is what I have now:
EmptyMass=130000
FuelMass=2290000
Thrust=35100
gattispilot is offline   Reply With Quote
Old 04-21-2017, 02:18 PM   #746
DaveS
Addon Developer
 
DaveS's Avatar


Default

Quote:
Originally Posted by gattispilot View Post
 So when we used Velco. 1st stage was:
EmptyMass=51944.392
FuelMass=1101259.734
Thrust=10898383.375

The real spec:
Empty mass 287,000 lb (130,000 kg)
Gross mass 5,040,000 lb (2,290,000 kg)
Thrust 7,891,000 lbf (35,100 kN) sea level

This is what I have now:
EmptyMass=130000
FuelMass=2290000
Thrust=35100
There's your problem. You specified the kilo-Newton value when Orbiter expects it in pure Newtons. Kilo=Thousand. So 35100 kN = 35100000 N.
DaveS is offline   Reply With Quote
Thanked by:
Old 04-21-2017, 09:43 PM   #747
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Ok I adjusted the thrust.

[STAGE_1]
Height=42.2099
Diameter=10.106
EmptyMass=130000
FuelMass=2290000
Thrust=35100000

But now she launched into space and the 1st stage thrust shuts down
gattispilot is offline   Reply With Quote
Old 04-21-2017, 09:52 PM   #748
boogabooga
Bug Crusher
 
boogabooga's Avatar
Default

gattispilot,

I multiplied the thrust of all three stages by 1000 as per the above posts. After that,

Code:
-10=Orbit(185,185)
-3=engine(0,100,3.0)
got me successfully into a 185 x 185 km orbit by using only the first stage and only about half of the second stage's fuel. The interstage skirt seemed to drop as it should, and second stage ignited on its own.

I couldn't get the payload you had there to work. I substituted it with something else, but I keep the mass the same. So, that shouldn't matter. Is this what you needed?
boogabooga is offline   Reply With Quote
Old 04-21-2017, 10:20 PM   #749
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Weird. it works now Thanks

I turn Attachment manager off

Last edited by gattispilot; 04-21-2017 at 10:25 PM.
gattispilot is offline   Reply With Quote
Thanked by:
Old 04-22-2017, 12:37 AM   #750
Donamy
Beta Tester


Default

Quote:
Originally Posted by gattispilot View Post
 Weird. it works now Thanks

I turn Attachment manager off
Wish someone would fix that.
Donamy is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Addons > Addon Development


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 06:28 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.