Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Beta
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Orbiter Beta Topics related to Beta releases of Orbiter and Orbiter development.

Reply
 
Thread Tools
Old 10-10-2018, 03:01 PM   #526
Upkeep
Orbinaut
Default

Thanks for your interest. I tried to install it via dxwebsetp.exe from the Windows site. Maybe this was the wrong one?
All the best
Upkeep
Upkeep is offline   Reply With Quote
Old 10-10-2018, 03:57 PM   #527
Atkara
Orbinaut
Default

Propably.

Try the link I gave you. It points where the file I'm talking about can be downloaded from, on Microsoft's website. Once downloaded, running it will prompt you to extract it's contents. Write down the suggested folder name, let it extract, then run the dxsetup.exe you'll find there. It'll do the rest.
Atkara is offline   Reply With Quote
Old 10-11-2018, 10:14 AM   #528
Ripley
Tutorial translator
 
Ripley's Avatar
Default

I recall I also had to install DX9 on my - then - new Win10 pc, and I had no problems.
Windows didn't complain about it.
Ripley is offline   Reply With Quote
Old 10-12-2018, 09:19 AM   #529
Upkeep
Orbinaut
Default

Thanks again for your help. Tried the link and downloaded. It installed OK with no problems, but still left with the same issue with Orbiter. Cannot launch. The same problem. This one has beaten me! I guess I shall have to give up and uninstall. A shame after all these years!

Thanks again for your help.

Best wishes

Upkeep
Upkeep is offline   Reply With Quote
Old 10-12-2018, 08:39 PM   #530
kuddel
Donator
Default

Hey Upkeep,
don't give up (so early).

Let's try to narrow down the issue.
The list is what I think you've done / what you're at.
Please check every point and give corrections where I might be wrong or you get different results or have problems.
Some steps/points are just assumptions by me, not all points are "tasks"

[a] OS is Windows 10 (64bit)
[b] Orbiter is installed in a Path that does allow execution. ("C:\Programm Files" might not be OK as of UAC restrictions. Try "Desktop" to see if it runs better there)
[c] You are running Orbiter BETA (from the subversion repository)
[d] You have installed (at least some) Texture packs
[e] You can run Orbiter.exe (inline client) and start a simple scenario
[f] You have downloaded and installed the DirectX 9 runtimes.
[g] You have installed D3D9Client
[h] You should be able to run Orbiter_ng.exe
[i] You have enabled the D3D9Client under the modules tab
[j] You have set up the screen according to your needs/wishes.
[k] You can now start a scenario
kuddel is offline   Reply With Quote
Old 10-13-2018, 09:13 AM   #531
Upkeep
Orbinaut
Default

How kind of you to offer to help! Thank you.

To answer the points

[a] OS is Windows 10 (64bit) - Yes. That is correct
[b] Orbiter is installed in a Path that does allow execution. ("C:\Programm Files" might not be OK as of UAC restrictions. Try "Desktop" to see if it runs better there) Both Orbiter and Orbiter beta are installed on a separate hard drive - my E drive, with shortcuts on the desktop
[c] You are running Orbiter BETA (from the subversion repository) Yes and the standard Orbiter 2016
[d] You have installed (at least some) Texture packs: Yes, Moon and Mars and some Earth tiles.
[e] You can run Orbiter.exe (inline client) and start a simple scenario: No. I can open the menu but in Video it just shows RGB Emulation. When I launch Orbiter it crashes.
[f] You have downloaded and installed the DirectX 9 runtimes. Yes, and these are installed
[g] You have installed D3D9Client: Yes. For Orbiter Beta - D3D9ClientBeta27-forRev73 and for Orbiter 2016 - D3D9Client2016-R3b
[h] You should be able to run Orbiter_ng.exe No. Menu opens OK but on Launch Orbiter command or any scenario it crashes
[i] You have enabled the D3D9Client under the modules tab: Yes
[j] You have set up the screen according to your needs/wishes. Yes. Though the resolution box in the Video section is blank. When I run the NG version (Orbiter Beta and Orbiter 2016) it shows my Nvidia driver by name but nothing else. For the ordinary orbiter. exe it just shows RGB Emulation (both Beta and 2016)
[k] You can now start a scenario: No crashes as soon as I press Launch Orbiter or try a scenario. Same with both versions of Orbiter and same with Orbiter.exe and Orbiter.NG.


Hope this helps to throw some light on the problem.

Many thanks again for your help.

Best wishes

Upkeep
Upkeep is offline   Reply With Quote
Old 10-13-2018, 02:42 PM   #532
kuddel
Donator
Default

Thanks for your detailed feedback

It seems that Orbiter can't figure out your graphics hardware....hmm
Could you try the following:
Check the "Always enumerate devices" box under "Video" tab (meaning: it should be "checked").
Then close the launchpad dialog and open it again. Sometimes that helped to detect the graphics card.
Do this with Orbiter.exe first, although Orbiter_NG.exe should perform the same tasks, but first the inline client has to work, so we'll stick to that issue first.

If that doesn't change anything, I am currently out of ideas, but maybe someone else had similar issues with a graphics adapter.
kuddel is offline   Reply With Quote
Old 10-13-2018, 03:29 PM   #533
GLS
Addon Developer
 
GLS's Avatar
Default

There should be an option on the menu, when you right click the orbiter.exe file, saying "Run with graphics processor", where you can choose between the Intel integrated GPU and the NVIDIA GPU. If it runs in the Intel and not in the NVIDIA, then it could be some configuration change in the NVIDIA control panel... or it fried...
GLS is offline   Reply With Quote
Thanked by:
Old 10-13-2018, 04:08 PM   #534
Upkeep
Orbinaut
Default

Thanks for the response. In fact, I do not have a choice of graphics, just Nvidia. I have tried with the default Nvidia settings in Control Panel, and the Nvidia Graphics Card works fine with other applications.

Thanks anyway for your help.
Best wishes

Upkeep.
Upkeep is offline   Reply With Quote
Old 10-13-2018, 04:26 PM   #535
GLS
Addon Developer
 
GLS's Avatar
Default

Quote:
Originally Posted by Upkeep View Post
 Thanks for the response. In fact, I do not have a choice of graphics, just Nvidia. I have tried with the default Nvidia settings in Control Panel, and the Nvidia Graphics Card works fine with other applications.

Thanks anyway for your help.
Best wishes

Upkeep.
Right-click on the NVIDIA icon near the clock, and there should be an option to show a contxt menu, or something simillar. That enables the menu entry I'm talking about.
Or you can set the default GPU for a program in the NVIDIA control panel.
GLS is offline   Reply With Quote
Old 10-13-2018, 04:35 PM   #536
Upkeep
Orbinaut
Default

Tried Control Panel again. Unfortunately I have no option to change from Nvidia. I do not have an Intel driver installed, just Nvidia GTX 770. Looking at the back of the PC there are no other graphic card ports.

Thanks for trying.

All the best
Upkeep
Upkeep is offline   Reply With Quote
Old 10-13-2018, 04:51 PM   #537
DaveS
Addon Developer
 
DaveS's Avatar


Default

Quote:
Originally Posted by Upkeep View Post
 Tried Control Panel again. Unfortunately I have no option to change from Nvidia. I do not have an Intel driver installed, just Nvidia GTX 770. Looking at the back of the PC there are no other graphic card ports.

Thanks for trying.

All the best
Upkeep
The "dual-GPU" option that GLS is talking about is only available on laptops. It works by switching between the integrated GPU ("IGPU") which is built into your CPU and the dedicated external GPU ("EGPU"). It uses the IGPU during low graphics load situations to conserve battery lifetime. When it senses a high graphics load it should automatically switch over to the more powerful but more battery-demanding EGPU. As soon as this load disappears again, it switches back to the IGPU.


Desktop PCs don't have this function as they don't rely on battery power so they're free to stick to the EGPU at all times.


Where does your the cable from monitor plug in currently? Is it into the graphics card itself or into the motherboard?
DaveS is online now   Reply With Quote
Thanked by:
Old 10-13-2018, 04:54 PM   #538
Upkeep
Orbinaut
Default

It plugs into the graphics card itself using DVI plug

Best wishes
Upkeep
Upkeep is offline   Reply With Quote
Old 10-13-2018, 04:57 PM   #539
kuddel
Donator
Default

Just to be absolutely sure the DirectX 9.0c is really installed (I do believe you know what you're doing, so sorry if it sounds ridiculous...
but I know for example that some people still try the web-installer and that one does not do it right for 9.0c)

Can you check these files versions, please: DirectX 9.0 (June 2010 release)
search for the following files:

%WinDir%\System32\D3DX9_43.dll with version 9.29.952.3111
%WinDir%\System32\d3dx10_43.dll with version 9.29.952.3111
%WinDir%\System32\d3dx11_43.dll with version 9.29.952.3111

(BTW, the list is from here)

Last edited by kuddel; 10-13-2018 at 04:59 PM.
kuddel is offline   Reply With Quote
Old 10-13-2018, 05:03 PM   #540
Upkeep
Orbinaut
Default

Yes, all three files are there.

All the best

Upkeep
Upkeep is offline   Reply With Quote
Thanked by:
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Beta


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 01:51 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.