Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > MFD Questions & Help
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

MFD Questions & Help Post your questions here for help with the Multi-Function Displays.

Reply
 
Thread Tools
Old 02-15-2020, 11:50 AM   #1
Atrament666
Orbinaut
Default No text in any MFD with D3D9Client

Hi,
After years of happy orbiting I had to reinstall the system. And now I don't seem to be able to make the Orbiter running as it used to.

I downloaded the latest available Orbiter 2016, the latest D3D9Client and the latest XR2 and XRSound.

I am trying to run it in Linux Manjaro with wine. There is no text in the MFDs not in the cockpit or in the glass view, they are just blank, or some of them, like Orbit MFD for example, contain only the graphic elements.

It works using the stock engine, but not with D3D9Client. But I prefer D3D9Client for the better performance.

I tried all possible combinations of settings in Video section, older versions of D3D9Client, I also tried the beta version of Orbiter with matching beta version of D3D9. I spent hours googling and searching this forum but with no luck.

I am attaching a screenshot where you can see the problem.

Any help would be greatly appreciated.

Thanks
Attached Thumbnails
orbiter.jpg  
Atrament666 is offline   Reply With Quote
Old 02-15-2020, 05:42 PM   #2
dbeachy1
O-F Administrator
 
dbeachy1's Avatar



Default

to Orbiter-Forum!

I haven't run Orbiter under Wine myself, but you could check out the forum thread Orbiter 2016 under Wine for more information.

dbeachy1 is offline   Reply With Quote
Old 02-16-2020, 01:24 PM   #3
Atrament666
Orbinaut
Default

Thanks for the reply, I have already seen that thread, sadly nothing there helped me. I tried everything mentioned there but always with the same result.

But I have noticed something - the InterplanetaryMFD works. Even more - if I switch to the IMFD and then click Sel the menu is suddenly working but then when I try to open any other MFD it's gone again...

Is InterplanetaryMFD drawing itself somehow differently then other MFDs?
Atrament666 is offline   Reply With Quote
Old 02-16-2020, 09:26 PM   #4
Atrament666
Orbinaut
Default

Problem solved by downgrading Wine to 4.21
Atrament666 is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > MFD Questions & Help


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 10:04 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.