Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Beta
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Orbiter Beta Topics related to Beta releases of Orbiter and Orbiter development.

Reply
 
Thread Tools
Old 07-17-2016, 06:30 PM   #286
Eduard
Orbinaut
Default

Hi Jarmo,

I might have some useful new information.
I asked myself the following question: What about the other celestial bodies?

It turns out that I can see surface textures of the following objects:
- Mercury
- Venus
- Io
- Europa
- Ganymede
- Callisto
- Saturn
- Titan
- Hyperion
- Miranda
- Ariel
- Ubriel
- Titania
- Oberon
- Neptune
- Triton
- Proteus
- Nereid

But not from the other objects:
- Earth
- Moon
- Mars
- Phobos
- Deimos
- Vesta
- Jupiter
- Mimas
- Enceladus
- Tethys
- Dione
- Rhea
- Iapetus
- Uranus (no surface or clouds, but rings & atmosphere are visible)
Eduard is offline   Reply With Quote
Old 07-17-2016, 06:46 PM   #287
jarmonik
Beta Tester

Default

This problem is now fixed. Texture search paths were wrong/not working at all.
jarmonik is offline   Reply With Quote
Old 07-18-2016, 01:00 PM   #288
Glab
Orbinaut
Default

Hi at all, i'm testing rev.58 + low res. textures+ D3D9Client, but i can't load any texture of planets (Earth, Moon...) and hear no sound.

Without D3D9Client, all works well, but on my PC it runs slow, 3,00 GHz, 4gb ram, Intel HD Graphics.

Solutions?
Glab is offline   Reply With Quote
Old 07-19-2016, 09:38 PM   #289
Eduard
Orbinaut
Default

Quote:
Originally Posted by Glab View Post
 Hi at all, i'm testing rev.58 + low res. textures+ D3D9Client, but i can't load any texture of planets (Earth, Moon...) and hear no sound.

Without D3D9Client, all works well, but on my PC it runs slow, 3,00 GHz, 4gb ram, Intel HD Graphics.

Solutions?
See my comments and Jarmo's answer above. I already discovered the problem and Jarmo says that he has fixed it now, and that search paths where incorrect.
So I asume that the next build will contain the corrections he made.

And you hear no sound? I have Orbitersound working here as it did before.
Eduard is offline   Reply With Quote
Old 07-21-2016, 05:51 PM   #290
gamer19
Orbinaut
Default

Hi all.
My first post here.

I play Orbiter for like decade or so but yes... first post...
Problem is that I can not got D3D mode working with latest beta.
I didn't even try any beta until this latest one, and right from the start D3D mode did not work.
You will probably say "you must have not installed it correctly" but I played Orbiter 2006 for a very long time in D3d mode. Not a problem at all. But now...
Was is any different n beta ? I think I DL and tried every D3D files I've found here, neither did the trick.
And it's a real shame, since Orbiter with all those new (multi-gigabyte) textures and height maps looks way better than non-betas.

Can any one try to help me, please ? :-/
Or I must post Orbiter.log first.
Can't do it right now, I'm at work.
gamer19 is offline   Reply With Quote
Old 07-29-2016, 06:27 AM   #291
Abloheet
Addon Developer
 
Abloheet's Avatar
Default

Hasn't a new beta released, r 59? I ran SVN update today and it updated to revision 59. What's new in r 59? Will it be rc2? And, why isnt it posted here?
Abloheet is offline   Reply With Quote
Old 07-29-2016, 09:55 AM   #292
martins
Orbiter Founder
Default New Orbiter Beta Released (r.59 aka RC.2, 29 Jul 2016)

Change log:
  1. Vessel integrator: During orbit stabilisation, switched rotation model from "Euler full" to "Euler simple" to avoid instabilities
  2. zlib.dll: removed dependency on VS2013 runtimes
  3. MSI package: updated VS redistributables to VC90
  4. DeltaGlider: altitude readout in horizon instrument now shows altitude above ground
  5. HUD: target direction marker in Surface HUD compass ribbon now active when target base is selected in Map MFD.
  6. Track camera: can now move away from target even if within target radius

This beta has been designated RC.2.

This should address most of the issues raised with r.58 / RC.1

There is no new OVP commit. The latest beta D3D9 client should still work.
martins is offline   Reply With Quote
Old 07-29-2016, 11:03 AM   #293
jarmonik
Beta Tester

Default

Thanks about RC2. Looks like the CTD problem is fixed at least the one that I was having. Orbiter 2016 is starting to look very good.

The D3D9 is also in a pretty good shape. There are a few minor bugs remaining and I would need to write some documentation for it and figure out how to officially distribute the client. I guess we need something better than using attachments in this forum.
jarmonik is offline   Reply With Quote
Old 07-30-2016, 05:50 AM   #294
dbeachy1
O-F Administrator
 
dbeachy1's Avatar


Default

Thanks for posting RC2! I installed a clean instance of RC2 tonight and did a clean rebuild of my XR vessels using Orbiter 2016 RC2. (I used the inline DX7 client.) For the most part everything is OK (just some minor stuff like wheels sinking into the ground that I can fix by tweaking the touchdown points), but I did encounter one major issue with the XR5. Here is how I reproduced it:

1. Load up the XR5's "Ready for Takeoff to ISS" scenario.
2. The ship starts falling through the ground and tumbling.

The odd thing is that the XR5 is fine when I load up the "Landed at Brighton Beach" scenario: it only falls through the ground when landed at Cape Canaveral. The other XR vessels are fine with similar scenarios at Cape Canaveral.

Here are the new Beta-2 XR DLL builds for Orbiter 2016 RC2:


To run them, just drop the DLLs in to your modules folder overtop of the existing XR DLLs -- all other files are the same.

The only other major issue I found was with OrbiterSound, but I don't think that is an Orbiter core issue: it crashes inside its DLL (orbitersound.dll) with a null pointer whenever I call RequestLoadVesselWave3(...) during vessel startup, but I assume that is because the OrbiterSound DLL needs to be rebuilt for Orbiter 2016. Does OrbiterSound work for anyone else for vessels that use custom sounds?

One more question -- the XR Altitude Hold autopilot invokes the GetAltitude() VESSEL API method to determine how far the ship is above the surface. However, that value no longer returns the above ground level value like it did in Orbiter 2010 (for example, at Brighton Beach the value returned is -2565 meters). Is there an API method that returns the above ground level distance? In other words, I need the value to vary with terrain elevation so the autopilot will know how far it is above the landing surface.
dbeachy1 is offline   Reply With Quote
Old 07-30-2016, 06:14 AM   #295
jarmonik
Beta Tester

Default

Quote:
Originally Posted by dbeachy1 View Post
 One more question -- the XR Altitude Hold autopilot invokes the GetAltitude() VESSEL API method to determine how far the ship is above the surface. However, that value no longer returns the above ground level value like it did in Orbiter 2010 (for example, at Brighton Beach the value returned is -2565 meters). Is there an API method that returns the above ground level distance? In other words, I need the value to vary with terrain elevation so the autopilot will know how far it is above the landing surface.
How about GetAltitude(ALTMODE_GROUND) ?

There are also following functions which may help in some cases.

GetSurfaceElevation()
GetSurfaceNormal()
jarmonik is offline   Reply With Quote
Thanked by:
Old 07-30-2016, 10:26 AM   #296
birdmanmike
Orbinaut
 
birdmanmike's Avatar
Default

Quote:
Originally Posted by dbeachy1 View Post
 Here are the new Beta-2 XR DLL builds for Orbiter 2016 RC2:


To run them, just drop the DLLs in to your modules folder overtop of the existing XR DLLs -- all other files are the same.
OK thanks, that means as I'm still loading up RC2 that I just take the XR downloads from the Altea Aerospace downloads page(or is there another beta build location?) but use the above DLLs. I guess that Dan's UMmu 3 (and UCGO 3) still needed and works?

Thanks
birdmanmike is offline   Reply With Quote
Old 07-30-2016, 12:37 PM   #297
JMW
Aspiring Addon Developer
 
JMW's Avatar
Default

Quote:
Originally Posted by dbeachy1 View Post
 The only other major issue I found was with OrbiterSound, but I don't think that is an Orbiter core issue: it crashes inside its DLL (orbitersound.dll) with a null pointer whenever I call RequestLoadVesselWave3(...) during vessel startup, but I assume that is because the OrbiterSound DLL needs to be rebuilt for Orbiter 2016. Does OrbiterSound work for anyone else for vessels that use custom sounds?
Hi Doug, I'm confused.
You refer to CustomVesselSounds which is a feature of OrbiterSoundSDK40 and then say you are using RequestLoadVesselWave3 which is from the old OrbiterSoundSDK35.
Which SDK are you using ?
OrbiterSoundSDK40 uses RequestLoadVesselWave(...) commands.

With that SDK and commands all works fine with RC2 for me.

I'm also confused as to where these posts should be - http://www.orbiter-forum.com/showthread.php?t=37289 or here ??

Last edited by JMW; 07-30-2016 at 12:43 PM.
JMW is offline   Reply With Quote
Old 07-30-2016, 02:46 PM   #298
dbeachy1
O-F Administrator
 
dbeachy1's Avatar


Default

I'm still building and linking with the OrbiterSound 3.5 SDK, which is why it uses RequestLoadVesselWave3. I try building with OrbiterSound 4 and see how it goes.
dbeachy1 is offline   Reply With Quote
Thanked by:
Old 07-30-2016, 06:07 PM   #299
NukeET
Gen 1:1
 
NukeET's Avatar

Default

Quote:
Originally Posted by dbeachy1 View Post
 I'm still building and linking with the OrbiterSound 3.5 SDK, which is why it uses RequestLoadVesselWave3. I try building with OrbiterSound 4 and see how it goes.

FYI: with Orbiter Sound 4.0 on a clean install of RC2, I'm getting CTD when selecting the Radio/mp3 MFD. No hints as to why per Orbiter.log. My opinion is that Orbiter Sound needs to be adjusted for RC2.
NukeET is offline   Reply With Quote
Thanked by:
Old 07-30-2016, 06:51 PM   #300
JMW
Aspiring Addon Developer
 
JMW's Avatar
Default

NukeET:
Actually, that's been happening with me and others since the first Beta...
http://www.orbiter-forum.com/showthr...&postcount=540
JMW is offline   Reply With Quote
Thanked by:
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Beta


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 06:07 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.