Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Beta
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Orbiter Beta Topics related to Beta releases of Orbiter and Orbiter development.

Reply
 
Thread Tools
Old 07-07-2016, 11:44 PM   #271
Hlynkacg
Aspiring rocket scientist
 
Hlynkacg's Avatar


Default

This may be an odd question but is there a specific .NET Framework I should be using when developing add-ons for the beta? Does it matter? I'm currently using 4.5.2.
Hlynkacg is offline   Reply With Quote
Old 07-08-2016, 12:29 AM   #272
orb
O-F Administrator
Ninja
 
orb's Avatar

Default

Orbiter isn't dependent on any version of .NET Framework. If you want to use .NET with Orbiter add-ons you can use any version (of course you will need to use unmanaged code to interface with Orbiter).
orb is offline   Reply With Quote
Thanked by:
Old 07-08-2016, 09:19 AM   #273
Urwumpe
Certain Super User
 
Urwumpe's Avatar

Default

Is there a bug tracker for Orbiter beta?
Urwumpe is online now   Reply With Quote
Old 07-08-2016, 09:29 AM   #274
DaveS
Addon Developer
 
DaveS's Avatar


Default

Quote:
Originally Posted by Urwumpe View Post
 Is there a bug tracker for Orbiter beta?
Yes here: http://www.orbiter-forum.com/project.php?projectid=1
DaveS is offline   Reply With Quote
Old 07-08-2016, 10:04 AM   #275
Urwumpe
Certain Super User
 
Urwumpe's Avatar

Default

Quote:
Originally Posted by DaveS View Post
Oh OK, thought it was only for the published 2010P1 version. Will file my bug report there then.
Urwumpe is online now   Reply With Quote
Old 07-12-2016, 06:42 PM   #276
martins
Orbiter Founder
Default New Orbiter Beta Released (r.58 aka RC.1, Jul 12 2016)

OVP commit for this beta: r.52

Change log:
  1. bug fix: texpack: TOC now includes nodes without own data to bridge gap to orphaned descendants
  2. bug fix: TileManager2: tile grid resolution was stored as static member but could differ between instances (could lead to memory corruption)
This should address the problem previously noted that texpack misses out any tiles which are not connected to the root by an unbroken chain. The bad news is that you will have to re-run texpack on all layers that caused problems (mostly Earth, from what I gather).

There is also a bug fix that could cause memory corruption if different tile manager instances used different mesh grid resolutions. This would for example occur if the grid resolution was set to 64 or 128, since cloud layers are fixed to 32. This affected both the inline client and D3D7 client.

I've designated this beta as RC.1. See also http://orbiter-forum.com/showthread.php?t=37243
martins is offline   Reply With Quote
Old 07-12-2016, 07:12 PM   #277
GLS
Addon Developer
 
GLS's Avatar
Default

Martin, could you check this out please? http://www.orbiter-forum.com/showthr...&postcount=201
GLS is offline   Reply With Quote
Old 07-12-2016, 09:42 PM   #278
kuddel
Donator
Default D3D9Client 24.1 (for Orbiter BETA r58)

Here's the current D3D9Client (linked against BETA r58)

I could not (yet) test it 'cause my texpack run is not through
but I added all the necessary changes of OVP r52!

/Kuddel

Last edited by kuddel; 10-11-2018 at 09:46 PM.
kuddel is offline   Reply With Quote
Old 07-12-2016, 09:48 PM   #279
kuddel
Donator
Default

--- sorry wrote nonsense ----
kuddel is offline   Reply With Quote
Old 07-14-2016, 08:35 AM   #280
Ripley
Tutorial translator
 
Ripley's Avatar
Default

Will there be other revisions of this version, eventually becoming next RCs, or will it be closed or "frozen" at Rev58?
Since in the RC1 thread you wrote that you are going to remove the low-res packs, it sounds as if it won't work anymore as in the past.
Ripley is offline   Reply With Quote
Old 07-16-2016, 08:40 PM   #281
Eduard
Orbinaut
Default

Hello everyone, I have installed the the latest Beta, 24.1 r.58 now and I am trying to get the newest client D3D9ClientBeta24.1-forBETA r58(r733).zip working, still using the uncompressed planet textures, but now the planet textures are not loaded at all. (The stock client works well and shows alle textures, but the D3D9 client does not.)
I thought that the cashed version should still work. Any ideas?
Eduard is offline   Reply With Quote
Old 07-16-2016, 09:37 PM   #282
jroly
Donator
 
jroly's Avatar
Default

Eduard, there are settings in the launchpad to choose which type or types should be loaded. Play around with that.
jroly is offline   Reply With Quote
Old 07-17-2016, 02:06 PM   #283
Eduard
Orbinaut
Default

Quote:
Originally Posted by jroly View Post
 Eduard, there are settings in the launchpad to choose which type or types should be loaded. Play around with that.
Hi jroly,

I have tried several different options, but I really don't get it working.
Under the "D3D9Client Advanced Setup" (Video -> Advanced) I tried "Cache only", "Cache & Archive" and even "Archive only", but in none of the cases I see any of the uncompressed surface, elevation or cloud textures or other textures.
Also changing from "Load on demand" to "Pre-load at session start" does not make any difference.
And moving de textures from the "Textures" to the "Textures2" directory did not make any difference (I don't know the reason why there are 2 textures directories, maybe someone can explain it).
The only textures I see are the surface bases and the vessels on the planets.

I have archived some Earth textures now with Martin's new texpack-tool in the Utils-directory, and these compressed textures are finally loaded correctly now (when using the "Cache & Archive" or "Archive only" option of course). But the other textures are still never loaded.

The Orbiter.log and D3D9ClientLog.html do not give much information about it. Is there a way I can easily troubleshoot this problem?
Maybe I am doing something very stupid, but I don't see what.

B.t.w. I am using all downloaded textures from http://mirror.orbiter-radio.co.uk/or...turepacks.html, all low res textures and the complete high-resolution packs (not from the "map picker").
Until the latest beta download everything was working well.
Eduard is offline   Reply With Quote
Old 07-17-2016, 03:24 PM   #284
jarmonik
Beta Tester

Default

Quote:
Originally Posted by Eduard View Post
 B.t.w. I am using all downloaded textures from http://mirror.orbiter-radio.co.uk/or...turepacks.html, all low res textures and the complete high-resolution packs (not from the "map picker").
Until the latest beta download everything was working well.
I can confirm the problem there. Although, I took my textures from the map picker. First I though it could be due to missing lvl 10 ??? The map picker contains levels [11-13]. Is the base package (the archive) for level [1-9] or [1-10] ? I copied the lvl-10 manually there but still not working in D3D9. But it is working in the inline engine so obviously it is a D3D9 problem.

I also tried Matrin's D3D7Client form the "RC1" thread but it gives a CTD right after activation from the modules tab. Is there anyone who can run the D3D7Client and see if it works properly ?

I already looked the D3D9 code but couldn't find anything. Running a full analysis of it can take a while.
jarmonik is offline   Reply With Quote
Old 07-17-2016, 06:11 PM   #285
Weirdo Earthtorch
Orbinaut
Default

Wrong thread.

Last edited by Weirdo Earthtorch; 07-18-2016 at 09:34 AM. Reason: Wrong thread
Weirdo Earthtorch is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Beta


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 03:41 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.