Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Beta
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Orbiter Beta Topics related to Beta releases of Orbiter and Orbiter development.

Reply
 
Thread Tools
Old 09-16-2019, 09:17 PM   #586
martins
Orbiter Founder
Default

Good news. It may be that the conflict just happened in the [Current state] scenario, and that got overwritten with a valid one now.

Usually my deployment script set the [Current state] scenario to a defined default one, but it looks like that didn't happen recently, and the scenario just contains whatever I run last myself. I may have to look at my scripts to fix that.
martins is online now   Reply With Quote
Thanked by:
Old 09-20-2019, 04:45 PM   #587
Abloheet
Addon Developer
 
Abloheet's Avatar
Default

What changes are there in the latest beta snapshot rev90?
Abloheet is offline   Reply With Quote
Old 09-20-2019, 06:40 PM   #588
martins
Orbiter Founder
Default

The log should tell you:
Code:
svn log svn://svn.orbiter-forum.com/orbiter | more
martins is online now   Reply With Quote
Thanked by:
Old 10-22-2019, 03:05 AM   #589
TCR_500
Biblical Creationist
 
TCR_500's Avatar
Default

Speaking of revision numbers, the title hasn't been updated to reflect the latest revision or the date of the revision.
TCR_500 is offline   Reply With Quote
Thanked by:
Old 10-22-2019, 01:10 PM   #590
GLS
Addon Developer
 
GLS's Avatar
Default

This is probably related to the terrain changes introduced for Orbiter 2016 and not necessarily any specific BETA, but I found that a VESSEL2-derived vessel, which calls VESSEL2::clbkSaveState( scn ); on exit, will sometimes output garbage into the POS, HEADING, ALT, etc scenario parameters, which then causes a CTD when reloading scenario.
Upgrading to VESSEL3 (both class and the call above) fixes the issue. If I keep the call to VESSEL2, the result isn't correct as I'll get latitude 0, and longitude equal to the heading.
So it looks like the VESSEL2 class doesn't like the terrain, or there's an error somewhere in it. Also of note, as it could be a factor, this happened in SSU's ET vessel, which is a child attachment to the main vessel, which itself is attached to another vessel, and it all is still (landed) on the ground.
GLS is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Beta


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 04:02 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.