Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Support & Bugs > Addon Developer Forums > Space Shuttle Ultra
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Space Shuttle Ultra Support & development threads for Space Shuttle Ultra addon.

Reply
 
Thread Tools
Old 04-15-2019, 03:45 PM   #1
spinkle
Orbinaut
Unhappy SSU compile error c1083

Hi please can anyone help me when trying to build solution for SSU i keep coming up with fatal error C1083 Click image for larger version

Name:	error.jpg
Views:	37
Size:	310.1 KB
ID:	16583 it seems to be asking for orbiterAPI.h file but cant find it
spinkle is offline   Reply With Quote
Old 04-15-2019, 03:49 PM   #2
Urwumpe
Certain Super User
 
Urwumpe's Avatar

Default

Did you check that your include paths are correct?
Urwumpe is offline   Reply With Quote
Old 04-15-2019, 06:02 PM   #3
GLS
Addon Developer
 
GLS's Avatar
Default

Quote:
Originally Posted by Urwumpe View Post
 Did you check that your include paths are correct?
There should be no need for changing any paths, as long as the "Space Shuttle Ultra" folder is inside the Orbitersdk folder.
GLS is offline   Reply With Quote
Old 04-15-2019, 06:58 PM   #4
Urwumpe
Certain Super User
 
Urwumpe's Avatar

Default

Quote:
Originally Posted by GLS View Post
 There should be no need for changing any paths, as long as the "Space Shuttle Ultra" folder is inside the Orbitersdk folder.

Thats what I mean there - the configured paths could be wrong or the checkout folder.
Urwumpe is offline   Reply With Quote
Old 04-17-2019, 06:37 AM   #5
spinkle
Orbinaut
Default

arr no it's not will move it to the correct location and try again thankss
spinkle is offline   Reply With Quote
Old 06-17-2019, 06:22 AM   #6
spinkle
Orbinaut
Default

managed to install but it wont load in im getting this string of errors can anyone shed light on them ?
============================ ERROR: ===========================
Could not load vessel module: SSU_Pad
[Vessel::LoadModule | .\Vessel.cpp | 5747]
================================================== =============
============================ ERROR: ===========================
Could not load vessel module: SSU_LCC
[Vessel::LoadModule | .\Vessel.cpp | 5747]
================================================== =============
============================ ERROR: ===========================
Could not load vessel module: SSU_MLP
[Vessel::LoadModule | .\Vessel.cpp | 5747]
================================================== =============
============================ ERROR: ===========================
Could not load vessel module: SpaceShuttleUltra
[Vessel::LoadModule | .\Vessel.cpp | 5747]
================================================== =============
============================ ERROR: ===========================
Could not load vessel module: SSU_Tank
[Vessel::LoadModule | .\Vessel.cpp | 5747]
================================================== =============
============================ ERROR: ===========================
Could not load vessel module: SSU_SRB
[Vessel::LoadModule | .\Vessel.cpp | 5747]
================================================== =============
============================ ERROR: ===========================
Could not load vessel module: SSU_SRB
[Vessel::LoadModule | .\Vessel.cpp | 5747]
================================================== =============
spinkle is offline   Reply With Quote
Old 06-17-2019, 10:01 AM   #7
GLS
Addon Developer
 
GLS's Avatar
Default

Quote:
Originally Posted by spinkle View Post
 managed to install but it wont load in im getting this string of errors can anyone shed light on them ?
============================ ERROR: ===========================
Could not load vessel module: SSU_Pad
[Vessel::LoadModule | .\Vessel.cpp | 5747]
================================================== =============
============================ ERROR: ===========================
Could not load vessel module: SSU_LCC
[Vessel::LoadModule | .\Vessel.cpp | 5747]
================================================== =============
============================ ERROR: ===========================
Could not load vessel module: SSU_MLP
[Vessel::LoadModule | .\Vessel.cpp | 5747]
================================================== =============
============================ ERROR: ===========================
Could not load vessel module: SpaceShuttleUltra
[Vessel::LoadModule | .\Vessel.cpp | 5747]
================================================== =============
============================ ERROR: ===========================
Could not load vessel module: SSU_Tank
[Vessel::LoadModule | .\Vessel.cpp | 5747]
================================================== =============
============================ ERROR: ===========================
Could not load vessel module: SSU_SRB
[Vessel::LoadModule | .\Vessel.cpp | 5747]
================================================== =============
============================ ERROR: ===========================
Could not load vessel module: SSU_SRB
[Vessel::LoadModule | .\Vessel.cpp | 5747]
================================================== =============
This means Orbiter can't find the vessels in the scenario. Check that the SSU_xyz.cfg files are in the Config\Vessels folder, and the SSU_xyz.dll files are in the Modules folder.
GLS is offline   Reply With Quote
Old 06-18-2019, 05:58 PM   #8
spinkle
Orbinaut
Default

right cracked that problem one more big issue, so I load up the Atlantis test mission and it just boots out, no error logged the only thing I can find in the log is this ...000000.000: >>> WARNING: Obsolete API function used: VESSEL::CreateVariableDragElement
000000.000: At least one active module is accessing an obsolete interface function.
000000.000: Addons which rely on obsolete functions may not be compatible with
000000.000: future versions of Orbiter.g any ideas why it could be booting out?
spinkle is offline   Reply With Quote
Old 06-18-2019, 06:12 PM   #9
GLS
Addon Developer
 
GLS's Avatar
Default

Quote:
Originally Posted by spinkle View Post
 right cracked that problem one more big issue, so I load up the Atlantis test mission and it just boots out, no error logged the only thing I can find in the log is this ...000000.000: >>> WARNING: Obsolete API function used: VESSEL::CreateVariableDragElement
000000.000: At least one active module is accessing an obsolete interface function.
000000.000: Addons which rely on obsolete functions may not be compatible with
000000.000: future versions of Orbiter.g any ideas why it could be booting out?
That's (just) a warning telling us to update some functions.
Are you sure the meshes and textures are also in the correct place? You seem to have messed up the installation...
GLS is offline   Reply With Quote
Old 06-18-2019, 06:21 PM   #10
spinkle
Orbinaut
Default

the path that all the meshes are under is: orbiter 2016/meshes/SSU and textures are under are under orbiter2016/textures/SSU is this correct and do you have a tutorial on how to install this correctly
spinkle is offline   Reply With Quote
Old 06-21-2019, 06:04 AM   #11
spinkle
Orbinaut
Default

Cracked it the issue I was having was due to the fact I was installing the SSU file the correct way, but after reading through the installation instructions again I noticed you have to install it the opposite way round and install it backwards and install orbiter into the SSU folder. now it is up and running with no issues thanks very much for your help
spinkle is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Addons > Addon Support & Bugs > Addon Developer Forums > Space Shuttle Ultra

Tags
# ssu


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 07:20 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.