Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Development
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Addon Development Developers post news, updates, & discussions here about your projects in development.

Reply
 
Thread Tools
Old 01-14-2011, 11:14 PM   #16
vlad32768
Orbinaut
Default

I made a small update due to API change in Blender 2.56.

The script works now in recent Blender 2.5 builds. Functionality is the same.
vlad32768 is offline   Reply With Quote
Old 01-15-2011, 12:03 AM   #17
marooder86
Donator
 
marooder86's Avatar
Default

You've just made my day (or night) mister. I'm gonna try it right now.

Heh, looks like my excitation was premature cause I'm having a bit of a problem here. I've instaled the script but it doesn't show in add on window. I' ve checked if the python script is really placed in proper folder and it's there. Does anyone encounter simillar problem or it's just on my computer.
I'm using Blender 2.56a beta-windows32.

Last edited by marooder86; 01-15-2011 at 07:34 PM. Reason: Script doesn't show in add on window
marooder86 is offline   Reply With Quote
Old 01-15-2011, 10:25 PM   #18
vlad32768
Orbinaut
Default

Quote:
Originally Posted by marooder86 View Post
 Heh, looks like my excitation was premature cause I'm having a bit of a problem here. I've instaled the script but it doesn't show in add on window. I' ve checked if the python script is really placed in proper folder and it's there. Does anyone encounter simillar problem or it's just on my computer.
I'm using Blender 2.56a beta-windows32.
You must download the latest build from graphicall.org.
2.56a beta release from Blender.org uses old API, so don't use it.

Later please write Blender revision number when you report a bug.

Last edited by vlad32768; 01-15-2011 at 10:29 PM.
vlad32768 is offline   Reply With Quote
Old 01-16-2011, 12:10 AM   #19
marooder86
Donator
 
marooder86's Avatar
Default

Quote:
Originally Posted by vlad32768 View Post
 You must download the latest build from graphicall.org.
2.56a beta release from Blender.org uses old API, so don't use it.
That helped thanks
But not every meshes load properly, there are some problems with XR2 and XR5 vessels, well at least a have them.
Here are pictures:
On this you can see error pop up window. I don't know but maybe this is because I loaded it not directly from Orbiter's directory.

And thats how it looks from the bottom. Seems like not entire mesh has been loaded

The Ravenstar is a complete mess

There were no problems with XR1 and other add ons meshes.

Revision number of Blender is: r43338

Last edited by marooder86; 01-16-2011 at 12:22 AM.
marooder86 is offline   Reply With Quote
Old 01-16-2011, 12:49 AM   #20
TSPenguin
The Seeker
 
TSPenguin's Avatar
Default

The XR2 mesh is encrypted. You can not modify it.
TSPenguin is offline   Reply With Quote
Old 01-16-2011, 12:54 AM   #21
marooder86
Donator
 
marooder86's Avatar
Default

Quote:
Originally Posted by TSPenguin View Post
 The XR2 mesh is encrypted. You can not modify it.
I didn't know that thanx for the info.
marooder86 is offline   Reply With Quote
Old 01-16-2011, 01:38 PM   #22
vlad32768
Orbinaut
Default

Quote:
Originally Posted by marooder86 View Post
 But not every meshes load properly, there are some problems with XR2 and XR5 vessels
Fixed bug with XR5 mesh. You can download a new version.



That XR5 mesh is slightly buggy
It has a group with missed UVs, and Blender doesn't like it. Now importer adds (0,0) UVs in that case.

Also XR5 mesh has A LOT of unnecessary geometry, but it doesn't prevent the mesh from being imported, of course.

Last edited by vlad32768; 01-16-2011 at 01:50 PM.
vlad32768 is offline   Reply With Quote
Old 01-16-2011, 02:04 PM   #23
marooder86
Donator
 
marooder86's Avatar
Default

Quote:
Originally Posted by vlad32768 View Post
 Fixed bug with XR5 mesh...
Yes now it works. Man that was a quick fix, and thanx for great plugin.
marooder86 is offline   Reply With Quote
Old 01-16-2011, 08:36 PM   #24
Hielor
Defender of Truth

Default

Quote:
Originally Posted by vlad32768 View Post
 That XR5 mesh is slightly buggy
It has a group with missed UVs, and Blender doesn't like it. Now importer adds (0,0) UVs in that case.
This is not a bug. According to the .msh specification, UV coordinates are optional.
Hielor is offline   Reply With Quote
Old 01-17-2011, 06:07 PM   #25
JMW
Aspiring Addon Developer
 
JMW's Avatar
Default

Hi
Having no luck trying to get Blender to import mesh
Downloaded archive from http://gitorious.org/blender-orbiter...tarball/master
Extracted " io_orbiter_msh.py" to C:\Blender\2.56\scripts\addons. (Thumbnail 4)
Enabled module in File->User Preferences->Add-Ons (I think - no confirmation message)

I get error message as at 3rd thumbnail when trying to import mesh. Nothing appears in Blender scene.

1st. Do I have the right version of Blender.? (One I have is shown at thumbnails 1 & 2.)
2nd. Have I got right version of archive? (blender-orbiter-io-blender-orbiter-io-master.tar).
3rd. Have I put addon in correct directory?

I'm a complete novice with Blender !!. What am I doing wrong ???

Please help.

JMW

Now have error mesage as at Thumbnail 5.

Last edited by JMW; 02-04-2017 at 05:20 PM.
JMW is offline   Reply With Quote
Old 01-17-2011, 06:58 PM   #26
marooder86
Donator
 
marooder86's Avatar
Default

Quote:
Originally Posted by JMW View Post
 Hi
Having no luck trying to get Blender to import mesh
Have yoy tried with different meshes?
Quote:
I get error message as at 3rd thumbnail when trying to import mesh. Nothing appears in Blender scene.
It doesn't look like error message for me. It says that mesh has been imported but seems like it has no faces or vertices at all, like it was an empty object.
Quote:
1st. Do I have the right version of Blender.? (One I have is shown at thumbnails 1 & 2.)
As vlad32768 said the latest builds should work.
Quote:
2nd. Have I got right version of archive? (blender-orbiter-io-blender-orbiter-io-master.tar).
If you downloaded it from the link from the first post of this tread then I belief it's the right one.
Quote:
3rd. Have I put addon in correct directory?
Seems like yes, it's the place it should be.
Quote:
I'm a complete novice with Blender !!. What am I doing wrong ???
If you're new to Blender wouldn't be wiser to get to know it more before trying to import or export meshes.
Try to import some different meshes from your Orbiters directory and see if they work or not. And before importing, delete all object on the scene or at least default cube, you don't need it there
If it won't work anyway then I think you have to wait for updated version of vlad's script or download a little bit older Blender's build, the one I use works perfectly and it;s this one: r43338.
marooder86 is offline   Reply With Quote
Thanked by:
Old 01-17-2011, 09:11 PM   #27
vlad32768
Orbinaut
Default

Quote:
Originally Posted by JMW View Post
 I'm a complete novice with Blender !!. What am I doing wrong ???
You are using the wrong plugin. There are logs of another plugin at thumbnail #3 (possibly Wavefront .obj importer).

You should enable Orbiter mesh import-export in Add-ons tab, and use File->Import->Orbiter mesh (.msh) to import an Orbiter mesh.

Last edited by vlad32768; 01-17-2011 at 09:14 PM.
vlad32768 is offline   Reply With Quote
Thanked by:
Old 01-17-2011, 10:56 PM   #28
JMW
Aspiring Addon Developer
 
JMW's Avatar
Default

Hi vlad.
I can't find a reference to Orbiter in Addons tab?

Last edited by JMW; 02-04-2017 at 05:20 PM.
JMW is offline   Reply With Quote
Old 01-18-2011, 05:34 PM   #29
vlad32768
Orbinaut
Default

Quote:
Originally Posted by JMW View Post
 I can't find a reference to Orbiter in Addons tab?
That's strange. Probably there are some problems with this Blender build.
I can't download R34360 now, but all is OK with Blender 2.56a SVN r34384 Win32 built by BrianSzep.
vlad32768 is offline   Reply With Quote
Old 01-18-2011, 06:09 PM   #30
Kendo
Orbinaut
 
Kendo's Avatar
Default

Hi, it works fine with 2.56a r34371 build win32

Last edited by Kendo; 01-18-2011 at 06:13 PM.
Kendo is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Addons > Addon Development


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 11:38 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.