Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Hardware & Software Help
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Hardware & Software Help Hardware & Software related questions & help.

Reply
 
Thread Tools
Old 06-04-2017, 04:35 PM   #1
Archasio
Orbinaut
Post Help with orbiter versions

Hi

What does for example 2010-P1 mean and how does it differ from build# like 100830. I want to install orbiter 2010 for better add-on compability but I'm unsure what version of the D3D9 to install. The R15? Also, can I install the current version of the xr-vessels or do I have to download some old version?
Archasio is offline   Reply With Quote
Old 06-04-2017, 04:50 PM   #2
PhantomCruiser
Wanderer
 
PhantomCruiser's Avatar

Default

Don't know if it is the latest, but R15 is what I've got on my Orbiter 2010 installation(s).

As far as getting an older version of the XR fleet, AFAIR Doug doesn't host his older versions.
PhantomCruiser is offline   Reply With Quote
Old 06-04-2017, 04:56 PM   #3
Face
Beta Tester
 
Face's Avatar

Default

Quote:
Originally Posted by Archasio View Post
 Hi

What does for example 2010-P1 mean and how does it differ from build# like 100830. I want to install orbiter 2010 for better add-on compability but I'm unsure what version of the D3D9 to install. The R15? Also, can I install the current version of the xr-vessels or do I have to download some old version?
2010-P1 means the first patch of the Orbiter version that came out in the year 2010. Build 100830 is the version that was built at date 10-08-30, meaning year 2010, month 08 (August), day 30. Both designations refer to the same thing: the Orbiter version most understand as "the previous one".

According to jarmonik's SVN repository, the latest version designation for the 2010-P1 branch of D3D9Client is R16.6 . I don't know if there are binaries for that, though. I *think* R15 is OK, though.

The author of the XR-series - Doug Beachy (dbeachy1) - stated that he is not supporting the old versions of his vessels, only the new 2016 builds. AFAIK, he is not offering the old binaries as download anymore, and you can't use the new versions in 2010-P1.

EDIT: 'ed by PC
Face is offline   Reply With Quote
Old 06-04-2017, 05:02 PM   #4
dbeachy1
O-F Administrator
 
dbeachy1's Avatar


Default

That's correct, I don't host or support old XR versions. However, you can still get them on the Internet Wayback Machine here: https://web.archive.org/web/20160313...m/index-3.html
dbeachy1 is offline   Reply With Quote
Thanked by:
Old 06-04-2017, 06:19 PM   #5
Ripley
Tutorial translator
 
Ripley's Avatar
Default

Quote:
Originally Posted by Face View Post
 ...According to jarmonik's SVN repository, the latest version designation for the 2010-P1 branch of D3D9Client is R16.6 . I don't know if there are binaries for that, though. I *think* R15 is OK, though...
Here's the D3D9 16.5:
https://www.orbiter-forum.com/showth...postcount=3691

Didn't know of a 16.6.
Ripley is offline   Reply With Quote
Old 06-04-2017, 06:34 PM   #6
Face
Beta Tester
 
Face's Avatar

Default

Quote:
Originally Posted by Ripley View Post
 Didn't know of a 16.6.
At least that's what's in the code since 2016-04-24, in a commit done by kuddel.
Face is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Hardware & Software Help

Tags
2010, 2016, altea, compbability, version


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 09:21 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.