Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Requests
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Addon Requests If you have a request for a new addon or want to know where to find a specific addon, ask it here!

Reply
 
Thread Tools
Old 04-20-2019, 08:15 PM   #316
pappy2
Orbinaut
Default

Thank you "gattispilot",
I managed to install all with your explanations.

But for takeoff when I select "AND" to make it work with MS15 ignition engines and boosters does not work!

Do you have an idea ??




Last edited by pappy2; 04-20-2019 at 08:47 PM.
pappy2 is offline   Reply With Quote
Thanked by:
Old 04-20-2019, 09:05 PM   #317
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

I don't think it can be done. The launch is done via MS2015 which I don't think has that function
gattispilot is offline   Reply With Quote
Old 04-20-2019, 11:25 PM   #318
Donamy
Beta Tester


Default

Any way you can do it with VB ?
Donamy is online now   Reply With Quote
Old 04-21-2019, 01:05 AM   #319
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Not sure. Ms2015 has an autopilot. Vb not
gattispilot is offline   Reply With Quote
Old 04-21-2019, 01:27 AM   #320
Donamy
Beta Tester


Default

But it has triggers.
Donamy is online now   Reply With Quote
Old 04-21-2019, 09:00 AM   #321
pappy2
Orbinaut
Default

What's odd is that if I change the central tank's unique but keeping your boosters running with MS2015 works.




But when I use the "hutchinson" boosters after the countdown of the MFD no ignition!
pappy2 is offline   Reply With Quote
Old 04-21-2019, 11:17 AM   #322
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

So what need to do is this. Open the scn and go to the scn editor. Then go to Propellant and add fuel to all.
Then save it if you want or continue. On the standard setup I think it has 1 booster and hutchison uses 2.
gattispilot is offline   Reply With Quote
Thanked by:
Old 04-21-2019, 04:06 PM   #323
pappy2
Orbinaut
Default

Quote:
Originally Posted by gattispilot View Post
 So what need to do is this. Open the scn and go to the scn editor. Then go to Propellant and add fuel to all.
Then save it if you want or continue. On the standard setup I think it has 1 booster and hutchison uses 2.
Ah !!! WELL, HERE.
that was it: No fuel ....
Thank you for finding the fault quickly.



By cons I have another concern "hutchison" uses two boosters well in his .ini file and I copy / paste the data for the second booster.
But here is the scenario STS66 during the ejection both boosters leave the same side !



But with the scenario STS93 the two boosters are well ejected from sidebooks.



I do not know how this phenomenon can occur ??

Below my .ini file

Below my .ini file

Code:
[MISC]
cog=38.0
FOCUS=1
THRUST_REAL_POS=1

[TEXTURE_LIST]
TEX_1=Exhaust_atsme
TEX_2=solidfuel_exhaust
TEX_3=contrail4
TEX_4=contrail
TEX_5=contrailSRBA

[PARTICLESTREAM_1]
Name=vent
amin=1e-006
amax=0.1
atmslowdown=0.35
growthrate=0.4
lifetime=1.0
lmax=0.5
lmin=0
srcrate=30
srcsize=0.3
v0=1
ltype=EMISSIVE
atmsmap=ATM_PLOG
levelmap=LVL_PSQRT
tex=contrail

[PARTICLESTREAM_2]
NAME=mach
SRCSIZE=4
SRCRATE=40
V0=12
SRCSPREAD=0
LIFETIME=0.25
GROWTHRATE=4
ATMSLOWDOWN=0
LTYPE=EMISSIVE
LEVELMAP=LVL_PSQRT
LMIN=0
LMAX=4
ATMSMAP=ATM_PLOG
AMIN=0.7e-7
AMAX=1
TEX= contrail

[PARTICLESTREAM_3]
NAME=solidfuel_exhaust
SRCSIZE=3
SRCRATE=12
V0=30
SRCSPREAD=0.05
LIFETIME=1.3
GROWTHRATE=3
ATMSLOWDOWN=0.3
LTYPE=EMISSIVE
LEVELMAP=LVL_PSQRT
LMIN=0
LMAX=1
ATMSMAP=ATM_PLOG
AMIN=1e-6
AMAX=1
TEX=solidfuel_exhaust
GROWFACTOR_RATE=6
GROWFACTOR_SIZE=0.2

[PARTICLESTREAM_4]
NAME=contrail4
SRCSIZE=3
SRCRATE=12
V0=50
SRCSPREAD=0.05
LIFETIME=15.5
GROWTHRATE=3
ATMSLOWDOWN=0.3
LTYPE=EMISSIVE
LEVELMAP=LVL_PSQRT
LMIN=0
LMAX=1
ATMSMAP=ATM_PLOG
AMIN=1e-6
AMAX=1
TEX=contrailSRBA
GROWFACTOR_RATE=6
GROWFACTOR_SIZE=0.2

[PARTICLESTREAM_5]
NAME=launch1
Srcsize=12.000
Srcrate=5000.000
V0=150.000
Srcspread=0.750
Lifetime=16.000
Growthrate=2.500
Atmslowdown=0.750
Ltype=EMISSIVE
Levelmap=LVL_PSQRT
Lmin=0
Lmax=1.000
Atmsmap=ATM_PLOG
Amin=1e-006
Amax=1.000
Tex=contrail4

[FX_VENT]
pstream=vent
off_1=(0,10.1,-28)
dir_1=(0,0,-1)
time_fin_1=-5
off_2=(-2.5,7.5,-28)
dir_2=(0,0,-1)
time_fin_2=-5
off_3=(2.5,7.5,-28)
dir_3=(0,0,-1)
time_fin_3=-5

[FX_MACH]
pstream=mach
mach_min=0.91
mach_max=1.09
off_1=(0,0.2,21.7)
off_2=(5.5,0,12.0)
off_3=(-5.5,0,12.0)
off_4=(0,8.1,9.1)
off_5=(0,17.5,-26.3)
dir=(0,0,-1)

[FX_LAUNCH]
N=2
Height=5
Distance=15
Angle=90
Pstream1=launch1
CutoffAltitude=300

[BOOSTER_1]
N=1
MeshName="2016spaceshuttle\Shuttle_lsrb"
Height=38.5
Diameter=3.71 
EmptyMass=53705.414
FuelMass=503487
Thrust=14739770.25
angle=0.0
off=(-6,0.,2.115)
BurnTime=122.0
eng_1=(-0.2,0,-22.5)
eng_diameter=2.2
ENG_PSTREAM1=solidfuel_exhaust
ENG_PSTREAM2=contrail4
Speed=(15,0,0)
Rot_speed=(0,-0.4,0)
CURVE_1=(-1,0)
CURVE_2=(0,100)
CURVE_3=(30.3,100)
CURVE_4=(35.5,87)
CURVE_5=(60.0,87)
CURVE_6=(65.1,100)
CURVE_7=(103,100)
CURVE_8=(115,85)
CURVE_9=(136,5)

[BOOSTER_2]
N=1
MeshName="2016spaceshuttle\Shuttle_rsrb"
Height=38.5
Diameter=3.71 
EmptyMass=53705.414
FuelMass=503487
Thrust=14739770.25
angle=0.0
off=(6,0.,2.115)
BurnTime=122.0
eng_1=(-0.2,0,-22.5)
eng_diameter=2.2
ENG_PSTREAM1=solidfuel_exhaust
ENG_PSTREAM2=contrail4
Speed=(15,0,0)
Rot_speed=(0,-0.4,0)
CURVE_1=(-1,0)
CURVE_2=(0,100)
CURVE_3=(30.3,100)
CURVE_4=(35.5,87)
CURVE_5=(60.0,87)
CURVE_6=(65.1,100)
CURVE_7=(103,100)
CURVE_8=(115,85)
CURVE_9=(136,5)

[STAGE_1]
Height=46.88 
Diameter=8.7
EmptyMass=26535
FuelMass=728715.23
Thrust=6539030.025
BurnTime=504.1
off=(-0.05,0,13.401)
MeshName="2016spaceshuttle\Shuttle_tank"
eng_1=(-1.6,7.93,-26.88)
eng_2=( 1.6,7.93,-26.88)
eng_3=( 0.0,11.33,-26.03)
DIR=(0.0, 0.25885, -0.96545)
eng_diameter=2.0
speed=(0,0,-10)
ENG_TEX=Exhaust_atsme
battery=1.5
Reignitable=0

[PAYLOAD_1]
MeshName="2016SPACESHUTTLE\Atlantis\Atlantis2016F"
off=(-0.00,8.13,0.0)
Diameter=23.1
Height=36.2
Mass=94130
Module="Atlantis"
Name=STS-66
SPEED=(0,0.8,0)
Rot_Speed=(0.002,0,0)
RENDER=1
LIVE=1

Last edited by pappy2; 04-21-2019 at 04:30 PM.
pappy2 is offline   Reply With Quote
Thanked by:
Old 04-22-2019, 10:32 AM   #324
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

So use this for your boosters:
Code:
[BOOSTER_1]
N=1
MeshName="2016spaceshuttle\Shuttle_lsrb"
Height=38.5
Diameter=3.71 
EmptyMass=66406
FuelMass=503487
Thrust=14739770.25
angle=0.0
off=(-6,0.,2.115)
BurnTime=122.0
eng_1=(-0.2,0,-22.5)
eng_diameter=2.2
ENG_PSTREAM1=solidfuel_exhaust
ENG_PSTREAM2=contrail4
Speed=(-15.000,-4.000,0.000)
Rot_speed=(-0.200,0.400,0.000)
CURVE_1=(-1,0)
CURVE_2=(0,100)
CURVE_3=(30.3,100)
CURVE_4=(35.5,87)
CURVE_5=(60.0,87)
CURVE_6=(65.1,100)
CURVE_7=(103,100)
CURVE_8=(115,85)
CURVE_9=(136,5)

[BOOSTER_2]
N=1
MeshName="2016spaceshuttle\Shuttle_rsrb"
Height=38.5
Diameter=3.71 
EmptyMass=66406
FuelMass=503487
Thrust=14739770.25
angle=0.0
off=(6,0.,2.115)
BurnTime=122.0
eng_1=(-0.2,0,-22.5)
eng_diameter=2.2
ENG_PSTREAM1=solidfuel_exhaust
ENG_PSTREAM2=contrail4
Speed=(15.000,-4.000,0.000)
Rot_speed=(-0.200,-0.400,0.000)
CURVE_1=(-1,0)
CURVE_2=(0,100)
CURVE_3=(30.3,100)
CURVE_4=(35.5,87)
CURVE_5=(60.0,87)
CURVE_6=(65.1,100)
CURVE_7=(103,100)
CURVE_8=(115,85)
CURVE_9=(136,5)
[STAGE_1]
Height=46.88 
Diameter=8.7
EmptyMass=26535
FuelMass=728715.23
Thrust=6539030.025
BurnTime=504.1
off=(-0.05,0,13.401)


---------- Post added 04-22-19 at 05:32 AM ---------- Previous post was 04-21-19 at 04:25 PM ----------

Something I would like to get working better but need help on the code part is the payload bay area.
From 2010 shuttle in the mfd is :


showing IUS tilt and then the IUS is ready for release
then the spin table:


Since we have no payload mfd for the shuttle. I have it just write on the hud. Maybe a pop up window?

But The code I have functions but it would be nice to show the actual tilt angle and spin rpm.

Code:
	if (USEIUS == 1){
		//tilt of ase/IUS


		if (tilt == 1)tiltvalue = .6;  //first step
		if (tilt == 3)tiltvalue = 1.0;  //2nd step
		//phi = phi + .001;//move up second step
		if (tilt == 1)		phi = (phi + .001);//move up
		if (tilt == 2)		phi = (phi - .001);//move down
		if (tilt == 4)		phi = (phi + .001);//move down
		if ((tilt == 1) && (phi > tiltvalue))tilt = 3;  //reaches limit so 1st stop
		if ((tilt == 4) && (phi > tiltvalue))tilt = 0;  //reaches limit so 2nd stop
		if ((tilt == 2) && (phi < 0))tilt = 0;  //reaches limit so stop
		if (phi < 0)phi = 0;
		if (phi >1.0)phi = 1.0;
		//phi = 1;
		xp1 = arm1_tip[1] - arm1_tip[0]; normalise(xp1);
		xr1 = arm1_tip[2] - arm1_tip[0]; normalise(xr1);
		//if ((tilt == 1) || (tilt == 4) || (tilt == 2))phi = phi *simt;  //move ase attachment and ius
		DIR = _V(0, sin(phi), cos(phi));

		SetAttachmentParams(sat_attach4, pl4_ofs, DIR, pl4_rot);//ase
		SetAttachmentParams(sat_attach1, pl1_ofs, DIR, pl1_rot);//ius
		//sets new attachment rotation values for saving
		pl1_dir.x = DIR.x;
		pl4_dir.x = DIR.x;
		pl1_dir.y = DIR.y;
		pl4_dir.y = DIR.y;
		pl1_dir.z = DIR.z;
		pl4_dir.z = DIR.z;

	}
gattispilot is offline   Reply With Quote
Thanked by:
Old 04-22-2019, 03:16 PM   #325
pappy2
Orbinaut
Default

Quote:
Originally Posted by gattispilot View Post
 So use this for your boosters:

Code:
[BOOSTER_1]
N=1
MeshName="2016spaceshuttle\Shuttle_lsrb"
Height=38.5
Diameter=3.71 
EmptyMass=66406
FuelMass=503487
Thrust=14739770.25
angle=0.0
off=(-6,0.,2.115)
BurnTime=122.0
eng_1=(-0.2,0,-22.5)
eng_diameter=2.2
ENG_PSTREAM1=solidfuel_exhaust
ENG_PSTREAM2=contrail4
Speed=(-15.000,-4.000,0.000)
Rot_speed=(-0.200,0.400,0.000)
CURVE_1=(-1,0)
CURVE_2=(0,100)
CURVE_3=(30.3,100)
CURVE_4=(35.5,87)
CURVE_5=(60.0,87)
CURVE_6=(65.1,100)
CURVE_7=(103,100)
CURVE_8=(115,85)
CURVE_9=(136,5)

[BOOSTER_2]
N=1
MeshName="2016spaceshuttle\Shuttle_rsrb"
Height=38.5
Diameter=3.71 
EmptyMass=66406
FuelMass=503487
Thrust=14739770.25
angle=0.0
off=(6,0.,2.115)
BurnTime=122.0
eng_1=(-0.2,0,-22.5)
eng_diameter=2.2
ENG_PSTREAM1=solidfuel_exhaust
ENG_PSTREAM2=contrail4
Speed=(15.000,-4.000,0.000)
Rot_speed=(-0.200,-0.400,0.000)
CURVE_1=(-1,0)
CURVE_2=(0,100)
CURVE_3=(30.3,100)
CURVE_4=(35.5,87)
CURVE_5=(60.0,87)
CURVE_6=(65.1,100)
CURVE_7=(103,100)
CURVE_8=(115,85)
CURVE_9=(136,5)
[STAGE_1]
Height=46.88 
Diameter=8.7
EmptyMass=26535
FuelMass=728715.23
Thrust=6539030.025
BurnTime=504.1
off=(-0.05,0,13.401)


And again thank you "gattispilot"
everything is very good now both boosters separate well each side.





Thank you again for your amazing work on recompiling the 2016 Orbiter Shuttle.

---------- Post added at 03:16 PM ---------- Previous post was at 12:32 PM ----------

Hello "gattispilot",
what are the lines of the files to change to have the right texture of the Atlantis Shuttle for STS-66 ??



The texture exists in your .zip, but I can not find how to change it.
pappy2 is offline   Reply With Quote
Thanked by:
Old 04-22-2019, 03:38 PM   #326
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Well the textures is matched to the mesh which is matched to OV and mid. Look at Post 302. There are 2 Atlantis Orginal and Not Orginal
gattispilot is offline   Reply With Quote
Old 04-22-2019, 04:28 PM   #327
pappy2
Orbinaut
Default

Quote:
Originally Posted by gattispilot View Post
 Well the textures is matched to the mesh which is matched to OV and mid. Look at Post 302. There are 2 Atlantis Orginal and Not Orginal
AH THANK YOU "gattispilot".
Indeed you had already written to me above ...

And here's the result !



Thank you again for your help.

Last edited by pappy2; 04-22-2019 at 05:09 PM.
pappy2 is offline   Reply With Quote
Thanked by:
Old 04-22-2019, 04:59 PM   #328
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Your Welcome. I know that SF had a different docking system. But don't think it did any thing just looks.
I think I could add that panel. Not sure if needed.
Payload Bay function like Tilt Table and spin table will be next update. Not sure about it.

If we could get the all functions of the mfd to work would be great and auto land that would be GREAT.
gattispilot is offline   Reply With Quote
Old 04-22-2019, 05:13 PM   #329
pappy2
Orbinaut
Default

Regarding the automatic launch, the basic NAvette autopilot, can no longer use it with the recompile, this is a choice on your part ?

pappy2 is offline   Reply With Quote
Old 04-23-2019, 09:42 AM   #330
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Yes. So since the launch is ms2015 it uses the AP in Ms2015 rather than the Atlantis. The main reason why was I was not able to switch the meshes for ET, SRB. I know SSU can. So we went with MS2015 for launch.

So maybe I need to update that window. I am more than happy to have code help to fix that so we use the Ap.

---------- Post added 04-23-19 at 04:42 AM ---------- Previous post was 04-22-19 at 12:22 PM ----------

So this is what I get when pressing Ctrl Space
gattispilot is offline   Reply With Quote
Thanked by:
Reply

  Orbiter-Forum > Orbiter Addons > Addon Requests


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 03:53 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.