Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > General Questions & Help
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

General Questions & Help General & Advanced Orbiter flight questions, Orbiter installation questions, to all other help topics here.

Reply
 
Thread Tools
Old 07-31-2019, 12:00 AM   #16
Linguofreak
Orbinaut
Default

Quote:
Originally Posted by jangofett287 View Post
 Lets be clear here, there should be no way for userland code in Win10 to cause a system reset. This is almost certainly hardware related.
Well, either hardware or kernel-mode code (OS, drivers). Given that the last DOS-kernel version of Windows was released almost 20 years ago now, the OS itself should be solid, so either hardware or drivers. I suppose you could say that buggy drivers are hardware related, but most driver related crashes have to do with the driver scribbling over critical kernel data rather than causing the hardware it drives to do nasty things to the system electrically, so I tend to classify them as software bugs.

In any case, any time you get bluescreens or reboots in a 3D application, your GPU drivers are almost always the culprit. After that, it's either some other 3rd party driver, Windows, or a physical problem with the hardware (bad RAM, bad motherboard, etc).
Linguofreak is online now   Reply With Quote
Old 08-01-2019, 12:21 AM   #17
creature
Donator
Default

Tried "windowed" mode today

RGB option it loaded but FPS were very low

all other options=reset

I ve had no other issues with this PC or video card on other graphic intensive sims.

Obviously I don't like to keep crashing my computer so I may give it a rest for a while and just continue to use the Full Screen option. If I come up with anything or a solid log file I will post it. In my opinion, I think it may be the Nvidia driver. My current version is 430.86. There is a new one out but from past experience with Nvidia, "don't fix what ain't broken". My only issue is Orbiter windowed mode. All other sims I use run great.

Thanks for your help
c
creature is offline   Reply With Quote
Old 08-01-2019, 05:38 PM   #18
Marijn
Orbinaut
 
Marijn's Avatar
Default

Quote:
Originally Posted by creature View Post
 In my opinion, I think it may be the Nvidia driver.
Recently, I did a few fresh Win10 installations. After it finishes, Orbiter runs fine. When I installed the latest Nvidia drivers, I got trouble with the 3d device. So it's most likely a driver issue. Associating Orbiter_ng.exe to any Nvidia functionality seems to fail for me.
Marijn is offline   Reply With Quote
Old 08-07-2019, 02:28 AM   #19
creature
Donator
Default

Quote:
Recently, I did a few fresh Win10 installations. After it finishes, Orbiter runs fine.
Just curious if you now the Nvidia driver version that Orbiter worked with before the update and were you able to run in windowed mode.

thx
c
creature is offline   Reply With Quote
Old 08-07-2019, 04:29 AM   #20
Linguofreak
Orbinaut
Default

Quote:
Originally Posted by creature View Post
 Tried "windowed" mode today

RGB option it loaded but FPS were very low

all other options=reset

I ve had no other issues with this PC or video card on other graphic intensive sims.

Obviously I don't like to keep crashing my computer so I may give it a rest for a while and just continue to use the Full Screen option. If I come up with anything or a solid log file I will post it. In my opinion, I think it may be the Nvidia driver. My current version is 430.86. There is a new one out but from past experience with Nvidia, "don't fix what ain't broken". My only issue is Orbiter windowed mode. All other sims I use run great.

Thanks for your help
c
Well, really, "don't fix what ain't broken" is a fairly universal rule when dealing with graphics drivers: they are complex systems and thus bound to be full of bugs (especially given that most GPU manufacturers keep their drivers proprietary), so if you don't have any current issues, it's best not to change anything. But for the same reason, if you are getting bluescreens or reboots when running 3D programs, the very first thing to do is update your drivers. Or, if you're running OpenGL software on ATI hardware (including pretty much anything that's available for any system other than Windows), just buy an NVidia card. ATI's great with DirectX, glitchy/underperformant with OpenGL on Windows, and useless (at least with the manufacturer's drivers) when you aren't running Windows.
Linguofreak is online now   Reply With Quote
Old 08-08-2019, 01:00 AM   #21
creature
Donator
Default

Small update

I updated my Nviida driver to 431.60. No change. works fine in full screen under NG.exe

still no joy with windowed mode or the normal orbiter.exe
creature is offline   Reply With Quote
Old 08-08-2019, 01:27 AM   #22
Frilock
Donator
 
Frilock's Avatar
Default

Have you tried completely removing the old driver?

https://docs.google.com/document/d/1...sW0rLcYQ0/edit

Make sure to follow the advice about disconnecting the internet until you have complete removed/reinstalled the driver
Frilock is offline   Reply With Quote
Old 08-11-2019, 08:19 PM   #23
Treetop64
Orbinaut
 
Treetop64's Avatar
Default

Quote:
Originally Posted by jangofett287 View Post
 Lets be clear here, there should be no way for userland code in Win10 to cause a system reset. This is almost certainly hardware related.
Absolutely agree.

Was having a similar issue a few months ago where anything that asked more of the GPU (graphics intensive games, etc) resulted in a system reboot.

Also noticed later that a red LED on the motherboard indicating a memory issue was on when the computer was turned off.

Turns out that all I had to do was simply re-seat the DIMM and video cards. Started up and the problem hasn't occurred since, and the LED is off.

Lucky that's all it was though, and not an actual hardware issue.
Treetop64 is offline   Reply With Quote
Old 08-11-2019, 09:54 PM   #24
CuriousMarc
Orbinaut
Default

I have a similar issue where Orbiter16 will boot in full screen, but crash in windowed mode (but thankfully not reboot the machine). That's on Win7. Also NVIDIA graphics.
CuriousMarc is offline   Reply With Quote
Old 08-11-2019, 11:51 PM   #25
Linguofreak
Orbinaut
Default

Quote:
Originally Posted by creature View Post
 Small update

I updated my Nviida driver to 431.60. No change. works fine in full screen under NG.exe

still no joy with windowed mode or the normal orbiter.exe
If the issue persists after you try Frilock's recommendation, there is a fairly decent chance that there is a physical problem with your hardware. There's still a chance that it might be a big that NVidia hasn't patched yet, or maybe an OS bug, but the odds that it is hardware related go up significantly at this point.

---------- Post added at 18:51 ---------- Previous post was at 18:43 ----------

Quote:
Originally Posted by CuriousMarc View Post
 I have a similar issue where Orbiter16 will boot in full screen, but crash in windowed mode (but thankfully not reboot the machine). That's on Win7. Also NVIDIA graphics.
The lack of a reboot makes the issue significantly different. It's much more likely to be an Orbiter issue, somewhat less likely to be a driver issue, and much, much, much less likely to be a hardware issue than the OP. You should post a separate thread to make sure that it gets proper attention.
Linguofreak is online now   Reply With Quote
Old 08-21-2019, 11:19 PM   #26
CuriousMarc
Orbinaut
Default

Quote:
Originally Posted by Linguofreak View Post
 If the issue persists after you try Frilock's recommendation, there is a fairly decent chance that there is a physical problem with your hardware. There's still a chance that it might be a big that NVidia hasn't patched yet, or maybe an OS bug, but the odds that it is hardware related go up significantly at this point.

---------- Post added at 18:51 ---------- Previous post was at 18:43 ----------



The lack of a reboot makes the issue significantly different. It's much more likely to be an Orbiter issue, somewhat less likely to be a driver issue, and much, much, much less likely to be a hardware issue than the OP. You should post a separate thread to make sure that it gets proper attention.
And when using the D3D9 client and orbiter_ng instead of the regular orbiter, everything is fine both windowed and full screen mode.
CuriousMarc is offline   Reply With Quote
Thanked by:
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > General Questions & Help


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 04:11 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.