Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Support & Bugs
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Addon Support & Bugs Support & bug reports for Orbiter addons.

Reply
 
Thread Tools
Old 05-02-2018, 05:19 PM   #1
clipper
Orbinaut
Default D3D9 Older Microtextures Issue

So I decided to do some digging in the D3D9 Client topic and eventually I found some older microtextures (I'm talking about the ones found on post #3473 by rstr) and thought about giving them a try. I've personally found them to be better looking than the newer ones posted at the CodePlex page.

I attached the images for comparison so you can judge for yourself (same settings on both plus the official high-resolution Moon textures).

Now the problem I have with the older textures is that at certain angles and altitudes, the ground becomes black (this exact same problem is shown here).

The solution proposed by jarmonik is to either disable the normals (which I did, but I only ended up making the ground bright red instead of black) or to fill the RGB channels of the respective textures. The issue is that I have very limited experience with textures and I do not have Photoshop (I tried using paint.net but that function is not present there), so I wonder if someone could check whether this solution works.

Thank you in advance.
Attached Thumbnails
older textures.jpg   newer textures.jpg  
clipper is offline   Reply With Quote
Old 05-02-2018, 08:12 PM   #2
jarmonik
Beta Tester

Default

The surface reddness issue caused by disabled normals are fixed from this shader. Place it in Modules/D3D9Client/

The old textures are still darkening the surface due to being too dark. An easy way to fix that is to apply a high-pass filter on them in an image editor.

NOTE: Remove *.txt extension from the file name
Attached Files
File Type: txt Surface.fx.txt (34.6 KB, 8 views)
jarmonik is offline   Reply With Quote
Thanked by:
Old 05-02-2018, 09:23 PM   #3
clipper
Orbinaut
Default

Thanks for that, it worked perfectly well!
clipper is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Addons > Addon Support & Bugs


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 05:12 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.