Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Requests
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Addon Requests If you have a request for a new addon or want to know where to find a specific addon, ask it here!

Reply
 
Thread Tools
Old 12-04-2019, 05:46 PM   #946
Marg
Orbinaut
Default

I also thought about few of those things:
1) Shuttle main engines - weren't they stowed, when in orbit (three nozzles were moved closer together)? I saw "SSMES 1 1.0000" entry in Shuttle2016 scenario, I think it is just taken over from Shuttle Fleet scenarios.

2) Shuttle\Orbiter meshes have some holes\gaps, for example, near the one of EThatches\Umbilicals looking from underside. Some others - like RCC panel gaps were edited and are closed. I did not want to mess up with such complex mesh in Anim8or, being afraid to mess up group numbering or something like that, I just looked some vertex numbers and coordinates, and manually edited the .msh file in Notepad.

P.S STSpayload bay texture could be 2x higher resolution (Ku-band antenna texture is a part of it too). And yes, - by the way, I replaced radiator texture with gray texture from SSU (I think SSU), And I made it partially reflective with matte effect. In D3D9 debug I set material reflection ~0.25 and roughness ~0.77. I think this old blue texture was because of maybe Earth reflection in particular photo it was made of...

Last edited by Marg; 12-04-2019 at 05:52 PM.
Marg is offline   Reply With Quote
Thanked by:
Old 12-04-2019, 06:15 PM   #947
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

If you can fix the gaps. Then I can cut the tiles for air probes. Redo the KU antenna. Basically all shuttles used the same mesh with a different texture so the groups would be the same.

Not sure about the SSMEs that is in the Atlantis code also. Do we have a new payload bay texture? I wonder about the shape of the shuttle bay also. Couldn't find a profile image of the sides of the payload..

And if we change that might redo the external hatch as the inside side is the same as the outside

So found these:





So it looks like the sides of the payload bay are straight down. I think in the mesh it is slanted in?

Last edited by gattispilot; 12-04-2019 at 07:06 PM.
gattispilot is offline   Reply With Quote
Old 12-04-2019, 07:23 PM   #948
Donamy
Beta Tester


Default

I can give you the KU mesh that the SSU used before. Or anything else you want to update from the old Fleet model.

Last edited by Donamy; 12-04-2019 at 07:26 PM.
Donamy is offline   Reply With Quote
Thanked by:
Old 12-04-2019, 07:38 PM   #949
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Sounds good. Not sure about the payload bay sides.
gattispilot is offline   Reply With Quote
Old 12-04-2019, 09:26 PM   #950
Marg
Orbinaut
Default

Just wanted to add some notes about PAM-D testing...

Never say "everything OK" too early, I launched STS-51G scenarios, 3 PAM-D satellites.
There are times, when everything works, and there are times when not everything works.
I loaded launch scenario:

1) one time everything OK
2) second time - SPIN1 OK, SPIN2 OK, but SPIN4 shows RPM value -1, and when pressing RPM+ satellite disappears.

similar on orbit, actually there was

1) one time OK
2) second time SPIN1 OK, but if I remember SPIN2 showed RPM value 15004,
pressing RPM+, satellite disappeared.


Seems quite random thing, SPIN1 always seems OK, but other SPINtables can "malfunction", I noticed, when I saw RPM "0" for appropriate SPIN, that means - it will work.
If RPM is -1, or 15004, or something like that (non zero value) - a failure will be.

P.S. Maybe that's idea - to simulate random malfunction of spintables,

P.S.2 After this post I launch on orbit scenario a couple of times - everything was OK. As I saw RPM values "0" I knew all spin tables will be OK, and it was OK. Hm, really seems random.
So it mostly works, and is not a big issue.

And I launched again several times - everything was OK. So maybe its an Orbiter issue ( I run Orbiter 2016, not BETA) , so after all, nevermind...

Last edited by Marg; 12-04-2019 at 09:41 PM.
Marg is offline   Reply With Quote
Old 12-04-2019, 10:38 PM   #951
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Code:
	// ***** 9. SSME pitch gimbal animations
	double init_gimbal = -10*RAD;
	float max_gimbal = (float)(-0.2*PI);
	anim_ssme = CreateAnimation (init_gimbal/max_gimbal);

	static UINT SSMEL_Grp = GRP_SSMEL;
	ssme_anim[0] = new MGROUP_ROTATE (midx, &SSMEL_Grp, 1, _V(-1.55,-0.37,-12.5), _V(-1,0,0), max_gimbal);
	AddAnimationComponent (anim_ssme, 0, 1, ssme_anim[0]);

	static UINT SSMER_Grp = GRP_SSMER;
	ssme_anim[1] = new MGROUP_ROTATE (midx, &SSMER_Grp, 1, _V( 1.55,-0.37,-12.5), _V(-1,0,0), max_gimbal);
	AddAnimationComponent (anim_ssme, 0, 1, ssme_anim[1]);

	static UINT SSMET_Grp = GRP_SSMET;
	ssme_anim[2] = new MGROUP_ROTATE (midx, &SSMET_Grp, 1, _V(0.0,  2.7, -12.5), _V(-1,0,0), max_gimbal);
	AddAnimationComponent (anim_ssme, 0, 1, ssme_anim[2]);
But the value is not saved or loaded.
Code:
void Atlantis::SetSSMEPosition (double pos)
{
	SetAnimation (anim_ssme, pos);
}

So this is the cargo bay. Shouldn't the side be square rather than slanted in?

so I get this for sts51g1


ran the scn 3 times and no issue

I wonder if the KU need to be higher so the dish clears the bay.


So i straighten the sides but noticed the texture for SSu and Atlantis the sides are slanted

Last edited by gattispilot; 12-04-2019 at 10:56 PM.
gattispilot is offline   Reply With Quote
Old 12-05-2019, 12:48 AM   #952
Donamy
Beta Tester


Default

The KU dish you show, should tilt up, not down in the stowed position. And is tilted in slightly for door clearance.

Last edited by Donamy; 12-05-2019 at 12:50 AM.
Donamy is offline   Reply With Quote
Old 12-05-2019, 12:55 AM   #953
Donamy
Beta Tester


Default

Here's a couple drawings
Attached Thumbnails
Ku band DA top.jpg   Ku band DA right.jpg  
Donamy is offline   Reply With Quote
Old 12-05-2019, 01:10 AM   #954
DaveS
Addon Developer
 
DaveS's Avatar


Default

Quote:
Originally Posted by Donamy View Post
 The KU dish you show, should tilt up, not down in the stowed position. And is tilted in slightly for door clearance.
Here's the angle we use for the SSU Ku band assembly:


Deployed Electronics Assembly (DEA, main rectangular silver box): 15s inboard towards the centerline.


Alpha gimbal boom (the short white boom attached to the DEA): 30s inboard as seen from the top


Beta gimbal boom along with the dish: 47.8s downward as seen from the front and 15s up as seen from the right. Dish itself needs to be rotated 0.7s outboard as seen from the top.
DaveS is offline   Reply With Quote
Old 12-05-2019, 10:48 PM   #955
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Thanks. looking at the code and some other things:
from SF scn
Code:
  SSMES 1 1.0000
  ADTA 0 0.0000
  PETD 0 0.0000
  SETD 1 1.0000
  PRADIATOR 0 0.0000
  SRADIATOR 0 0.0000
So the way it looks is they are some action so the first number is the stage and the 2nd animation state.

So ATDA I know I need to add. Easy enough to add the go through the hull. But Cutting the hull and making it rotate might take longer.

But from the Atlantis code
Code:
SetAnimation (anim_rad,  plop->RadiatorStatus.pos);
Code:
void Atlantis::SetRadiatorPosition (double pos)
{
    SetAnimation (anim_rad, pos);
}

void Atlantis::SetKuAntennaPosition (double pos)
{
    SetAnimation (anim_kubd, pos);
}

void Atlantis::SetSSMEPosition (double pos)
{
    SetAnimation (anim_ssme, pos);
}
[CODE] static UINT RRadiatorGrp[1] = {GRP_radiatorFR};
static MGROUP_ROTATE RRadiator (midx, RRadiatorGrp, 1,
_V(2.88, 1.3, 0), _V(0,0,1), (float)(35.5*RAD));
static UINT LRadiatorGrp[1] = {GRP_radiatorFL};
static MGROUP_ROTATE LRadiator (midx, LRadiatorGrp, 1,
_V(-2.88, 1.3, 0), _V(0,0,1), (float)(-35.5*RAD));

anim_rad = CreateAnimation (0);
AddAnimationComponent (anim_rad, 0, 1, &RRadiator);
AddAnimationComponent (anim_rad, 0, 1, &LRadiator);[/CODE

So it looks like may need to break the port/starboard radiatiors into 2 parts. And are the PETD/SETD the aft radiators? or P/S ETDoor?

So on the key command there are just 1 for ET doors and Radiators. But the animation is broke into 2. So from the scn you can have one open/close and the other open/close.

Do we need 2 keys per ETdoor and Radiators.

And on the ATDA there is a key but do we also want it to deploy if airspeed<mach3(3704.404113km/sec)?

---------- Post added at 04:48 PM ---------- Previous post was at 05:26 AM ----------

So got the SSMES to move and PETD ans SETD. BUT on the radiator. The Atlantis has both port and Starboard radiator tied together.
Should they be separate? So you could have the port deployed and starboard stowed?


Also maybe do this for the KU band:

Last edited by gattispilot; 12-05-2019 at 10:59 PM.
gattispilot is offline   Reply With Quote
Old 12-06-2019, 05:39 AM   #956
Donamy
Beta Tester


Default

Yes they should be, but I don't know if they ever were. Other than testing anyway.
Donamy is offline   Reply With Quote
Old 12-07-2019, 07:16 PM   #957
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Thanks. So really not necessary to have PRADiator and SRAdiator. as the animation for both is the same?

So looking at the air data probe.



slanted at 10 degrees.



I know it is an assembly but I do the animation in two parts. 1st part tile rotates into the hull and the probe piece rotates out. That way the alignment doesn't have to be good.

---------- Post added at 03:25 PM ---------- Previous post was at 05:43 AM ----------

I don't know It might just be easier to use the airprobe as is and just have them come thru the hull.






MArq if you can sent me your fixed mesh we are go from there.

---------- Post added 12-07-19 at 01:16 PM ---------- Previous post was 12-06-19 at 03:25 PM ----------

So added the air probes. I also did the interior side of the external hatch. Added the new KU band. But what goes in the red box. It is where the Ku band fits into and above the sill?


Sure I can put a white box there

Last edited by gattispilot; 12-07-2019 at 07:20 PM.
gattispilot is offline   Reply With Quote
Old 12-07-2019, 07:46 PM   #958
DaveS
Addon Developer
 
DaveS's Avatar


Default

Here you go:
Attached Thumbnails
Ku_base.jpg  
DaveS is offline   Reply With Quote
Old 12-07-2019, 10:54 PM   #959
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Thanks.
So this is what we get. I think on the airprobe just rotating out with out cutting the nose may be best.
deploying

deployed:

stowed.

notice the more dark area. may need to merge points. Need to fix the nose gear.

New payload bay with KU.


Right now I have it all swing out. But I think The dish may need to be rotated on deploy?
Code:
// ***** 3. Ku-band antenna animation *****

	static UINT KuBand1Grp[7] = { GRP_DEA_cable_rotating, GRP_Beta_gimbal_boom, GRP_Gimbal_lock_structure, GRP_Alpha_gimbal, GRP_Beta_gimbal_boom, GRP_reciever,GRP_dish };
	static MGROUP_ROTATE KuBand1 (midx, KuBand1Grp, 7,
		_V(2.59, 0.85, 11.727), _V(0, 1, 0), (float)(-113 * RAD));


	anim_kubd = CreateAnimation (0);
	AddAnimationComponent (anim_kubd, 0,     1, &KuBand1);
gattispilot is offline   Reply With Quote
Old 12-07-2019, 11:27 PM   #960
DaveS
Addon Developer
 
DaveS's Avatar


Default

Quote:
Originally Posted by gattispilot View Post
 Right now I have it all swing out. But I think The dish may need to be rotated on deploy?
The dish rotation is part of the Ku band activation procedure. It happens about 2 minutes after powering up the Ku band Electronics Assemblies (EAs). There's two Ku band EAs, EA1 and EA2, both of them live on the middeck. EA1 handles most of the Ku band system including the comm portion while EA2 handles the Rendezvous Radar portion.


The Ku band deploy procedure only rotates the Deployed Assembly (DA) to the deploy position, it doesn't do anything else. Setting up the Ku band system is done through the Ku band activation procedure.
DaveS is offline   Reply With Quote
Thanked by:
Reply

  Orbiter-Forum > Orbiter Addons > Addon Requests


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 05:27 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.