Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Development
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Addon Development Developers post news, updates, & discussions here about your projects in development.

Reply
 
Thread Tools
Old 10-15-2019, 01:03 PM   #31
BrianJ
Addon Developer
Default

Hi,
well, as you say, no real clues in the orbiter.log - although it looks like it is loading the starship_mk1.dll module OK.

It's possible it could be the mesh causing problems.

Attached is a .zip with a simple .cfg based Starship (doesn't use the .dll, just standard Orbiter .cfg and the mesh) and a test scenario with Starship in orbit.
Unzip into your orbiter folder, you'll find the "starship vchamp test" scenario in the main scenario folder.

starship_vchamp_test.zip

Give it a try - if it crashes, its the mesh causing problems.

Cheers,
Brian
BrianJ is offline   Reply With Quote
Old 10-15-2019, 01:29 PM   #32
vchamp
Orbinaut
 
vchamp's Avatar
Default

Thanks, Brian. Tried it, no crash. So the mesh is ok.
Looks great BTW, very good model and textures.

Last edited by vchamp; 10-15-2019 at 01:31 PM.
vchamp is offline   Reply With Quote
Old 10-15-2019, 02:36 PM   #33
BrianJ
Addon Developer
Default

OK, not the mesh then.
It could be a "missing runtime .dll" like msvcrXX.dll or some other dependency - but if you can run any of my other add-ons, this one should be ok.
Not sure what the problem is - sorry! If it's working for other folks, it must be something specific to your set-up. I'll keep looking for possible causes!
Cheers,
Brian
BrianJ is offline   Reply With Quote
Thanked by:
Old 10-15-2019, 03:09 PM   #34
francisdrake
Addon Developer
Default

Quote:
>>> ERROR: DDraw error DDERR_BLTFASTCANTCLIP
000000.000: >>> [OrbiterGraphics::clbkBlt | .\OGraphics.cpp | 1633]
000000.000: ---------------------------------------------------------
This line looks a little suspicious. Could you maybe try the other graphics card, e.g. the Intel onboard graphic chip? It might be related to texture copying within memory.
francisdrake is online now   Reply With Quote
Thanked by:
Old 10-15-2019, 03:11 PM   #35
BrianJ
Addon Developer
Default

@vchamp
Had a quick look at the code, it could be that I'm trying to allocate exhaust textures to non-existent RCS thrusters (ooops!). Tolerable for some but not others??

Here is a new "starship_mk1.dll" module with problem fixed.
Unzip into Orbiter folder and overwrite old .dll module.
Any good?

starship_vchamp_new_dll.zip
BrianJ is offline   Reply With Quote
Thanked by:
Old 10-15-2019, 03:17 PM   #36
BrianJ
Addon Developer
Default

Quote:
Originally Posted by francisdrake View Post
 This line looks a little suspicious. Could you maybe try the other graphics card, e.g. the Intel onboard graphic chip? It might be related to texture copying within memory.
I always get that error with everything! Doesn't cause me any problems (that I noticed). I use my PC's onboard Intel chip graphics. If vchamp has an option to switch between graphics cards, might indeed be worth a try.
BrianJ is offline   Reply With Quote
Old 10-15-2019, 03:25 PM   #37
vchamp
Orbinaut
 
vchamp's Avatar
Default

Quote:
Originally Posted by BrianJ View Post
 @vchamp
Had a quick look at the code, it could be that I'm trying to allocate exhaust textures to non-existent RCS thrusters (ooops!). Tolerable for some but not others??

Here is a new "starship_mk1.dll" module with problem fixed.
Unzip into Orbiter folder and overwrite old .dll module.
Any good?

Attachment 16837
Awesome, that fixed the problem!
vchamp is offline   Reply With Quote
Old 10-15-2019, 03:29 PM   #38
BrianJ
Addon Developer
Default

Ha! Good!
BrianJ is offline   Reply With Quote
Old 10-15-2019, 08:53 PM   #39
4throck
Enthusiast !
 
4throck's Avatar
Default

Thanks for the new .dll, it works great.
Great handling on the Starship, you can really fly it. Great job!
4throck is offline   Reply With Quote
Thanked by:
Old 10-16-2019, 05:25 AM   #40
Gargantua2024
Orbinaut
Default

SpaceX just released this latest launch animation about Starship:

Last edited by Gargantua2024; 10-16-2019 at 05:34 AM.
Gargantua2024 is offline   Reply With Quote
Thanked by:
Reply

  Orbiter-Forum > Orbiter Addons > Addon Development


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 06:13 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.