Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Web Forum
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Orbiter Web Forum A forum for general Orbiter-related comments and discussion. Post your questions about Orbiter and addons in the appropriate forums below. Upload your Orbiter screen shots to our gallery HERE!

Reply
 
Thread Tools
Old 10-07-2019, 04:18 AM   #1
fwd0502
chinese boy,the heir of dragon
Default D3D9's text missing when playing UCGO ISS

As is described in the title,when using UCGO Compatible ISS(by dan) in D3D9 orbiter client,the on screen text is missed so that i cant do any operations with iss(such as open\close airlocks,eva etc).The same problem also occurs on some addons like CTV,ESS station,ATV.Does anyone know how to deal with this tricky problem?
Lots of thanks!
fwd0502 is offline   Reply With Quote
Old 10-07-2019, 04:19 PM   #2
PhantomCruiser
Wanderer
 
PhantomCruiser's Avatar

Default

Yes, it happens. Going by memory here, so I might be all wrong.

Open up the [Video] tab, there should be a checkbox for GDI compatibility. See if that does the trick.
PhantomCruiser is offline   Reply With Quote
Old 10-08-2019, 05:03 AM   #3
fwd0502
chinese boy,the heir of dragon
Default

i’ve avtivated this function,but the problem still exists,so is there another solution?

---------- Post added at 05:03 AM ---------- Previous post was at 02:09 AM ----------

anyone help pleaz!
fwd0502 is offline   Reply With Quote
Old 10-08-2019, 11:39 AM   #4
jarmonik
Beta Tester

Default

The modern computer graphics is being rendered on screen by the GPU located on your video card. However, some add-ons are still insisting to use an old fashion GDI to write some text on the screen and the GDI is simply not designed to work side by side with the GPU. So, the GPU needs to shutdown first to be able to transfer the screen access for the GDI interface. This creates a lot of lag and a poor performance/framerate.


There's been no support for on screen GDI ability for 4-6 years now. I kinda thought that addons had moved to use the Sketchpad instead. I suppose there could be a way to re-enable the GDI partially for the Orbiter 2016 by rerouting the GDI through a texture layer but in that case near black colors would be transparent.
jarmonik is offline   Reply With Quote
Old 10-08-2019, 01:04 PM   #5
n122vu
Addon Developer
 
n122vu's Avatar

Default

If you're using Orbiter 2016, you're out of luck as far as any vessel that utilizes UMMU or UCGO, including the Arrow Freighter, the DGIV, etc. I believe this is a known issue with all of DanSteph's addons. Until he updates them to use Sketchpad and recompiles them with the 2016 SDK, they simply don't work correctly, and in some situations cause a CTD.

If you want to utilize UCGO or UMMU, you'll need to go back to Orbiter 2010 I'm afraid.

Last edited by n122vu; 10-08-2019 at 01:07 PM.
n122vu is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Web Forum


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 05:59 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.