Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > General Questions & Help
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

General Questions & Help General & Advanced Orbiter flight questions, Orbiter installation questions, to all other help topics here.

Reply
 
Thread Tools
Old 08-17-2019, 10:06 PM   #1
Treetop64
Orbinaut
 
Treetop64's Avatar
Default LaunchMFD Failing to Load in Orbiter '10 and '16

In my ongoing quest in reuniting with Orbiter...

Have both Orbiter 2010 (100830) and 2016 (160828) installed.

Launch MFD does not show up in the MFD menu when [SEL] is pressed, in either 2010 or 2016. [SEL] is pressed multiple times to cycle through the complete list.

Both of the latest versions of Launch MFD (v1.6.5-2010 and v1.6.6-2016) were downloaded and installed for their respective orbiter versions, as is also the case for HudDrawer (v0.4 for both) and ModuleMessaging (v2.1d for both).

32bit version of the VC++ Redistribution is downloaded and installed, and system restarted. I have a 64bit OS but since the MFD is a 32bit application I went with the 32bit version.

All are activated without errors in the Modules Tab:






Orbiter logs attached.


I never experienced this issue with LaunchMFD when I used Orbiter '10 before. It is an important tool and if I can't get it to work, that will pretty much nullify any good use I can get from Orbiter. At least if I want to create my own scenarios.

I hate to keep coming here whining about problems. Again, any help is appreciated.

Thank you.
Attached Files
File Type: log Orbiter10.log (29.1 KB, 4 views)
File Type: log Orbiter16.log (40.1 KB, 5 views)
Treetop64 is offline   Reply With Quote
Old 08-23-2019, 11:56 PM   #2
Treetop64
Orbinaut
 
Treetop64's Avatar
Default

A week, and nothing?

Wow.

Well, ok...
Treetop64 is offline   Reply With Quote
Old 08-24-2019, 01:14 AM   #3
PhantomCruiser
Wanderer
 
PhantomCruiser's Avatar

Default

Hey dude, sorry I didn't see your post earlier. Looking through your Orbiter logs doesn't reveal anything particular about your problem.


edit - - -
I didn't have LaunchMFD installed on my Orbiter, so I got it (along with Hud Drawer) and it's not working for me either. This was on Orbiter 2016.

I ran Orbiter 2010 and looked, I have LaunchMFD 1.5.4, so I have an older revision, but it works fine.


I'd shoot enjo a pm and see if he could help you out, or post on the development thread here https://www.orbiter-forum.com/showth...t=768#post5984
The last post on that thread was in November last year, but (CafuneanChill) reinstalled Visual C++and he got it working

Last edited by PhantomCruiser; 08-24-2019 at 01:26 AM.
PhantomCruiser is offline   Reply With Quote
Old 08-24-2019, 05:01 AM   #4
Enjo
Mostly harmless
 
Enjo's Avatar


Default

I didn't see this post either. What I do look for are posts where I replied at least once. Everything else is just too much overhead.

So your log file shows this message:

"Error loading module Modules\Plugin\LaunchMFD.dll (code 14001)"

Googling the error code reveals answers like this one:
https://stackoverflow.com/questions/...ror-code-14001

Short version:
Install Dependency Walker and see what additional DLL is missing. The clues point to (still) missing VC++ Runtime. Maybe you installed the one without the service pack?
Enjo is offline   Reply With Quote
Old 08-25-2019, 08:40 AM   #5
Treetop64
Orbinaut
 
Treetop64's Avatar
Default

Thank you for the replies.

As for service packs for the VC++ I downloaded and installed the latest versions for VS 2015, 2017, and 2019. Would I still need to install separate service packs for these?

Also, I learned that the latest VC++ versions have their own distinct runtime files that are not shared with previous versions. Could this be the cause of the problem and if so, how do I know which legacy version to install to support LaunchMFD?

I ran Dependecy Walker and selected ...Modules\Plugin\LaunchMFD.dll, though I have no idea what I'm looking at or what to do when it finishes looking at the dll. Lots of red text and errors, including not finding orbiter.exe (??) among other issues.
Treetop64 is offline   Reply With Quote
Old 08-25-2019, 01:34 PM   #6
Enjo
Mostly harmless
 
Enjo's Avatar


Default

And what about this one?
https://www.microsoft.com/en-us/down....aspx?id=26347
Enjo is offline   Reply With Quote
Thanked by:
Old 08-25-2019, 02:28 PM   #7
soumya-8974
Wiktronaut
 
soumya-8974's Avatar
Post Re: LaunchMFD Failing to Load in Orbiter '10 and '16

Yes, the Launch MFD and other MFDs by enjo and ADSWNJ are solely dependent with MSVC++ 2019 or newer. So, I am trying not to use it!
soumya-8974 is offline   Reply With Quote
Old 08-25-2019, 10:37 PM   #8
Treetop64
Orbinaut
 
Treetop64's Avatar
Default

Quote:
Originally Posted by Enjo View Post
That was it. LaunchMFD now runs on 2010 and 2016.

Thank you!

Treetop64 is offline   Reply With Quote
Thanked by:
Old 08-27-2019, 03:00 AM   #9
Enjo
Mostly harmless
 
Enjo's Avatar


Default

Quote:
Originally Posted by soumya-8974 View Post
 Yes, the Launch MFD and other MFDs by enjo and ADSWNJ are solely dependent with MSVC++ 2019 or newer. So, I am trying not to use it!
This is not entirely true. My addons use VC++ 2008 SP1 only, only addons by ADSWNJ use VC++2019. His addons also mean MMExt module, but you don't have to use it to use my MFDs. But this is a sad thing to hear in this context, because I was struggling hard to make my addons compatible with WinXP era PCs, and then I became (partly) reliant on VC++2019 through ADSWNJ's compiler. I was considering making a regular (on each version) recompile of the MMExt, to keep it VC++2008 compatible, but I really lack motivation to do it, as I'm completely focused on making a living.

Quote:
Originally Posted by Treetop64 View Post
 That was it. LaunchMFD now runs on 2010 and 2016.
Thank you!

Great!
Mind you, the link to the VC is on the OrbitHangar description.

Last edited by Enjo; 08-27-2019 at 03:03 AM.
Enjo is offline   Reply With Quote
Old 08-30-2019, 06:55 PM   #10
ADSWNJ
Scientist
 
ADSWNJ's Avatar
Default

Quote:
Originally Posted by soumya-8974 View Post
 Yes, the Launch MFD and other MFDs by enjo and ADSWNJ are solely dependent with MSVC++ 2019 or newer. So, I am trying not to use it!
I see this is fixed, which is good. Just to clarify on my addons: they are compiled in MSVC++ 2017, and statically linked to avoid runtime issues as you had. Avoid them if you wish though.
ADSWNJ is offline   Reply With Quote
Thanked by:
Old 08-31-2019, 06:53 AM   #11
Enjo
Mostly harmless
 
Enjo's Avatar


Default

Quote:
Originally Posted by ADSWNJ View Post
 and statically linked
I completely forgot about it!

---------- Post added at 08:53 AM ---------- Previous post was at 07:56 AM ----------

Quote:
Originally Posted by ADSWNJ View Post
 Avoid them if you wish though.
I agree, that it was not a nice thing from him to write, but I carry some guilt here. Soumya asked me for support via private message about half a year ago regarding a similar issue, but at that point of time I had a very hard situation in RL, so I couldn't reply. On the other hand I'm not hired here for a paid support, or sth, so do have some respect for the free work, that we provide and had provided for you, through working code. If the VC++ is your enemy, then take my addons and compile them from source. How hard is this?

Last edited by Enjo; 08-31-2019 at 08:20 AM.
Enjo is offline   Reply With Quote
Thanked by:
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > General Questions & Help


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 09:10 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.