Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Requests
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Addon Requests If you have a request for a new addon or want to know where to find a specific addon, ask it here!

Reply
 
Thread Tools
Old 10-13-2017, 10:29 AM   #241
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

So here is a complied module for testing.

So pressing k opens the gate. The only thing odd is when I exit it and shut the launchpad down it says another orbiter is running:

Finished initialising status
Finished initialising camera
Finished initialising panels
Finished setting up render state
**** Closing simulation session
Attached Files
File Type: zip gatewaytest3.zip (54.3 KB, 6 views)
gattispilot is offline   Reply With Quote
Thanked by:
Old 11-09-2017, 11:23 AM   #242
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

I added a debug script.

Shouldn't rel z gate position get smaller as you near the gate. I noticed it was getting larger and then when it got to the center the gate had closed not more debug but the ship didn't move to the next gate?

---------- Post added 11-09-17 at 05:11 AM ---------- Previous post was 11-08-17 at 07:22 AM ----------




Quick save before the gate

Code:
BEGIN_SHIPS
Gate_A:WORMHOLE
  STATUS Orbiting Earth
  RPOS 642609.01 -0.02 6978589.43
  RVEL -7510.130 -0.000 691.623
  AROT 0.00 2.44 0.00
  RCSMODE 2
  AFCMODE 7
  NAVFREQ 0 0
  XPDR 0
END
Gate_B:WORMHOLE
  STATUS Orbiting Moon
  RPOS 1678081.40 1583306.51 172452.76
  RVEL 811.921 812.276 22.717
  AROT -0.22 0.23 0.00
  AFCMODE 7
  NAVFREQ 0 0
  XPDR 0
END
ENDURANCE:ENDURANCENEW
  STATUS Orbiting Earth
  RPOS 642663.90 -0.00 6978653.57
  RVEL -7509.713 -0.000 689.122
  AROT 0.00 13.81 0.00
  VROT 0.00 0.06 0.00
  RCSMODE 2
  AFCMODE 7
  PRPLEVEL 0:0.999984
  DOCKINFO 2:0,LANDER1 3:0,LANDER2
  NAVFREQ 0 0
  XPDR 0
  CARGO1 0 0.0000
  CARGO2 0 0.0000
  CARGO3 0 0.0000
  CARGO4 0 0.0000
  CARGO5 0 0.0000
  CARGO6 0 0.0000
  CARGO7 0 0.0000
  CARGO8 0 0.0000
  CARGO9 0 0.0000
  10CARGO 0 0.0000
  11CARGO 0 0.0000
  12CARGO 0 0.0000
  13CARGO 0 0.0000
  14CARGO 0 0.0000
  15CARGO 0 0.0000
  16CARGO 0 0.0000
  POD 1 
  DOCKSELECT 1 
  DOCK1 0 0.0000
  DOCK2 0 0.0000
  DOCK3 0 0.0000
  DOCK4 0 0.0000
  DOCK5 0 0.0000
  DOCK6 0 0.0000
  DOCK7 0 0.0000
  DOCK8 0 0.0000
  DOCK9 0 0.0000
  10DOCK 0 0.0000
  11DOCK 0 0.0000
  UMMUCREW CASE-CASE-10-70-70
END
quicksave passing thru:
Code:
BEGIN_SHIPS
Gate_A:WORMHOLE
  STATUS Orbiting Earth
  RPOS 6837.93 -0.03 7008117.77
  RVEL -7541.897 -0.000 7.467
  AROT 0.00 2.44 0.00
  RCSMODE 2
  AFCMODE 7
  NAVFREQ 0 0
  XPDR 0
END
Gate_B:WORMHOLE
  STATUS Orbiting Moon
  RPOS 1744318.85 1649702.29 174136.05
  RVEL 758.066 761.402 17.262
  AROT -0.22 0.23 0.00
  AFCMODE 7
  NAVFREQ 0 0
  XPDR 0
END
ENDURANCE:ENDURANCENEW
  STATUS Orbiting Earth
  RPOS 6927.89 -0.01 7007970.76
  RVEL -7541.487 -0.000 4.959
  AROT 0.00 18.87 0.00
  VROT 0.00 0.06 0.00
  RCSMODE 2
  AFCMODE 7
  PRPLEVEL 0:0.999984
  DOCKINFO 2:0,LANDER1 3:0,LANDER2
  NAVFREQ 0 0
  XPDR 0
  CARGO1 0 0.0000
  CARGO2 0 0.0000
  CARGO3 0 0.0000
  CARGO4 0 0.0000
  CARGO5 0 0.0000
  CARGO6 0 0.0000
  CARGO7 0 0.0000
  CARGO8 0 0.0000
  CARGO9 0 0.0000
  10CARGO 0 0.0000
  11CARGO 0 0.0000
  12CARGO 0 0.0000
  13CARGO 0 0.0000
  14CARGO 0 0.0000
  15CARGO 0 0.0000
  16CARGO 0 0.0000
  POD 1 
  DOCKSELECT 1 
  DOCK1 0 0.0000
  DOCK2 0 0.0000
  DOCK3 0 0.0000
  DOCK4 0 0.0000
  DOCK5 0 0.0000
  DOCK6 0 0.0000
  DOCK7 0 0.0000
  DOCK8 0 0.0000
  DOCK9 0 0.0000
  10DOCK 0 0.0000
  11DOCK 0 0.0000
  UMMUCREW CASE-CASE-10-70-70
END
a DG will be transported. Not sure why passing thru the relpos of GAte A changed?
Code:
				{
					VESSELSTATUS2 vs_vessel, vs_other_gate;
					memset(&vs_vessel, 0, sizeof(vs_vessel));
					memset(&vs_other_gate, 0, sizeof(vs_other_gate));
					vs_vessel.version = 2;
					vs_other_gate.version = 2;

					VESSEL *v;
					v = oapiGetVesselInterface(hvessel);
					v->GetStatusEx(&vs_vessel);
					OBJHANDLE h_other_gate;
					char myname[16];
					char GateA[16];
					sprintf(myname, GetName());
					sprintf(GateA, "Gate_A");
					if (strcmp(myname, GateA) == 0)
					{
						h_other_gate = oapiGetVesselByName("Gate_B");
					}
					else{
						h_other_gate = oapiGetVesselByName("Gate_A");
					}
					VESSEL *v_other_gate;
					v_other_gate = oapiGetVesselInterface(h_other_gate);
					v_other_gate->GetStatusEx(&vs_other_gate);
					vs_vessel.rbody = vs_other_gate.rbody;
					vs_vessel.rpos = vs_other_gate.rpos;
					vs_vessel.vrot = vs_other_gate.vrot;
					vs_vessel.arot = vs_other_gate.arot;

			//		VECTOR3 outvel = _V(rvel.x, rvel.y, rvel.z);
			//		VECTOR3 rofs;
			//		GlobalRot(outvel, rofs);
			//		vs_vessel.rvel.x = vs_other_gate.rvel.x + rofs.x;
			//		vs_vessel.rvel.y = vs_other_gate.rvel.y + rofs.y;
			//		vs_vessel.rvel.z = vs_other_gate.rvel.z + rofs.z;




					jump = false;

					v->DefSetStateEx(&vs_vessel);
				}



			}


		}


	}


---------- Post added at 05:23 AM ---------- Previous post was at 05:11 AM ----------

So if the vessel has attachments it will not jump. Not sure there is a fix for that
gattispilot is offline   Reply With Quote
Old 11-10-2017, 08:43 AM   #243
jedidia
shoemaker without legs
 
jedidia's Avatar
Default

Quote:
Shouldn't rel z gate position get smaller as you near the gate.
Depending on where and how you are generating the debug string, what you see on the screen might not be the relative position at the gate you are next to, but to the gate that was processed last in orbiters queue.
jedidia is offline   Reply With Quote
Old 11-10-2017, 10:30 AM   #244
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Thanks. I guess the issue is if the vessel has attachments then it will not be moved to the other gate?
gattispilot is offline   Reply With Quote
Old 11-13-2017, 10:33 AM   #245
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

So if a vessel has another vessel attached the gate thinks it sent the ship but it doesn't. Any ideas how to get an ship with attached vessel to be transported? Docked vessel no issue
gattispilot is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Addons > Addon Requests


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 02:02 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.