Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > General Questions & Help
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

General Questions & Help General & Advanced Orbiter flight questions, Orbiter installation questions, to all other help topics here.

Reply
 
Thread Tools
Old 12-01-2016, 02:13 AM   #1
Aeadar
Lurker Representitive
 
Aeadar's Avatar
Default Windows 10 versus Orbiter

So I'm wondering if there's something about Windows 10 that makes Orbiter run at ridiculously low framerates?

Some background: After my good machine died about a year ago, I started running Orbiter on a cheap ($250) Acer machine. I bought the Acer kind of on a lark; my (then) current internet machine was nearing the end of its useful life, and the 'new' Windows 8 machines were about to hit the shelves and I much prefer having the last version of an operating system than the first. So I picked up the Acer, took it home, and put it in the closet.

Fast forward a few months and it was time to replace the old internet computer. And the Acer did ok...not good but not bad either.

Some time later, My Cyberpower died, so the Acer took over the Orbiter duties, and again, not great, not awful. My average framerate- about 25-30FPS...if in a moderately graphically intense area, say, sitting in an Arrow freighter parked at Niven Lunar base, I'd get about 9-12 FPS. Not good, but usable.

Now fast forward to last Sunday. I go to play Orbiter and, when I try to power up the Acer, it no longer accepts my password. Tried numerous times to no avail (I didn't know it but Windows 7 tells you the correct password after entering an incorrect one).

Funny thing is, if I boot into Safe mode, it still asks for the password, and actually accepts it.

Anyway, I'm two blocks from Office Depot and I really didn't like the Acer (Other than the Cyberpower, I've always owned HPs), so I went over to Office Depot and found a $250 HP. Now, being not only lazy, but also on a very tight budget, I employed the following logic: "If a $250 Acer does ok, then surely a $250 HP would do better."

Initially, I was pleased; OF members may remember an old Scott Manley video showing asteroid discoveries from 1980-2010. When trying to play this video on the Acer, it would begin to pause and pixelate not even halfway through. So this was the first video I tried on the new HP...and it played perfectly! No glitching, no pauses or pixelating at all.
Very pleasing.

So I tried Orbiter.

Set up the launchpad the same as I had it before, and started up my current scenario (Arrow freighter and Prelude base next to Niven Base) and...2 frames per second! I've tried windowed mode(no effect) and lowering the screen resolution (takes me to 3 FPS).

I seem to remember some discussion on the forum related to Windows 10, and I have tried searching 'windows 10'. Unfortunately, the OF search engine drops the '10' and ends up presenting me with several dozen threads. And in addition to hating Orbiter, Win10 also seems to have a serious dislike for wifi as well.
Now my wifi IS slow, but I've never seen it as slow as it is now. Literally, if I click on a thread here, it takes 40 to 90 seconds before the 'home' screen goes away and the 'thread' screen begins to build.

So I guess my question(s) are: Has anyone here had similar problems with Win10 and what remedies can be employed?
And, in regards to the Acer, barring a 'password recovery disk', which I don't have available, might there be any way around my password suddenly not being accepted (other than in Safe mode)?

Thanks very much for any replies.
Aeadar is offline   Reply With Quote
Old 12-01-2016, 03:25 AM   #2
hutchison66
Donator
Default

I changed over to windows 10 6 months ago I was getting 50 FPS on my Hp Pavilion while on windows 8, I was running a very intensive ISS model. when I changed over to windows 10 I went down to 8 FPS I went through a load of settings and couldn't get it to run any faster so I took the chance to go back to windows 8 and recommend staying on it I don't think windows 10 has any more benefits to make it worth moving over
so stay on Windows 8 people
hutchison66 is offline   Reply With Quote
Thanked by:
Old 12-01-2016, 05:42 AM   #3
dbeachy1
O-F Administrator
 
dbeachy1's Avatar


Default

Orbiter runs perfectly on Windows 10 for me. In any case, I suggest using the D3D9 Orbiter client rather than the default DX7 client -- the D3D9 client has much higher framerates in addition to more eye candy.
dbeachy1 is offline   Reply With Quote
Old 12-01-2016, 07:10 AM   #4
Ripley
Tutorial translator
 
Ripley's Avatar
Default

A 250$ machine can't have a dedicated graphics card, so the question is: what CPU do you have now on your HP, and what was ACER's one?

I'm on Win10 and no problems.
Ripley is offline   Reply With Quote
Thanked by:
Old 12-01-2016, 07:19 AM   #5
IronRain
Orbinaut
 
IronRain's Avatar

Default

2 Windows 10 machines -> no problems.
IronRain is offline   Reply With Quote
Thanked by:
Old 12-01-2016, 08:26 AM   #6
PhantomCruiser
Wanderer
 
PhantomCruiser's Avatar

Default

I'd upgraded my 5 year old machine to Win10 when it made itself available. Orbiter was the first thing I ran on it. I didn't really see any notable difference between 8 and 10.

Now if it would just run the new Tomb Raider...

Last edited by PhantomCruiser; 12-18-2016 at 09:35 AM.
PhantomCruiser is offline   Reply With Quote
Thanked by:
Old 12-01-2016, 10:44 AM   #7
Xyon
Puts the Fun in Dysfunctional
 
Xyon's Avatar


Default

Quote:
Originally Posted by Ripley View Post
 A 250$ machine can't have a dedicated graphics card, so the question is: what CPU do you have now on your HP, and what was ACER's one?

I'm on Win10 and no problems.
Sure it could - admittedly not a very good one, but this would probably squeeze into the budget for a low-spec system at that kind of cost.

Quote:
Originally Posted by Aedar
  (I didn't know it but Windows 7 tells you the correct password after entering an incorrect one).
Windows 7 shows your password hint after you input an incorrect password, not the password itself. If your hint is too expositional, that's your own fault for putting it in there.

As for Windows 10 itself, I've not noticed it getting in the way of Orbiter at all, but you do need to make sure your computer can handle what you're asking of it. Frankly, if your box is comfortable running Windows 10, I can't imagine Orbiter will add much stress on top of that kind of load.
Xyon is offline   Reply With Quote
Thanked by:
Old 12-01-2016, 03:24 PM   #8
jangofett287
Heat shield 'tester'
 
jangofett287's Avatar
Default

One thing, Dx7 is not hardware accelerated on Win10. So if you're using the inline client all the rendering is being done on your CPU along with the actual simulation.
jangofett287 is offline   Reply With Quote
Thanked by:
Old 12-01-2016, 11:25 PM   #9
Aeadar
Lurker Representitive
 
Aeadar's Avatar
Default

Quote:
Originally Posted by Xyon View Post
 Sure it could - admittedly not a very good one, but this would probably squeeze into the budget for a low-spec system at that kind of cost.



Windows 7 shows your password hint after you input an incorrect password, not the password itself. If your hint is too expositional, that's your own fault for putting it in there.

Thanks for the replies all.

And thanks for the link Xyon; I might try that, except this new machine (like the Acer) is one of those 'slimline' models (a touch over 4 inches outside width), so I don't know if it would fit. May just take it back and see what else they have.

Actually, the password hint was in fact the four-digit password.

Aeadar is offline   Reply With Quote
Old 12-02-2016, 12:39 AM   #10
Hielor
Defender of Truth

Default

Quote:
Originally Posted by Aeadar View Post
 Actually, the password hint was in fact the four-digit password.
Not the best choice for a hint. I believe newer version of Windows don't let you include the password itself in the hint.
Hielor is offline   Reply With Quote
Old 12-02-2016, 10:07 AM   #11
4throck
Enthusiast !
 
4throck's Avatar
Default

No problems with Windows 10, even on a 8 year old PC.

But you must configure it to run properly.
Learn about disabling some background services (telemetry) that will use up your memory and disk access. Also the cache location and usage of USB "readyboost" will impact performance.

With those optimizations in place, Windows 10 outperforms 7 on my machine
4throck is offline   Reply With Quote
Thanked by:
Old 12-18-2016, 05:43 AM   #12
FlyingSinger
Donator
 
FlyingSinger's Avatar


Default D3D9 on new Windows 10 PC?

I have a related question with Orbiter 2016 on a brand new Windows 10 "gaming" PC that I got mainly for music recording and Orbiter.

I have Orbiter 2016 installed on an external USB drive which I have used to run Orbiter on both my work laptop and my "old" home laptop. On both of these PC's, I had been using the NG version of Orbiter, with the latest D3D9Client installed in the Orbiter directory. This has worked fine on both of those PC's.

When I run the NG version on the new PC (running directly from the Orbiter install on the same external drive), it doesn't show the video controls in the launchpad window, and when I launch a scenario, I get only the black DOS window with "no client attached." The D3D9Client is checked in the Modules tab, and I get no "missing DLL" or similar error message.

It seems I have forgotten a step required to activate the DXD9 client on this new machine. I was worried that maybe it wouldn't work at all on Win10, but I see here that several people are using it with Win10.

Any ideas here? I am probably missing something simple.

Thanks,
Bruce

P.S. The "good news" is that this 8-core machine with NVIDIA graphics is fast enough to give me a decent frame rate even with Orbiter's default DX7 graphics. I was getting single digit fps on my two laptops, but D3D9 works great on both.

---------- Post added 12-18-16 at 12:43 AM ---------- Previous post was 12-17-16 at 11:01 PM ----------

I accidentally figured this out. I used my Steam account to install Universe Sandbox on the new PC, and its installer realized that this new PC did not have DirectX installed (I thought this would be a standard part of Windows 10, or added on a so-called "gaming PC," but I guess not). Once I saw that it had installed DirectX, I tried Orbiter_ng again and it worked like a champ, with frame rates from 200 to 890 fps. Probably sufficient for most things.

Thanks,
Bruce
FlyingSinger is offline   Reply With Quote
Old 12-18-2016, 12:41 PM   #13
jedidia
shoemaker without legs
 
jedidia's Avatar
Default

Quote:
I used my Steam account to install Universe Sandbox on the new PC, and its installer realized that this new PC did not have DirectX installed
That is majorly weird... DirectX is practically an integral part of windows by this time.
jedidia is offline   Reply With Quote
Old 12-18-2016, 12:55 PM   #14
FlyingSinger
Donator
 
FlyingSinger's Avatar


Default

Quote:
Originally Posted by jedidia View Post
 That is majorly weird... DirectX is practically an integral part of windows by this time.
Yes, but my explanation is probably wrong about this. It obviously had SOME version of DX installed because Orbiter ran with its native (DX7?) graphics. But whatever was installed or updated by the Steam/Universe Sandbox installer made the difference for orbiter_ng. Keep in mind that this was practically an out-of-the-box new PC and that I don't know much about Windows!
FlyingSinger is offline   Reply With Quote
Old 12-18-2016, 06:48 PM   #15
jedidia
shoemaker without legs
 
jedidia's Avatar
Default

Basically all post win2000-systems were delivered with DX9+. Might still be an issue that the client requires a certain service pack, but with Win10? That's got DX12 bundled with it. What I could imagine is that your GPU drivers were severly out of date or badly installed, and that steam fixed that. I know Steam has the capability to do that, but usually it doesn't do it without asking... ?
jedidia is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > General Questions & Help


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 07:09 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.