Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Requests
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Addon Requests If you have a request for a new addon or want to know where to find a specific addon, ask it here!

Reply
 
Thread Tools
Old 12-08-2019, 12:23 AM   #961
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

So for a simple KU. activation would be swing out 113 degrees. Then the dish rotates around?
gattispilot is offline   Reply With Quote
Thanked by:
Old 12-08-2019, 01:21 AM   #962
DaveS
Addon Developer
 
DaveS's Avatar


Default

Quote:
Originally Posted by gattispilot View Post
 So for a simple KU. activation would be swing out 113 degrees. Then the dish rotates around?
No. Ku deploy is what rotates the entire Ku band antenna (called the Deployed Assembly, DA). This is done by placing both PLB MECH PWR switches in the ON position and then placing the KU ANT switch in DPY position.


The rotation of the dish to the so called "Master Index Pulse" position (this makes the gimbals seek out their null positions (0)) happens during KU-BD ACTIVATION once the KU BD PWR switch is placed in the ON position. This switch isn't on the R13L panel but rather the A1U panel.
DaveS is online now   Reply With Quote
Thanked by:
Old 12-08-2019, 08:01 AM   #963
Marg
Orbinaut
Default

Unfortunately I haven't worked too much on shuttle mesh, only a bit closing gap around one of the umbilical doors. Maybe it is not a biggest issue after all. I saw some other smaller gaps when viewing close in...
I thought for a while, there would be an idea to introduce internal frame, which blocks all "holes"...

By the way, cockpit rear windows (to payload bay) actually had black frame around them... they were somehow more complex, I think Gazza's STS-VC had something similar.
Marg is offline   Reply With Quote
Old 12-08-2019, 12:17 PM   #964
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

So fix the ethatch gaps.
On the window frame. Gazza St vc was plyon and no mesh change.
In sf no frame really.

sts2016



Can you send a image of the black frames. I did notice in SF the aft cockpit view was more in the window. I can do that. and add another view to see the mfd

do you mean this. the black frames?



So on the KU. the deploy is really just swing the DEA unit out. THen the dish is rotated?
in the atlantis the dish rotate seems to be a part of deploy

Last edited by gattispilot; 12-08-2019 at 01:32 PM.
gattispilot is offline   Reply With Quote
Old 12-08-2019, 01:35 PM   #965
Marg
Orbinaut
Default

Quote:
do you mean this. the black frames?
Yes, I meant those black frames\lines around windows.
Marg is offline   Reply With Quote
Old 12-08-2019, 08:26 PM   #966
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Oh. I get this from the external view. But changing the VC will take a bit more.


---------- Post added at 02:26 PM ---------- Previous post was at 08:07 AM ----------

So I get this in the VC. But noticed something about the front. Looks like some of the window frame is missing?
gattispilot is offline   Reply With Quote
Thanked by:
Old 12-08-2019, 08:42 PM   #967
Marg
Orbinaut
Default

Missing? On the left? Isn't it hidden behind monitor\screen box.
By the way - upper windows have some seams\gaps, looking up from aft cockpit view (at them), where darker frame mesh meets the lighter "main" cockpit mesh. Is it worth fixing I do not know.
Marg is offline   Reply With Quote
Old 12-08-2019, 09:17 PM   #968
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

No in the front. Not sure if it is the vc mesh or external mesh


---------- Post added at 03:17 PM ---------- Previous post was at 03:05 PM ----------

The main mesh is doing it. I made the main mesh seen only external and it went away.

The issue is the external mesh and vc don't align up.
gattispilot is offline   Reply With Quote
Old 12-08-2019, 09:46 PM   #969
Marg
Orbinaut
Default

There is also small gap above the cockpit window in the middle... visible there in that pic, between red circles.
Marg is offline   Reply With Quote
Old 12-09-2019, 09:28 AM   #970
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

fixed that and the aft top. But not sure about the front part. The VC window frame match to the exterior frame.

Code:
mesh_orbiter = AddMesh(hOrbiterMesh);//mesh 1
	SetMeshVisibilityMode(mesh_orbiter, MESHVIS_EXTERNAL | MESHVIS_VC | MESHVIS_EXTPASS);
Weird. If I move the camera back a bit it look good. Like it is clipping

---------- Post added at 04:57 PM ---------- Previous post was at 04:31 PM ----------

So If the z camera is 13.9 cliping:

moved the camera back 13.6 and no issue:

I wonder if the setsize is correct?
Code:
SetSize (19.6);


---------- Post added 12-09-19 at 03:28 AM ---------- Previous post was 12-08-19 at 04:57 PM ----------

So try these meshes. just the original Columbia for now. If it is good. I will remake the rest.
New camera aft location.
the only thing not working is the ku band deployment.
https://drive.google.com/open?id=1Of...V3xQr9Xxac8iNz

Last edited by gattispilot; 12-08-2019 at 10:38 PM.
gattispilot is offline   Reply With Quote
Old 12-09-2019, 07:20 PM   #971
Marg
Orbinaut
Default

Hi, did a quick test.

1) Port side aft window outer black "frame" is flickering ("mesh overlapping"?).
2) Sitting in PLT seat front window, front window's left side very small gap (just a few points, when earth in background), i think between cockpit and main mesh.

3) Maybe aft cockpit camera a bit (20 cm) further from window, and just 3 cm lower:
0.45, 3.02, 12.48



P.S. interesting that wings have also gaps, when looking from behind (again Earth in background), elevons do not cover whole "thickness" of wings... but that's just an observation...

Umbilical doors - I almost lost them, no even seams visible only when opened they are still just a bit off the mesh (a couple of inches)...

Last edited by Marg; 12-09-2019 at 07:29 PM.
Marg is offline   Reply With Quote
Thanked by:
Old 12-09-2019, 07:38 PM   #972
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Thanks. Can you post an image of the gaps. I will move the aft camera.
gattispilot is offline   Reply With Quote
Old 12-09-2019, 09:00 PM   #973
Marg
Orbinaut
Default


I do not know why it does not appear, but "view image" works.

---------- Post added at 11:00 PM ---------- Previous post was at 10:53 PM ----------

BTW I saw SSME nozzles up high, but my animation somehow moved them more together (of course, group numbers and ANIM COMP numbers can be different), rotation axis for lower nozzles were not exactly x:
Code:
[ANIM_COMP_16]
; SSME1 stow
SEQ=7
GROUPS=16
RANGE=(0,1)
ROT_PNT=(0,2.445,-11.713)
ROT_AXIS=(1,0,0)
ANGLE=-11.6

[ANIM_COMP_17]
; SSME2 stow 
SEQ=7
GROUPS=15
RANGE=(0,1)
ROT_PNT=(-1.559,-0.327,-12.524)
ROT_AXIS=(-0.70710678,0.70710678,0)
ANGLE=-7.1

[ANIM_COMP_18]
; SSME3 stow
SEQ=7
GROUPS=14
RANGE=(0,1)
ROT_PNT=(1.559,-0.327,-12.524)
ROT_AXIS=(0.70710678,0.70710678,0)
ANGLE=7.1

Last edited by Marg; 12-09-2019 at 08:56 PM.
Marg is offline   Reply With Quote
Old 12-09-2019, 10:16 PM   #974
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Thanks. I fixed the wings. But can you screen shot the cockpit window issue. This"Sitting in PLT seat front window, front window's left side very small gap (just a few points, when earth in background), i think between cockpit and main mesh. "

I saw the aft window issue also.

for the ssmes. I have this:
Code:
// ***** 9. SSME pitch gimbal animations
	double init_gimbal = -10*RAD;
	float max_gimbal = (float)(-0.2*PI);
	anim_ssmes = CreateAnimation (init_gimbal/max_gimbal);

	static UINT SSMEL_Grp = GRP_SSMEL;
	ssme_anim[0] = new MGROUP_ROTATE (midx, &SSMEL_Grp, 1, _V(-1.55,-0.37,-12.5), _V(-1,0,0), max_gimbal);
	AddAnimationComponent (anim_ssmes, 0, 1, ssme_anim[0]);

	static UINT SSMER_Grp = GRP_SSMER;
	ssme_anim[1] = new MGROUP_ROTATE (midx, &SSMER_Grp, 1, _V( 1.55,-0.37,-12.5), _V(-1,0,0), max_gimbal);
	AddAnimationComponent (anim_ssmes, 0, 1, ssme_anim[1]);

	static UINT SSMET_Grp = GRP_SSMET;
	ssme_anim[2] = new MGROUP_ROTATE (midx, &SSMET_Grp, 1, _V(0.0,  2.7, -12.5), _V(-1,0,0), max_gimbal);
	AddAnimationComponent (anim_ssmes, 0, 1, ssme_anim[2]);
But this looks for Gimbal not stowing. When you they be stowed?



still clipping not sure how to fix except move the camera back?
gattispilot is offline   Reply With Quote
Old 12-09-2019, 10:32 PM   #975
Marg
Orbinaut
Default

I stowed in orbit after MECO, with specific animation command but honestly, I am not sure how it is in real life, I just saw in orbit photos (from ISS) and during landing that SSME's are closer together.


in first image - minor issue.
but in the second - there is a flicker looking form outside (part of aft window's black frame), and left red area actually significant gap between cabin's rear wall and "roof".
Marg is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Addons > Addon Requests


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 10:54 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.