Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Support & Bugs
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Addon Support & Bugs Support & bug reports for Orbiter addons.

Reply
 
Thread Tools
Old 03-14-2018, 11:16 AM   #1
gattispilot
Addon Developer
 
gattispilot's Avatar
Default Canadam2

So I have a simple vessel with a cfg and a mesh. I use attachment manager to attach the arm to the vessel. Exit and get a ctd.



Code:
; === Configuration file for vessel class ===
ClassName = logistic
MeshName = logisticmodule

Mass = 100
Size = 7

BEGIN_DOCKLIST
 0 0 4.697    0 0 1   0 -1 0
 0 0 -4.697    0 0 -1   0 -1 0
 2.127 0 -1.512    1 0 0   0 1 0
 -2.127 0 -1.512    -1 0 0   0 1 0
END_DOCKLIST

BEGIN_ATTACHMENT
C 0.0 2.271 -4.217  0 1 0  0 0 1  arm
END_ATTACHMENT

TouchdownPoints = 10 0 5  -10 0 5  0 10 5
here is a link to the vessel and scn.
https://drive.google.com/open?id=18H...sNYqQubO7TEpVb
gattispilot is offline   Reply With Quote
Old 03-14-2018, 01:37 PM   #2
Donamy
Beta Tester


Default

Where's SiameseCat when you need him ?
Donamy is offline   Reply With Quote
Thanked by:
Old 03-14-2018, 04:35 PM   #3
BrianJ
thing
Default

I don't use Attachment Manager, but it looks like you are trying to attach your "DSG_Logistic" vessel using it's Attachment Point Index 2 - but it only has one attachment point so it should be Index 0.
BrianJ is offline   Reply With Quote
Thanked by:
Old 03-14-2018, 04:46 PM   #4
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Thanks Yes the Logistic vessel has 1 parent attachment.
This is what the scn looks like after attaching:
Code:
DSG_Logistic:Logisticmodule
  STATUS Orbiting Earth
  RPOS 6711300.025 0.145 2017237.306
  RVEL -2171.2617 0.0002 7222.5227
  AROT -0.000 -18.601 180.000
  AFCMODE 7
  NAVFREQ 0 0
END
SSRMSD:SSRMSD
  STATUS Orbiting Earth
  RPOS 6711297.112 -19.336 2017233.837
  RVEL -2171.2617 0.0002 7222.5227
  AROT -90.000 -0.000 18.601
  ATTACHED 1:0,DSG_Logistic
  AFCMODE 7
  PRPLEVEL 0:1.000000
  NAVFREQ 0 0
  ARM_STATUS 0.000000 -2.002987 -0.925857 -180.178632 -91.102044 -5.282819 185.360109
  ACTIVE_LEE 1
  FOLDED 1 1.0000
  LIGHT
  ACTIVE_CAMERA 0
  CAM_STATUS 0.000000 0.000000 0.000000 0.000000
@SUBSYSTEM LEE1
@ENDSUBSYSTEM		;LEE1
@SUBSYSTEM LEE2
@ENDSUBSYSTEM		;LEE2
END
END_SHIPS

Last edited by gattispilot; 03-14-2018 at 04:48 PM.
gattispilot is offline   Reply With Quote
Old 03-17-2018, 03:59 PM   #5
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

So I made the attachment on the logistic module a child rather than a parent and still a ctd.

So I went back to PArent on the Module.

So if I attach 0:0 I get this but no CTD.
Code:
DSG_Logistic:Logisticmodule
  STATUS Orbiting Earth
  RPOS 6481820.842 0.161 2663897.980
  RVEL -2867.1964 0.0002 6975.5934
  AROT -0.000 -18.601 180.000
  AFCMODE 7
  NAVFREQ 0 0
END
SSRMSD:SSRMSD
  STATUS Orbiting Earth
  RPOS 6481818.655 -10.590 2663893.644
  RVEL -2867.1964 0.0002 6975.5934
  AROT -90.000 -0.000 18.601
  ATTACHED 0:0,DSG_Logistic
  AFCMODE 7
  PRPLEVEL 0:1.000000
  NAVFREQ 0 0
  ARM_STATUS 0.000000 -2.002987 -0.925857 -180.178632 -91.102044 -5.282819 185.360109
  ACTIVE_LEE 1
  FOLDED 1 1.0000
  LIGHT
  ACTIVE_CAMERA 0
  CAM_STATUS 0.000000 0.000000 0.000000 0.000000
@SUBSYSTEM LEE1
@ENDSUBSYSTEM		;LEE1
@SUBSYSTEM LEE2
@ENDSUBSYSTEM		;LEE2
END
END_SHIPS

But if I attach like this it looks good but a ctd.
Code:
BEGIN_SHIPS
DSG_Logistic:Logisticmodule
  STATUS Orbiting Earth
  RPOS 5737555.701 0.198 4023663.430
  RVEL -4330.5939 0.0002 6174.6871
  AROT -0.000 -18.601 180.000
  AFCMODE 7
  NAVFREQ 0 0
END
SSRMSD:SSRMSD
  STATUS Orbiting Earth
  RPOS 5737552.788 -19.283 4023659.961
  RVEL -4330.5939 0.0002 6174.6871
  AROT -90.000 -0.000 18.601
  ATTACHED 1:0,DSG_Logistic
  AFCMODE 7
  PRPLEVEL 0:1.000000
  NAVFREQ 0 0
  ARM_STATUS 0.000000 -2.002987 -0.925857 -180.178632 -91.102044 -5.282819 185.360109
  ACTIVE_LEE 1
  FOLDED 1 1.0000
  LIGHT
  ACTIVE_CAMERA 0
  CAM_STATUS 0.000000 0.000000 0.000000 0.000000
@SUBSYSTEM LEE1
@ENDSUBSYSTEM		;LEE1
@SUBSYSTEM LEE2
@ENDSUBSYSTEM		;LEE2
END
END_SHIPS
gattispilot is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Addons > Addon Support & Bugs


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 02:36 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.