Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Requests
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Addon Requests If you have a request for a new addon or want to know where to find a specific addon, ask it here!

Reply
 
Thread Tools
Old 01-17-2020, 07:32 PM   #1066
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Quote:
Originally Posted by Donamy View Post
 Which button, or is it no buttons ?
Sorry the only button I got to work is the on/off.
The row below no luck

---------- Post added at 01:32 PM ---------- Previous post was at 07:32 AM ----------

Yeah I got the buttons to work.


So the payload camera view can now be seen in the CCTV. RMS can't be though
gattispilot is offline   Reply With Quote
Thanked by:
Old 01-17-2020, 10:10 PM   #1067
Donamy
Beta Tester


Default

Sweet !!! but why not the RMS camera ? Is it because it is separate vessel?
Donamy is offline   Reply With Quote
Old 01-17-2020, 10:48 PM   #1068
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Because the CAM are set in the mfd and scn. So because the rms moves around the view can't follow it. Ideally the CCTV needs to be coded to allow the view to follow the rms and payload. Way above by pay scale
gattispilot is offline   Reply With Quote
Old 01-18-2020, 05:26 PM   #1069
Donamy
Beta Tester


Default

Hopefully someone who knows will chime in.

---------- Post added at 05:26 PM ---------- Previous post was at 02:17 AM ----------

Have you looked at the Canadarm2 code ? It has to remote cameras.
Donamy is offline   Reply With Quote
Thanked by:
Old 01-19-2020, 02:16 PM   #1070
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Quote:
Originally Posted by Donamy View Post
 Hopefully someone who knows will chime in.

---------- Post added at 05:26 PM ---------- Previous post was at 02:17 AM ----------

Have you looked at the Canadarm2 code ? It has to remote cameras.
We don't have that code. I have run into a weird issue with the camera MFD. When I press CAM on any MFD it adds a camera

---------- Post added 01-19-20 at 08:16 AM ---------- Previous post was 01-18-20 at 02:32 PM ----------

So got the CCTVs to be MFD so you can use CAMERA MFD. Not sure about getting the camera and rms hard coded into the mfd screen. So as the payload cameras move so does the view.
But I will add the animate the camera code back in.

Last edited by gattispilot; 01-19-2020 at 02:36 PM.
gattispilot is offline   Reply With Quote
Thanked by:
Old 01-19-2020, 06:28 PM   #1071
Donamy
Beta Tester


Default

Nice.
Donamy is offline   Reply With Quote
Thanked by:
Old 01-20-2020, 01:42 PM   #1072
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

So got the payload camera to tilt/rotate.
Saw this issue.
It was part of the old KU band. In the mesh it is id as a startracker?

Not sure what it should look like?

In the SSu it looks like nothing is there?
gattispilot is offline   Reply With Quote
Old 01-20-2020, 06:57 PM   #1073
Donamy
Beta Tester


Default

Looks like part of the old KU base. I'd delete it.
Donamy is offline   Reply With Quote
Thanked by:
Old 01-21-2020, 01:22 PM   #1074
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Quote:
Originally Posted by Donamy View Post
 Looks like part of the old KU base. I'd delete it.
Thought so. So now back to anim8or to remove that from all the shuttle meshes.
gattispilot is offline   Reply With Quote
Old 01-22-2020, 02:04 PM   #1075
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

So since I need to edit the payload bay. I was looking at SSU. So it looks like the SSU payload bay has actual structures and sf used a texture.


I think these are the same thing?

SF

SSU


One thing ZI noticed the distance of the top is the same as structure while SSu top rail seem lower?
SF


SSU


For now I may just keep the payload as is minus that KU base
gattispilot is offline   Reply With Quote
Old 01-22-2020, 02:22 PM   #1076
4throck
Enthusiast !
 
4throck's Avatar
Default

Quote:
Originally Posted by gattispilot View Post
 Thought so. So now back to anim8or to remove that from all the shuttle meshes.
This is why using multiple meshes for different parts can be useful. Less things to change
4throck is offline   Reply With Quote
Thanked by:
Old 01-23-2020, 11:58 AM   #1077
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Quote:
Originally Posted by 4throck View Post
 This is why using multiple meshes for different parts can be useful. Less things to change
Yes. But then you have to keep track of the index

For now I may just keep it as is. Minus that part.

I thought about about the textures where the bars are to remove them as they are structures.

Maybe on the next version?

---------- Post added 01-23-20 at 05:58 AM ---------- Previous post was 01-22-20 at 09:02 AM ----------

So now I get this:





This is sts 107. May need to redo the the SpaceLabmesh.

So how would the astronaunts get outside into space with the spacelab over the airlock?

http://www.spacefacts.de/graph/drawi...07_payload.htm

this image shows more of an airlock there?

Last edited by gattispilot; 01-23-2020 at 01:31 PM.
gattispilot is offline   Reply With Quote
Old 01-23-2020, 05:16 PM   #1078
Donamy
Beta Tester


Default

The SSU has the tunnel adapter.
Donamy is offline   Reply With Quote
Old 01-24-2020, 11:47 AM   #1079
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Thanks. I am getting educated. There was space Hab and space lab. But for now I need to get the base shuttle to work.

---------- Post added 01-24-20 at 05:47 AM ---------- Previous post was 01-23-20 at 11:55 AM ----------

So have updated the mesh of the 3 Columbia. But have run into 2 issues. On load when the cargobay doors are open the right side is closed. I press K and it goes to the open position and starts to close. So something is now right with the load code?

2nd is sometimes I get a CTD in d3D9 noting tin the log
gattispilot is offline   Reply With Quote
Old 01-29-2020, 11:29 AM   #1080
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

So getting closer. But noticed something. I now the external airlock and ODs bridge rails are a bit high. But it looks like the rms support might be hitting the bridges?

Moonraker with burnt ET



---------- Post added at 07:43 AM ---------- Previous post was at 05:34 AM ----------

So on the rms. The bridge rail of the External airlock is hitting the mpm structure.
So not sure if the MPm structure needs to move or the what?

I think my bridge fitting may be too wide?

I think I can do this. The red and blue part would rotate as the doors open. The green rod would translate up/down as the red/blue part move.
The yellow is the outline of the shuttle wall and sill.





And only 6 of these per side


---------- Post added 01-29-20 at 05:29 AM ---------- Previous post was 01-28-20 at 07:43 AM ----------

So I can get this:




redo radiators so bottom is at red line.
like this?


So the rms is in the wrong location. I will just move the mesh in code then the animation will be good. It needs to be closer to the outside wall
the green one is where it is now:



I also removed the KU band Antenna. I will make it default to be seen. But if a mission didn't have it then add KU to the scn and it will not be seen

Last edited by gattispilot; 01-29-2020 at 01:31 PM.
gattispilot is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Addons > Addon Requests


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 10:31 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.