Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Support & Bugs > Addon Developer Forums > Project Apollo - NASSP
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Project Apollo - NASSP Development, support and news for Project Apollo.

Reply
 
Thread Tools
Old 11-07-2019, 07:32 PM   #1
ThatRedMelon
Orbinaut
Question Lag on Contact with Lunar Surface

Hello,
Whenever I try and land my lunar module of any Apollo pre made mission, the PDI from P63-P66 works perfectly. However, at the end of P66 about 1 second before the lunar conctact light illuminates, my game lags to about 1 frame per second and seemingly doesn't stop until I painstakingly switch to P68. Due to switching to P68 seeming to fix it although I am not sure, is the lag due to Virtual AGC being provided with too much computational demand and my CPU cannot handle it?
Many thanks.

Last edited by ThatRedMelon; 11-07-2019 at 07:39 PM.
ThatRedMelon is offline   Reply With Quote
Old 11-08-2019, 09:24 AM   #2
Thymo
AGC nerd
Default

Virtual AGC uses a fixed memory cycle of 11.7us. So the load on your actual machine should be about to same no matter what program is running.

The only issue I can think of related to the AGC (and this is a long shot) is some issue with the counters getting continuously updated when RCS is trying to hold attitude on touch down, but I'm not completely familiar with how those are implemented. I doubt it suddenly causes an issue though.
Thymo is offline   Reply With Quote
Old 11-08-2019, 11:07 AM   #3
meik84
Orbinaut
Default

Hm. From time to time I have the issue that during bigger events (staging, LV sep, liftoff...) the sim slows down to almost halt. Maybe this is related to that. I don't think that the LGC is the culprit here. The computational load in P66 is a lot lower than in P64, so when something in that relation should happen, it has to happen in P64.
meik84 is offline   Reply With Quote
Old 11-08-2019, 11:28 PM   #4
ThatRedMelon
Orbinaut
Default

I have checked in spot view during lunar landing and the lag seems to occur the exact time the sensor legs touch the surface. I then assume the problem to be with collision detection however the lag also occurs during separation between stages. This could be an issue of a collision between the ascent and descent stages but I am not sure.
ThatRedMelon is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Addons > Addon Support & Bugs > Addon Developer Forums > Project Apollo - NASSP

Tags
agc, lag, lunar surface


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 07:59 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.