Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Support & Bugs > Addon Developer Forums > Project Apollo - NASSP
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Project Apollo - NASSP Development, support and news for Project Apollo.

Reply
 
Thread Tools
Old 08-10-2018, 07:56 AM   #1
tcirre93
Orbinaut
Default Aspect ratio / panel issue

I am having an issue with the LM panel. The center panel displays as a single large image. Any panel text is small and hard to read. If I switch the view to a side panel and switch back, the background of the panel appears black. The actual switches display properly in front of this background. In previous versions the panel itself is displayed larger and one can scroll around a bit.

I am using a 4K monitor and have tried a bunch of different resolutions. I am using D3DX9. What display settings does everyone else use? Could this be an issue with 16:9 monitor at high resolution?

Any help would be appreciated.

Thank You
tcirre93 is offline   Reply With Quote
Old 08-10-2018, 04:57 PM   #2
jalexb88
Orbinaut
Default

Hello,

I have this same issue when using my UHD monitor with Orbiter. I think the problem is windows 10 scales applications when using True Full Screen mode and then it is almost impossible to revert the scaling. My solution was to only select window display modes in the Orbiter video options. If you want a Full screen mode then select "Full Screen Window" and not "True Full Screen" because once you select True Full Screen and run Orbiter, then windows does the scaling change to the application. The only way I have found to revert this is to change the Orbiter directory folder name to something different as windows 10 seems to then forget the scaling changes in this case.

This is what fixed mine:

1. If your Orbiter directory is C:/Orbiter then change it to C:/Orbiter1 or whatever you want.

2. Do not select True Full Screen in Orbiter options.

Hope that helps!
jalexb88 is offline   Reply With Quote
Old 08-10-2018, 05:14 PM   #3
francisdrake
Addon Developer
Default

Win 10 has a setting for high DPI-settings. Disabling it may help.

Right-click on the Orbiter icon.
- Properties
- Compatibility settings
- High DPI settings (or so ...) --> Dialog box
Disable the settings,
Use "Behaviour at high DPI-settings": Let application decide.
(Sorry, my PC is non-english, the wording may be different).

This helped for me. Maybe play around with some settings here.
francisdrake is offline   Reply With Quote
Old 08-10-2018, 11:50 PM   #4
tcirre93
Orbinaut
Default

Disabling the DPI settings fixed the issue in true full screen. The windowed mode, however, still displays incorrectly.

As for the flashing, I noticed it on the surface MFD in both my NASSP install and my clean install. It disappears when using the directx 7 version.

As I have narrowed the issue down to D3D9, I have created a thread in the appropriate forum.

Thanks to everyone for your help!
tcirre93 is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Addons > Addon Support & Bugs > Addon Developer Forums > Project Apollo - NASSP


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 05:08 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.